summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-04-05 14:46:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-04-05 14:46:14 +0000
commit0987ee15a62415e3e2b139740ce318fd96c8281d (patch)
tree35d320a05ebf6a4b20d816489b666ef0d536cd9c /media-libs
parentProposed enhancement from Arfrever included part 2 (diff)
downloadgentoo-2-0987ee15a62415e3e2b139740ce318fd96c8281d.tar.gz
gentoo-2-0987ee15a62415e3e2b139740ce318fd96c8281d.tar.bz2
gentoo-2-0987ee15a62415e3e2b139740ce318fd96c8281d.zip
Version bump wrt #313011 by Lars Wendler.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libogg/ChangeLog9
-rw-r--r--media-libs/libogg/libogg-1.2.0.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/media-libs/libogg/ChangeLog b/media-libs/libogg/ChangeLog
index 84c52197097d..40055b259538 100644
--- a/media-libs/libogg/ChangeLog
+++ b/media-libs/libogg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libogg
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libogg/ChangeLog,v 1.63 2009/12/03 17:36:30 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libogg/ChangeLog,v 1.64 2010/04/05 14:46:14 ssuominen Exp $
+
+*libogg-1.2.0 (05 Apr 2010)
+
+ 05 Apr 2010; Samuli Suominen <ssuominen@gentoo.org> +libogg-1.2.0.ebuild:
+ Version bump wrt #313011 by Lars Wendler.
03 Dec 2009; Raúl Porcel <armin76@gentoo.org> libogg-1.1.4.ebuild:
ia64/sh/sparc stable wrt #288042
diff --git a/media-libs/libogg/libogg-1.2.0.ebuild b/media-libs/libogg/libogg-1.2.0.ebuild
new file mode 100644
index 000000000000..b1419bce4de5
--- /dev/null
+++ b/media-libs/libogg/libogg-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libogg/libogg-1.2.0.ebuild,v 1.1 2010/04/05 14:46:14 ssuominen Exp $
+
+EAPI=2
+inherit eutils libtool
+
+DESCRIPTION="the Ogg media file format library"
+HOMEPAGE="http://xiph.org/ogg/"
+SRC_URI="http://downloads.xiph.org/releases/ogg/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static-libs"
+
+src_prepare() {
+ elibtoolize
+ epunt_cxx
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS CHANGES
+ find "${D}" -name '*.la' -delete
+}