summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-08-24 06:15:11 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-08-24 06:15:11 +0000
commit2d0c67bfb8a675a150bd925c8a3138d04370f423 (patch)
tree902ba703c6d728f94bf88ea73fbc58d7c71b40c7 /media-libs
parentteTeX issues being covered up. Will be unmasked when work is completed on the (diff)
downloadgentoo-2-2d0c67bfb8a675a150bd925c8a3138d04370f423.tar.gz
gentoo-2-2d0c67bfb8a675a150bd925c8a3138d04370f423.tar.bz2
gentoo-2-2d0c67bfb8a675a150bd925c8a3138d04370f423.zip
resiolves bug #6840 for gcc3,2 compat and version bump
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/id3lib/ChangeLog11
-rw-r--r--media-libs/id3lib/files/digest-id3lib-3.8.01
-rw-r--r--media-libs/id3lib/files/id3lib-3.8.0-gcc3.patch97
-rw-r--r--media-libs/id3lib/id3lib-3.8.0.ebuild50
4 files changed, 158 insertions, 1 deletions
diff --git a/media-libs/id3lib/ChangeLog b/media-libs/id3lib/ChangeLog
index 23e815883159..7c769fbe6ce8 100644
--- a/media-libs/id3lib/ChangeLog
+++ b/media-libs/id3lib/ChangeLog
@@ -1,7 +1,16 @@
# ChangeLog for media-libs/id3lib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/id3lib/ChangeLog,v 1.3 2002/06/07 03:25:45 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/id3lib/ChangeLog,v 1.4 2002/08/24 06:15:11 mkennedy Exp $
+*id3lib-3.8.0 (23 Aug 2002)
+
+ 23 Aug 2002; Matthew Kennedy <mkennedy@gentoo.org>
+ id3lib-3.8.0.ebuild, ChangeLog, files/digest-id3lib-3.8.0 :
+
+ Version bump. Removed azarah's patch for _pre2 (doesn't seem to be
+ necessary for gcc3.2), added the following for 3.8.0 from Michael Best
+ <gentoo@pendragon.org> for gcc3.2 compatibility (Bug #6840)
+
*id3lib-3.8.0_pre2-r3 (6 Jun 2002)
6 Jun 2002; Brandon Low <lostlogic@lostlogicx.com> id3lib-3.8.0_pre2-r3.ebuild :
diff --git a/media-libs/id3lib/files/digest-id3lib-3.8.0 b/media-libs/id3lib/files/digest-id3lib-3.8.0
new file mode 100644
index 000000000000..998cc67f8b02
--- /dev/null
+++ b/media-libs/id3lib/files/digest-id3lib-3.8.0
@@ -0,0 +1 @@
+MD5 9d5947e2c25c846b03faadfb8c6e8601 id3lib-3.8.0.tar.gz 934333
diff --git a/media-libs/id3lib/files/id3lib-3.8.0-gcc3.patch b/media-libs/id3lib/files/id3lib-3.8.0-gcc3.patch
new file mode 100644
index 000000000000..12c8bc5ab37a
--- /dev/null
+++ b/media-libs/id3lib/files/id3lib-3.8.0-gcc3.patch
@@ -0,0 +1,97 @@
+--- include/id3/id3lib_strings.h.orig 2002-08-21 16:41:11.000000000 -0600
++++ include/id3/id3lib_strings.h 2002-08-21 16:40:32.000000000 -0600
+@@ -30,6 +30,94 @@
+
+ #include <string>
+
++#if (defined(__GNUC__) && (__GNUC__ >= 3) || (defined(_MSC_VER) && _MSC_VER > 1000))
++namespace std
++{
++ template<>
++ struct char_traits<unsigned char>
++ {
++ typedef unsigned char char_type;
++ // Unsigned as wint_t in unsigned.
++ typedef unsigned long int_type;
++ typedef streampos pos_type;
++ typedef streamoff off_type;
++ typedef mbstate_t state_type;
++
++ static void
++ assign(char_type& __c1, const char_type& __c2)
++ { __c1 = __c2; }
++
++ static bool
++ eq(const char_type& __c1, const char_type& __c2)
++ { return __c1 == __c2; }
++
++ static bool
++ lt(const char_type& __c1, const char_type& __c2)
++ { return __c1 < __c2; }
++
++ static int
++ compare(const char_type* __s1, const char_type* __s2, size_t __n)
++ {
++ for (size_t __i = 0; __i < __n; ++__i)
++ if (!eq(__s1[__i], __s2[__i]))
++ return lt(__s1[__i], __s2[__i]) ? -1 : 1;
++ return 0;
++ }
++
++ static size_t
++ length(const char_type* __s)
++ {
++ const char_type* __p = __s;
++ while (__p)
++ ++__p;
++ return (__p - __s);
++ }
++
++ static const char_type*
++ find(const char_type* __s, size_t __n, const char_type& __a)
++ {
++ for (const char_type* __p = __s; size_t(__p - __s) < __n; ++__p)
++ if (*__p == __a) return __p;
++ return 0;
++ }
++
++ static char_type*
++ move(char_type* __s1, const char_type* __s2, size_t __n)
++ { return (char_type*) memmove(__s1, __s2, __n * sizeof(char_type)); }
++
++ static char_type*
++ copy(char_type* __s1, const char_type* __s2, size_t __n)
++ { return (char_type*) memcpy(__s1, __s2, __n * sizeof(char_type)); }
++
++ static char_type*
++ assign(char_type* __s, size_t __n, char_type __a)
++ {
++ for (char_type* __p = __s; __p < __s + __n; ++__p)
++ assign(*__p, __a);
++ return __s;
++ }
++
++ static char_type
++ to_char_type(const int_type& __c)
++ { return char_type(); }
++
++ static int_type
++ to_int_type(const char_type& __c) { return int_type(); }
++
++ static bool
++ eq_int_type(const int_type& __c1, const int_type& __c2)
++ { return __c1 == __c2; }
++
++ static int_type
++ eof() { return static_cast<int_type>(-1); }
++
++ static int_type
++ not_eof(const int_type& __c)
++ { return eq_int_type(__c, eof()) ? int_type(0) : __c; }
++ };
++} // namespace std
++#endif
++
+ namespace dami
+ {
+ typedef std::basic_string<char> String;
diff --git a/media-libs/id3lib/id3lib-3.8.0.ebuild b/media-libs/id3lib/id3lib-3.8.0.ebuild
new file mode 100644
index 000000000000..e38fd1922178
--- /dev/null
+++ b/media-libs/id3lib/id3lib-3.8.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/id3lib/id3lib-3.8.0.ebuild,v 1.1 2002/08/24 06:15:11 mkennedy Exp $
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Id3 library for C/C++"
+SRC_URI="mirror://sourceforge/id3lib/${MY_P}.tar.gz"
+HOMEPAGE="http://id3lib.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ if [ "`gcc --version | cut -f1 -d.`" -eq 3 ] ||
+ ([ -n "${CXX}" ] && [ "`${CXX} --version | cut -f1 -d.`" -eq 3 ]) ||
+ [ "`gcc --version|grep gcc|cut -f1 -d.|cut -f3 -d\ `" -eq 3 ]
+ then
+ cd ${S}
+ # Removed azarah's patch for _pre2 (doesn't seem to be
+ # necessary for gcc3.2), added the following for 3.8.0 from
+ # Michael Best <gentoo@pendragon.org> (Bug #6840)
+ patch -p0 <${FILESDIR}/${P}-gcc3.patch || die
+ fi
+}
+
+src_compile() {
+
+ export CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog HISTORY INSTALL README THANKS TODO
+# some example programs to be placed in docs dir.
+ make clean
+ cp -a examples ${D}/usr/share/doc/${PF}/examples
+}