summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-12-22 20:46:21 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-12-22 20:46:21 +0000
commit36897c172ead4be71db4f4a66a233b31e4168034 (patch)
tree29685063fd05ff34d1ad038c43a7ad912e3bf785 /media-libs
parentAdd tcl8.5 patch (stupid configure script). Respect LDFLAGS. Call epatch jus... (diff)
downloadgentoo-2-36897c172ead4be71db4f4a66a233b31e4168034.tar.gz
gentoo-2-36897c172ead4be71db4f4a66a233b31e4168034.tar.bz2
gentoo-2-36897c172ead4be71db4f4a66a233b31e4168034.zip
Sync with in-overlay updates prepared for 7.7 final release.
(Portage version: 2.2_rc60/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/ChangeLog5
-rw-r--r--media-libs/mesa/mesa-7.7.ebuild75
2 files changed, 32 insertions, 48 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 741607ac81d7..435353966f2f 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.250 2009/12/22 13:54:59 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.251 2009/12/22 20:46:21 scarabeus Exp $
+
+ 22 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org> mesa-7.7.ebuild:
+ Sync with in-overlay updates prepared for 7.7 final release.
22 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
-mesa-7.6.1_rc4.ebuild, -mesa-7.7_rc3.ebuild:
diff --git a/media-libs/mesa/mesa-7.7.ebuild b/media-libs/mesa/mesa-7.7.ebuild
index 64ccf01f0c26..a8b1abf6ce36 100644
--- a/media-libs/mesa/mesa-7.7.ebuild
+++ b/media-libs/mesa/mesa-7.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.7.ebuild,v 1.1 2009/12/22 13:50:33 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.7.ebuild,v 1.2 2009/12/22 20:46:21 scarabeus Exp $
EAPI="2"
@@ -9,7 +9,6 @@ EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/mesa"
if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git"
EXPERIMENTAL="true"
- IUSE_VIDEO_CARDS_UNSTABLE="video_cards_nouveau"
fi
inherit autotools multilib flag-o-matic ${GIT_ECLASS} portability
@@ -17,7 +16,7 @@ inherit autotools multilib flag-o-matic ${GIT_ECLASS} portability
OPENGL_DIR="xorg-x11"
MY_PN="${PN/m/M}"
-MY_P="${MY_PN}-${PV/_*}"
+MY_P="${MY_PN}-${PV/_/-}"
MY_SRC_P="${MY_PN}Lib-${PV/_/-}"
DESCRIPTION="OpenGL-like graphic library for Linux"
HOMEPAGE="http://mesa3d.sourceforge.net/"
@@ -34,21 +33,13 @@ LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE_VIDEO_CARDS="${IUSE_VIDEO_CARDS_UNSTABLE}
- video_cards_intel
- video_cards_mach64
- video_cards_mga
- video_cards_none
- video_cards_r128
- video_cards_radeon
- video_cards_radeonhd
- video_cards_savage
- video_cards_sis
- video_cards_sunffb
- video_cards_tdfx
- video_cards_via"
+VIDEO_CARDS="intel mach64 mga none nouveau r128 radeon radeonhd savage sis sunffb svga tdfx via"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
IUSE="${IUSE_VIDEO_CARDS}
- debug gallium motif +nptl pic +xcb kernel_FreeBSD"
+ debug +gallium motif +nptl pic selinux +xcb kernel_FreeBSD"
# keep correct libdrm and dri2proto dep
# keep blocks in rdepend for binpkg
@@ -128,45 +119,35 @@ src_configure() {
driver_enable video_cards_tdfx tdfx
driver_enable video_cards_via unichrome
- # all live (experimental) stuff is wrapped around with experimental variable
- # so the users cant get to this parts even with enabled useflags (downgrade
- # from live to stable for example)
- if [[ -n ${EXPERIMENTAL} ]]; then
- # nouveau works only with gallium
- use gallium && myconf="${myconf} $(use_enable video_cards_nouveau gallium-nouveau)"
- if use video_cards_nouveau && ! use gallium ; then
- elog "Nouveau driver is available only via gallium interface."
- elog "Enable gallium useflag if you want to use nouveau."
- echo
- fi
- fi
-
myconf="${myconf} $(use_enable gallium)"
if use gallium; then
- elog "Warning gallium interface is highly experimental so use"
- elog "it only if you feel really really brave."
- elog
- elog "Intel: works only i915."
- elog "Nouveau: only available implementation, so no other choice"
- elog "Radeon: implementation up to the r500."
+ elog "You have enabled gallium infrastructure."
+ elog "This infrastructure currently support these drivers:"
+ elog " Intel: works only i915."
+ elog " Nouveau: only available implementation, so no other choice"
+ elog " Radeon: implementation up to the r500."
+ elog " Svga: VMWare Virtual GPU driver."
echo
myconf="${myconf}
--with-state-trackers=glx,dri,egl,xorg
+ $(use_enable video_cards_svga gallium-svga)
$(use_enable video_cards_nouveau gallium-nouveau)
$(use_enable video_cards_intel gallium-intel)"
- if ! use video_cards_radeon && ! use video_cards_radeonhd; then
- myconf="${myconf} --disable-gallium-radeon"
- else
+ if use video_cards_radeon || use video_cards_radeonhd; then
myconf="${myconf} --enable-gallium-radeon"
+ else
+ myconf="${myconf} --disable-gallium-radeon"
+ fi
+ else
+ if use video_cards_nouveau || use video_cards_svga; then
+ elog "SVGA and nouveau drivers are available only via gallium interface."
+ elog "Enable gallium useflag if you want to use them."
fi
fi
- # Deactivate assembly code for pic build
- myconf="${myconf} $(use_enable !pic asm)"
-
- # --with-driver=dri|xlib|osmesa ; might get changed later to something
- # else than dri
+ # --with-driver=dri|xlib|osmesa || do we need osmesa?
econf \
+ --disable-option-checking \
--with-driver=dri \
--disable-glut \
--without-demos \
@@ -175,7 +156,7 @@ src_configure() {
$(use_enable motif) \
$(use_enable nptl glx-tls) \
$(use_enable xcb) \
- --disable-gallium-svga \
+ $(use_enable !pic asm) \
--with-dri-drivers=${DRI_DRIVERS} \
${myconf}
}
@@ -223,13 +204,13 @@ driver_enable() {
case $# in
# for enabling unconditionally
1)
- DRI_DRIVERS="${DRI_DRIVERS},$1"
+ DRI_DRIVERS+=",$1"
;;
*)
if use $1; then
shift
for i in $@; do
- DRI_DRIVERS="${DRI_DRIVERS},${i}"
+ DRI_DRIVERS+=",${i}"
done
fi
;;