summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-01 11:52:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-01 11:52:28 +0000
commit4313e981c2dc3fc426104b82742db4e891d29dca (patch)
treea057379f0bf4de0b2d779caf9c17c7f43bba031b /media-libs
parentStable for ppc, wrt to bug #466074 (diff)
downloadgentoo-2-4313e981c2dc3fc426104b82742db4e891d29dca.tar.gz
gentoo-2-4313e981c2dc3fc426104b82742db4e891d29dca.tar.bz2
gentoo-2-4313e981c2dc3fc426104b82742db4e891d29dca.zip
Version bump.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alsa-lib/ChangeLog7
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.27.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 7d4bbc968f96..a0ba4f3b5e9b 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.349 2013/04/25 06:01:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.350 2013/05/01 11:52:28 ssuominen Exp $
+
+*alsa-lib-1.0.27 (01 May 2013)
+
+ 01 May 2013; Samuli Suominen <ssuominen@gentoo.org> +alsa-lib-1.0.27.ebuild:
+ Version bump.
25 Apr 2013; Samuli Suominen <ssuominen@gentoo.org>
alsa-lib-1.0.26-r2.ebuild:
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.27.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.27.ebuild
new file mode 100644
index 000000000000..075bf0662a68
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.27.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.27.ebuild,v 1.1 2013/05/01 11:52:28 ssuominen Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils multilib python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc debug alisp python"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ >=media-sound/alsa-headers-1.0.25-r1
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.0.25-extraneous-cflags.diff
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.in || die #466980
+ eautoreconf
+ # if eautoreconf'd with recent autoconf, then epunt_cxx is
+ # unncessary wrt #460974
+# epunt_cxx
+}
+
+src_configure() {
+ local myconf
+ use elibc_uclibc && myconf="--without-versioned"
+
+ econf \
+ --enable-shared \
+ --disable-resmgr \
+ --enable-rawmidi \
+ --enable-seq \
+ --enable-aload \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ $(use_enable python) \
+ ${myconf}
+}
+
+src_compile() {
+ emake
+
+ if use doc; then
+ emake doc
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ prune_libtool_files --all
+ find "${ED}"/usr/$(get_libdir)/alsa-lib -name '*.a' -exec rm -f {} +
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}