summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-10-23 08:18:41 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-10-23 08:18:41 +0000
commit4cf6bc83e0717068c11edc75590983f15eb7b252 (patch)
tree0e11ddd59d183cf148efaabaf156aeecfcd7d23a /media-libs
parent(non-maintainer commit) Backport patch that allows build system to properly d... (diff)
downloadgentoo-2-4cf6bc83e0717068c11edc75590983f15eb7b252.tar.gz
gentoo-2-4cf6bc83e0717068c11edc75590983f15eb7b252.tar.bz2
gentoo-2-4cf6bc83e0717068c11edc75590983f15eb7b252.zip
Add latest version.
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libvisio/ChangeLog7
-rw-r--r--media-libs/libvisio/libvisio-0.0.9.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/media-libs/libvisio/ChangeLog b/media-libs/libvisio/ChangeLog
index b30a80b25c83..cda19ac0cd6f 100644
--- a/media-libs/libvisio/ChangeLog
+++ b/media-libs/libvisio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libvisio
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisio/ChangeLog,v 1.7 2011/10/04 14:58:19 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisio/ChangeLog,v 1.8 2011/10/23 08:18:41 scarabeus Exp $
+
+*libvisio-0.0.9 (23 Oct 2011)
+
+ 23 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org> +libvisio-0.0.9.ebuild:
+ Add latest version.
*libvisio-0.0.8 (04 Oct 2011)
diff --git a/media-libs/libvisio/libvisio-0.0.9.ebuild b/media-libs/libvisio/libvisio-0.0.9.ebuild
new file mode 100644
index 000000000000..ae830f0c217b
--- /dev/null
+++ b/media-libs/libvisio/libvisio-0.0.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisio/libvisio-0.0.9.ebuild,v 1.1 2011/10/23 08:18:41 scarabeus Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/contrib/libvisio/"
+[[ ${PV} == 9999 ]] && vcs="autotools git-2"
+inherit base ${vcs}
+unset vcs
+
+DESCRIPTION="Library parsing the visio documents"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libvisio"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.9
+ app-text/libwpg:0.2
+"
+DEPEND="${DEPEND}
+ sys-devel/libtool
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ base_src_prepare
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}