summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2010-12-22 12:41:00 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2010-12-22 12:41:00 +0000
commit5395f8487c82be623674d6b215a29dcb6ed8eca4 (patch)
tree853ba72d3d3c23e08444e178335afc2a288aa7dd /media-libs
parentFix the gconf key type (it's a bool, not a string) for /apps/gnome_settings_d... (diff)
downloadgentoo-2-5395f8487c82be623674d6b215a29dcb6ed8eca4.tar.gz
gentoo-2-5395f8487c82be623674d6b215a29dcb6ed8eca4.tar.bz2
gentoo-2-5395f8487c82be623674d6b215a29dcb6ed8eca4.zip
Verify and potentially improve Python-related code, #313257
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/hamlib/ChangeLog7
-rw-r--r--media-libs/hamlib/hamlib-1.2.12-r2.ebuild91
2 files changed, 97 insertions, 1 deletions
diff --git a/media-libs/hamlib/ChangeLog b/media-libs/hamlib/ChangeLog
index c22f6e41dca7..203dca8ffee3 100644
--- a/media-libs/hamlib/ChangeLog
+++ b/media-libs/hamlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/hamlib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.52 2010/12/21 19:56:13 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.53 2010/12/22 12:41:00 tomjbe Exp $
+
+*hamlib-1.2.12-r2 (22 Dec 2010)
+
+ 22 Dec 2010; Thomas Beierlein <tomjbe@gentoo.org> +hamlib-1.2.12-r2.ebuild:
+ Verify and potentially improve Python-related code, #313257
*hamlib-1.2.12-r1 (21 Dec 2010)
diff --git a/media-libs/hamlib/hamlib-1.2.12-r2.ebuild b/media-libs/hamlib/hamlib-1.2.12-r2.ebuild
new file mode 100644
index 000000000000..a49be8fb70b8
--- /dev/null
+++ b/media-libs/hamlib/hamlib-1.2.12-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.12-r2.ebuild,v 1.1 2010/12/22 12:41:00 tomjbe Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit autotools-utils eutils multilib python
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="http://sourceforge.net/apps/mediawiki/hamlib"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc python tcl"
+
+RESTRICT="test"
+
+RDEPEND="
+ =virtual/libusb-0*
+ dev-libs/libxml2
+ python? ( <dev-lang/python-3 )
+ tcl? ( dev-lang/tcl )"
+
+DEPEND=" ${RDEPEND}
+ dev-util/pkgconfig
+ dev-lang/swig
+ >=sys-devel/libtool-2.2
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # fix hardcoded libdir paths
+ sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
+ -e "s#fix}/include#fix}/include/hamlib#" \
+ hamlib.pc.in || die "sed failed"
+
+ # fix tcl lib path
+ epatch "${FILESDIR}"/${PN}-1.2.11-bindings.diff
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)/hamlib \
+ --disable-static \
+ --with-rpc-backends \
+ --without-perl-binding \
+ $(use_with python python-binding) \
+ $(use_enable tcl tcl-binding)
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use doc ; then
+ cd doc && make doc || die "make doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ remove_libtool_files all
+
+ dodoc AUTHORS NEWS PLAN README README.betatester \
+ README.developer TODO || die "dodoc failed"
+
+ if use doc; then
+ dohtml doc/html/* || die "dohtml failed"
+ fi
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins hamlib.pc || die "doins failed"
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib || die "doenvd failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)
+}