summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-07-11 16:14:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-07-11 16:14:44 +0000
commit8687af3e75c5433c655e0245263ce7803280ea6d (patch)
tree51cb61f0a60828e09c21978612a2f30e3cc675c0 /media-libs
parentversion bump, port to rubberband 1.2 api, dont ignore cxxflags, fix build wit... (diff)
downloadgentoo-2-8687af3e75c5433c655e0245263ce7803280ea6d.tar.gz
gentoo-2-8687af3e75c5433c655e0245263ce7803280ea6d.tar.bz2
gentoo-2-8687af3e75c5433c655e0245263ce7803280ea6d.zip
version bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.7 x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/rubberband/ChangeLog8
-rw-r--r--media-libs/rubberband/files/rubberband-1.2-gcc43.patch12
-rw-r--r--media-libs/rubberband/rubberband-1.2.ebuild40
3 files changed, 59 insertions, 1 deletions
diff --git a/media-libs/rubberband/ChangeLog b/media-libs/rubberband/ChangeLog
index b7510129cd2f..0462098dcfe4 100644
--- a/media-libs/rubberband/ChangeLog
+++ b/media-libs/rubberband/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/rubberband
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/ChangeLog,v 1.5 2008/05/15 10:33:17 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/ChangeLog,v 1.6 2008/07/11 16:14:43 aballier Exp $
+
+*rubberband-1.2 (11 Jul 2008)
+
+ 11 Jul 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/rubberband-1.2-gcc43.patch, +rubberband-1.2.ebuild:
+ version bump
15 May 2008; Markus Rothe <corsair@gentoo.org> rubberband-1.0.1.ebuild:
Added ~ppc; bug #215033
diff --git a/media-libs/rubberband/files/rubberband-1.2-gcc43.patch b/media-libs/rubberband/files/rubberband-1.2-gcc43.patch
new file mode 100644
index 000000000000..eafa0924e12c
--- /dev/null
+++ b/media-libs/rubberband/files/rubberband-1.2-gcc43.patch
@@ -0,0 +1,12 @@
+Index: rubberband-1.2/src/sysutils.cpp
+===================================================================
+--- rubberband-1.2.orig/src/sysutils.cpp
++++ rubberband-1.2/src/sysutils.cpp
+@@ -26,6 +26,7 @@
+ #endif /* !_WIN32 */
+
+ #include <iostream>
++#include <cstdlib>
+
+
+ namespace RubberBand {
diff --git a/media-libs/rubberband/rubberband-1.2.ebuild b/media-libs/rubberband/rubberband-1.2.ebuild
new file mode 100644
index 000000000000..60526d4da38b
--- /dev/null
+++ b/media-libs/rubberband/rubberband-1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/rubberband-1.2.ebuild,v 1.1 2008/07/11 16:14:43 aballier Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
+HOMEPAGE="http://www.breakfastquay.com/rubberband/"
+SRC_URI="http://www.breakfastquay.com/rubberband/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/vamp-plugin-sdk
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ media-libs/ladspa-sdk
+ =sci-libs/fftw-3*"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_install() {
+ emake INSTALL_BINDIR="${D}/usr/bin" \
+ INSTALL_INCDIR="${D}/usr/include/rubberband" \
+ INSTALL_LIBDIR="${D}/usr/$(get_libdir)" \
+ INSTALL_VAMPDIR="${D}/usr/$(get_libdir)/vamp" \
+ INSTALL_LADSPADIR="${D}/usr/$(get_libdir)/ladspa" \
+ INSTALL_LRDFDIR="${D}/usr/share/ladspa/rdf" \
+ INSTALL_PKGDIR="${D}/usr/$(get_libdir)/pkgconfig" \
+ install || die "make install failed"
+ dodoc README
+}