summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:29:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:29:32 +0000
commit97b9d3fa08ee3a8e146db4abea86622c50f2269f (patch)
treec3e44f1d624b3e124bd48a664c11397be5f6b1c0 /media-libs
parentVersion bump for Gnome 3.12. (diff)
downloadgentoo-2-97b9d3fa08ee3a8e146db4abea86622c50f2269f.tar.gz
gentoo-2-97b9d3fa08ee3a8e146db4abea86622c50f2269f.tar.bz2
gentoo-2-97b9d3fa08ee3a8e146db4abea86622c50f2269f.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/clutter/ChangeLog7
-rw-r--r--media-libs/clutter/clutter-1.18.2.ebuild102
2 files changed, 108 insertions, 1 deletions
diff --git a/media-libs/clutter/ChangeLog b/media-libs/clutter/ChangeLog
index 8098abff48cf..c87cbdd0d331 100644
--- a/media-libs/clutter/ChangeLog
+++ b/media-libs/clutter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/clutter
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/ChangeLog,v 1.84 2014/04/18 11:24:51 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/ChangeLog,v 1.85 2014/04/27 17:29:32 eva Exp $
+
+*clutter-1.18.2 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> +clutter-1.18.2.ebuild:
+ Version bump for Gnome 3.12.
18 Apr 2014; Pacho Ramos <pacho@gentoo.org> -clutter-1.12.2.ebuild,
-clutter-1.14.6.ebuild, -clutter-1.16.4.ebuild:
diff --git a/media-libs/clutter/clutter-1.18.2.ebuild b/media-libs/clutter/clutter-1.18.2.ebuild
new file mode 100644
index 000000000000..fc6cc9c2f0b9
--- /dev/null
+++ b/media-libs/clutter/clutter-1.18.2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/clutter-1.18.2.ebuild,v 1.1 2014/04/27 17:29:32 eva Exp $
+
+EAPI="5"
+CLUTTER_LA_PUNT="yes"
+
+# Inherit gnome2 after clutter to download sources from gnome.org
+# since clutter-project.org doesn't provide .xz tarballs
+inherit clutter gnome2 virtualx
+
+DESCRIPTION="Clutter is a library for creating graphical user interfaces"
+
+LICENSE="LGPL-2.1+ FDL-1.1+"
+SLOT="1.0"
+IUSE="debug doc gtk +introspection test" # evdev tslib
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+# NOTE: glx flavour uses libdrm + >=mesa-7.3
+# XXX: uprof needed for profiling
+# >=libX11-1.3.1 needed for X Generic Event support
+# XXX: evdev input requires libinput and gudev >= 136
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=dev-libs/atk-2.5.3[introspection?]
+ >=dev-libs/json-glib-0.12[introspection?]
+ >=media-libs/cogl-1.17.5:1.0=[introspection?,pango]
+ media-libs/fontconfig
+ >=x11-libs/cairo-1.12:=[glib]
+ >=x11-libs/pango-1.30[introspection?]
+
+ virtual/opengl
+ x11-libs/libdrm:=
+ >=x11-libs/libX11-1.3.1
+ x11-libs/libXext
+ x11-libs/libXdamage
+ x11-proto/inputproto
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXcomposite-0.4
+
+ gtk? ( >=x11-libs/gtk+-3.3.18:3 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.20
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17
+ doc? (
+ >=dev-util/gtk-doc-1.20
+ >=app-text/docbook-sgml-utils-0.6.14[jadetex]
+ dev-libs/libxslt )
+ test? ( x11-libs/gdk-pixbuf )"
+
+# Tests fail with both swrast and llvmpipe
+# They pass under r600g or i965, so the bug is in mesa
+#RESTRICT="test"
+
+src_prepare() {
+ # We only need conformance tests, the rest are useless for us
+ sed -e 's/^\(SUBDIRS =\).*/\1 accessibility conform/g' \
+ -i tests/Makefile.am || die "am tests sed failed"
+ sed -e 's/^\(SUBDIRS =\)[^\]*/\1 accessibility conform/g' \
+ -i tests/Makefile.in || die "in tests sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="README NEWS ChangeLog*"
+
+ # XXX: Conformance test suite (and clutter itself) does not work under Xvfb
+ # (GLX error blabla)
+ # XXX: Profiling, coverage disabled for now
+ # XXX: What about cex100/egl/osx/wayland/win32 backends?
+ # XXX: evdev/tslib input seem to be experimental?
+ gnome2_src_configure \
+ --enable-xinput \
+ --enable-x11-backend=yes \
+ --disable-profile \
+ --disable-maintainer-flags \
+ --disable-gcov \
+ --disable-cex100-backend \
+ --disable-egl-backend \
+ --disable-quartz-backend \
+ --disable-wayland-backend \
+ --disable-win32-backend \
+ --disable-tslib-input \
+ --disable-evdev-input \
+ $(usex debug --enable-debug=yes --enable-debug=minimum) \
+ $(use_enable doc docs) \
+ $(use_enable gtk gdk-backend) \
+ $(use_enable introspection) \
+ $(use_enable test gdk-pixbuf)
+}
+
+src_test() {
+ Xemake check -C tests/conform
+}
+
+src_install() {
+ clutter_src_install
+}