summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-07-24 15:42:36 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-07-24 15:42:36 +0000
commit9e917a0e7b9c383985df097ebe45a55f89e21746 (patch)
treebac58a92b8cb88e6fa3f740e9a7cd7035e422480 /media-libs
parentOne more commit for this thing... (diff)
downloadgentoo-2-9e917a0e7b9c383985df097ebe45a55f89e21746.tar.gz
gentoo-2-9e917a0e7b9c383985df097ebe45a55f89e21746.tar.bz2
gentoo-2-9e917a0e7b9c383985df097ebe45a55f89e21746.zip
Version bump to 0.0.6_pre12.
Fix bug 271930. (Portage version: 13845-svn/cvs/Linux i686)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/spandsp/ChangeLog8
-rw-r--r--media-libs/spandsp/metadata.xml3
-rw-r--r--media-libs/spandsp/spandsp-0.0.6_pre12.ebuild58
3 files changed, 68 insertions, 1 deletions
diff --git a/media-libs/spandsp/ChangeLog b/media-libs/spandsp/ChangeLog
index 548b2ef29357..81752246f980 100644
--- a/media-libs/spandsp/ChangeLog
+++ b/media-libs/spandsp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/spandsp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/spandsp/ChangeLog,v 1.17 2009/07/24 12:04:23 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/spandsp/ChangeLog,v 1.18 2009/07/24 15:42:36 volkmar Exp $
+
+*spandsp-0.0.6_pre12 (24 Jul 2009)
+
+ 24 Jul 2009; Mounir Lamouri <volkmar@gentoo.org> metadata.xml,
+ +spandsp-0.0.6_pre12.ebuild:
+ Version bump to 0.0.6_pre12. Fix bug 271930
24 Jul 2009; Mounir Lamouri <volkmar@gentoo.org>
-spandsp-0.0.6_pre3.ebuild:
diff --git a/media-libs/spandsp/metadata.xml b/media-libs/spandsp/metadata.xml
index 2c6dcb2c2389..b273044223ac 100644
--- a/media-libs/spandsp/metadata.xml
+++ b/media-libs/spandsp/metadata.xml
@@ -3,7 +3,10 @@
<pkgmetadata>
<herd>voip</herd>
<use>
+ <flag name='fixed-point'>Enable fixed point support</flag>
+ <flag name='static-libs'>Compile static archives</flag>
<flag name='sse3'>Enable SSE3 support</flag>
+ <flag name='sse4'>Enable SSE4 support</flag>
<flag name='sse4a'>Enable SSE4a support</flag>
<flag name='sse5'>Enable SSE5 support</flag>
</use>
diff --git a/media-libs/spandsp/spandsp-0.0.6_pre12.ebuild b/media-libs/spandsp/spandsp-0.0.6_pre12.ebuild
new file mode 100644
index 000000000000..eda4aa05d8e2
--- /dev/null
+++ b/media-libs/spandsp/spandsp-0.0.6_pre12.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/spandsp/spandsp-0.0.6_pre12.ebuild,v 1.1 2009/07/24 15:42:36 volkmar Exp $
+
+EAPI="2"
+
+inherit multilib versionator
+
+DESCRIPTION="SpanDSP is a library of DSP functions for telephony."
+HOMEPAGE="http://www.soft-switch.org/"
+SRC_URI="http://www.soft-switch.org/downloads/spandsp/${P/_}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc fixed-point mmx sse sse2 sse3 sse4 sse5 static-libs"
+
+RDEPEND="media-libs/tiff"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen
+ dev-libs/libxslt )"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+# TODO:
+# there are two tests options: tests and test-data
+# they need audiofile, fftw, libxml and probably more
+# configure script is auto-enabling some sse* options sometimes
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable doc) \
+ $(use_enable fixed-point) \
+ $(use_enable mmx) \
+ $(use_enable sse) \
+ $(use_enable sse2) \
+ $(use_enable sse3) \
+ $(use_enable sse4 sse4a) \
+ $(use_enable sse4 sse4-1) \
+ $(use_enable sse4 sse4-2) \
+ $(use_enable sse5) \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog DueDiligence NEWS README || die "dodoc failed"
+
+ if ! use static-libs; then
+ # remove useless la file when not installing static lib
+ rm "${D}"/usr/$(get_libdir)/lib${PN}.la || die "rm failed"
+ fi
+
+ if use doc; then
+ dohtml -r doc/{api/html/*,t38_manual} || die "dohtml failed"
+ fi
+}