summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-16 18:53:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-16 18:53:18 +0000
commitc6203e6812d8104e7af1f60f1a46d727795f90c0 (patch)
tree1c75bdd1c16cbafc1bbd84d8c43db3b2bcf115ee /media-libs
parentFix .desktop entry (diff)
downloadgentoo-2-c6203e6812d8104e7af1f60f1a46d727795f90c0.tar.gz
gentoo-2-c6203e6812d8104e7af1f60f1a46d727795f90c0.tar.bz2
gentoo-2-c6203e6812d8104e7af1f60f1a46d727795f90c0.zip
Convert to multilib. Stack it for medialibs r13. Remove debug useflag that only adds -g to cflags. Drop sdl and xv useflags that did nothing since we dropped the gtk1 interface.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libdv/ChangeLog11
-rw-r--r--media-libs/libdv/libdv-1.0.0-r3.ebuild51
2 files changed, 60 insertions, 2 deletions
diff --git a/media-libs/libdv/ChangeLog b/media-libs/libdv/ChangeLog
index 2a47831a7710..9e40fb0e199d 100644
--- a/media-libs/libdv/ChangeLog
+++ b/media-libs/libdv/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libdv
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdv/ChangeLog,v 1.85 2012/05/17 14:19:31 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdv/ChangeLog,v 1.86 2013/08/16 18:53:18 aballier Exp $
+
+*libdv-1.0.0-r3 (16 Aug 2013)
+
+ 16 Aug 2013; Alexis Ballier <aballier@gentoo.org> +libdv-1.0.0-r3.ebuild:
+ Convert to multilib. Stack it for medialibs r13. Remove debug useflag that
+ only adds -g to cflags. Drop sdl and xv useflags that did nothing since we
+ dropped the gtk1 interface.
17 May 2012; Alexis Ballier <aballier@gentoo.org> libdv-1.0.0-r2.ebuild:
keyword ~amd64-fbsd
diff --git a/media-libs/libdv/libdv-1.0.0-r3.ebuild b/media-libs/libdv/libdv-1.0.0-r3.ebuild
new file mode 100644
index 000000000000..74bc38067eb7
--- /dev/null
+++ b/media-libs/libdv/libdv-1.0.0-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdv/libdv-1.0.0-r3.ebuild,v 1.1 2013/08/16 18:53:18 aballier Exp $
+
+EAPI=4
+
+inherit eutils libtool flag-o-matic multilib-minimal
+
+DESCRIPTION="Software codec for dv-format video (camcorders etc)"
+HOMEPAGE="http://libdv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/${PN}-1.0.0-pic.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/popt
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r11
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.99-2.6.patch
+ epatch "${WORKDIR}"/${PN}-1.0.0-pic.patch
+ elibtoolize
+ epunt_cxx #74497
+
+ append-cppflags "-I${S}"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ --without-debug \
+ --disable-gtk \
+ --disable-gtktest
+ if ! multilib_is_native_abi ; then
+ sed -i \
+ -e 's/ encodedv//' \
+ Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}