summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-28 03:15:36 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-28 03:15:36 +0000
commitccb8bfd586512bf147bb27e2fe2a296633e1c5e1 (patch)
tree018f0f77c97d367fa5d0c31ad09001e65e976026 /media-libs
parentBump to hourly snapshot (diff)
downloadgentoo-2-ccb8bfd586512bf147bb27e2fe2a296633e1c5e1.tar.gz
gentoo-2-ccb8bfd586512bf147bb27e2fe2a296633e1c5e1.tar.bz2
gentoo-2-ccb8bfd586512bf147bb27e2fe2a296633e1c5e1.zip
Fix an out of bounds crash when using Digikam #96065 by Quintin Pan.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/imlib2/ChangeLog9
-rw-r--r--media-libs/imlib2/files/imlib-1.2.0-bounds-check.patch27
-rw-r--r--media-libs/imlib2/imlib2-1.2.0-r2.ebuild7
-rw-r--r--media-libs/imlib2/imlib2-1.2.0.007.ebuild3
4 files changed, 40 insertions, 6 deletions
diff --git a/media-libs/imlib2/ChangeLog b/media-libs/imlib2/ChangeLog
index 7f025f901f7d..907f8e9480cf 100644
--- a/media-libs/imlib2/ChangeLog
+++ b/media-libs/imlib2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/imlib2
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/ChangeLog,v 1.39 2005/06/04 15:06:58 centic Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/ChangeLog,v 1.40 2005/07/28 03:15:36 vapier Exp $
+
+ 28 Jul 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/imlib-1.2.0-bounds-check.patch, imlib2-1.2.0-r2.ebuild,
+ imlib2-1.2.0.007.ebuild:
+ Fix an out of bounds crash when using Digikam #96065 by Quintin Pan.
04 Jun 2005; Dominik Stadler <centic@gentoo.org> imlib2-1.1.2.ebuild,
imlib2-1.2.0-r2.ebuild, imlib2-1.2.0.007.ebuild, imlib2-9999.ebuild:
diff --git a/media-libs/imlib2/files/imlib-1.2.0-bounds-check.patch b/media-libs/imlib2/files/imlib-1.2.0-bounds-check.patch
new file mode 100644
index 000000000000..fcf03be8b0bc
--- /dev/null
+++ b/media-libs/imlib2/files/imlib-1.2.0-bounds-check.patch
@@ -0,0 +1,27 @@
+http://bugs.gentoo.org/show_bug.cgi?id=96065
+http://bugs.kde.org/show_bug.cgi?id=100894
+http://xcomputerman.com/bugs/view.php?id=275
+
+Index: src/lib/rend.c
+===================================================================
+RCS file: /cvsroot/enlightenment/e17/libs/imlib2/src/lib/rend.c,v
+retrieving revision 1.1
+retrieving revision 1.2
+diff -u -p -r1.1 -r1.2
+--- src/lib/rend.c 1 Nov 2004 09:45:31 -0000 1.1
++++ src/lib/rend.c 28 Jul 2005 03:10:16 -0000 1.2
+@@ -431,11 +431,11 @@ __imlib_RenderImage(Display * d, ImlibIm
+ free(back);
+ return;
+ }
+- memcpy(buf, im->data + ((y + sy) * im->w) + sx,
++ memcpy(buf, im->data + ((y + sy) * im->w),
+ im->w * hh * sizeof(DATA32));
+ __imlib_DataCmodApply(buf, dw, hh, im->w - dw, NULL, cmod);
+- pointer = buf;
+- jump = 0;
++ pointer = buf + sx;
++ jump = im->w - sw;
+ }
+ else
+ {
diff --git a/media-libs/imlib2/imlib2-1.2.0-r2.ebuild b/media-libs/imlib2/imlib2-1.2.0-r2.ebuild
index ad3f7dd66bc3..9089ec079f55 100644
--- a/media-libs/imlib2/imlib2-1.2.0-r2.ebuild
+++ b/media-libs/imlib2/imlib2-1.2.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.2.0-r2.ebuild,v 1.3 2005/06/04 15:06:58 centic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.2.0-r2.ebuild,v 1.4 2005/07/28 03:15:36 vapier Exp $
EHACKAUTOGEN=yes
inherit enlightenment
@@ -20,8 +20,9 @@ DEPEND="=media-libs/freetype-2*
src_unpack() {
enlightenment_src_unpack
- cd ${S}
- epatch ${FILESDIR}/${P}-loaders.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-loaders.patch
+ epatch "${FILESDIR}"/imlib-1.2.0-bounds-check.patch
}
src_compile() {
diff --git a/media-libs/imlib2/imlib2-1.2.0.007.ebuild b/media-libs/imlib2/imlib2-1.2.0.007.ebuild
index 5c8d71540dcc..d40581291cde 100644
--- a/media-libs/imlib2/imlib2-1.2.0.007.ebuild
+++ b/media-libs/imlib2/imlib2-1.2.0.007.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.2.0.007.ebuild,v 1.4 2005/06/04 15:06:58 centic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.2.0.007.ebuild,v 1.5 2005/07/28 03:15:36 vapier Exp $
EKEY_STATE=snap
inherit enlightenment
@@ -22,6 +22,7 @@ src_unpack() {
enlightenment_src_unpack
cd "${S}"
epatch "${FILESDIR}"/${P}-x-typo.patch
+ epatch "${FILESDIR}"/imlib-1.2.0-bounds-check.patch
}
src_compile() {