summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-02-06 17:00:26 +0000
committerChris White <chriswhite@gentoo.org>2005-02-06 17:00:26 +0000
commitce6a1ecc4592530dd7a26ccc3ad7189251054602 (patch)
tree930cffe69db4cc3ff22289f2ee29c6f43445a812 /media-libs
parentrepoman: Trim trailing whitespace (diff)
downloadgentoo-2-ce6a1ecc4592530dd7a26ccc3ad7189251054602.tar.gz
gentoo-2-ce6a1ecc4592530dd7a26ccc3ad7189251054602.tar.bz2
gentoo-2-ce6a1ecc4592530dd7a26ccc3ad7189251054602.zip
Fixing bug #75403.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libtheora/ChangeLog6
-rw-r--r--media-libs/libtheora/libtheora-1.0_alpha3.ebuild5
-rw-r--r--media-libs/libtheora/libtheora-1.0_alpha4.ebuild5
3 files changed, 13 insertions, 3 deletions
diff --git a/media-libs/libtheora/ChangeLog b/media-libs/libtheora/ChangeLog
index 22202f116887..1b57aeabe08a 100644
--- a/media-libs/libtheora/ChangeLog
+++ b/media-libs/libtheora/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libtheora
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.22 2005/01/04 10:18:44 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.23 2005/02/06 17:00:26 chriswhite Exp $
+
+ 07 Feb 2005; Chris White <chriswhite@gentoo.org>
+ libtheora-1.0_alpha3.ebuild, libtheora-1.0_alpha4.ebuild:
+ Fixing bug #75403.
04 Jan 2005; Hardave Riar <hardave@gentoo.org> libtheora-1.0_alpha3.ebuild:
Stable on mips, dep of bug #74475.
diff --git a/media-libs/libtheora/libtheora-1.0_alpha3.ebuild b/media-libs/libtheora/libtheora-1.0_alpha3.ebuild
index 0c2b3ac2b4f6..832b13aab101 100644
--- a/media-libs/libtheora/libtheora-1.0_alpha3.ebuild
+++ b/media-libs/libtheora/libtheora-1.0_alpha3.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_alpha3.ebuild,v 1.19 2005/01/04 10:18:44 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_alpha3.ebuild,v 1.20 2005/02/06 17:00:26 chriswhite Exp $
+inherit flag-o-matic
DESCRIPTION="The Theora Video Compression Codec"
HOMEPAGE="http://www.theora.org/"
@@ -23,6 +24,8 @@ src_unpack() {
}
src_compile() {
+ # bug #75403, filter -O3 to -O2
+ replace-flags -O3 -O2
econf --enable-shared || die
emake || die
}
diff --git a/media-libs/libtheora/libtheora-1.0_alpha4.ebuild b/media-libs/libtheora/libtheora-1.0_alpha4.ebuild
index b96916af9dba..0e0f4b5d318f 100644
--- a/media-libs/libtheora/libtheora-1.0_alpha4.ebuild
+++ b/media-libs/libtheora/libtheora-1.0_alpha4.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_alpha4.ebuild,v 1.3 2005/01/01 18:57:40 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_alpha4.ebuild,v 1.4 2005/02/06 17:00:26 chriswhite Exp $
+inherit flag-o-matic
DESCRIPTION="The Theora Video Compression Codec"
HOMEPAGE="http://www.theora.org/"
@@ -23,6 +24,8 @@ src_unpack() {
}
src_compile() {
+ # bug #75403, -O3 needs to be filtered to -O2
+ replace-flags -O3 -O2
econf --enable-shared || die
emake || die
}