summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-12-19 13:06:14 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-12-19 13:06:14 +0000
commitdc8a7d8e311a7f49910cb9f4906d2921cdef90e1 (patch)
treec9e84c4547161167da7a0ada3a5c67a0ea55c8fd /media-libs
parentFix build with forced asneeded, bug #247916, honour CC and CFLAGS, bug #24084... (diff)
downloadgentoo-2-dc8a7d8e311a7f49910cb9f4906d2921cdef90e1.tar.gz
gentoo-2-dc8a7d8e311a7f49910cb9f4906d2921cdef90e1.tar.bz2
gentoo-2-dc8a7d8e311a7f49910cb9f4906d2921cdef90e1.zip
Fix build with latest imagemagick, by Robin H. Johnson <robbat2@gentoo.org>
Bug #247292 (Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog7
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.1.15-GetImagePixels.patch25
-rw-r--r--media-libs/xine-lib/xine-lib-1.1.15-r1.ebuild5
3 files changed, 34 insertions, 3 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 329eeb605522..ccde3c3d8dd3 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/xine-lib
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.576 2008/11/23 16:40:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.577 2008/12/19 13:06:14 aballier Exp $
+
+ 19 Dec 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/xine-lib-1.1.15-GetImagePixels.patch, xine-lib-1.1.15-r1.ebuild:
+ Fix build with latest imagemagick, by Robin H. Johnson
+ <robbat2@gentoo.org> Bug #247292
23 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
xine-lib-1.1.15-r1.ebuild:
diff --git a/media-libs/xine-lib/files/xine-lib-1.1.15-GetImagePixels.patch b/media-libs/xine-lib/files/xine-lib-1.1.15-GetImagePixels.patch
new file mode 100644
index 000000000000..c1c572dc72b3
--- /dev/null
+++ b/media-libs/xine-lib/files/xine-lib-1.1.15-GetImagePixels.patch
@@ -0,0 +1,25 @@
+Upstream ImageMagick changed part of the API and did not updated their
+deprecated support stuff, so bump us along for now to avoid having to downgrade.
+
+Gentoo-bug: 247292
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar --exclude '*~' xine-lib-1.1.15.orig/src/libxinevdec/image.c xine-lib-1.1.15/src/libxinevdec/image.c
+--- xine-lib-1.1.15.orig/src/libxinevdec/image.c 2008-06-14 16:15:00.000000000 -0700
++++ xine-lib-1.1.15/src/libxinevdec/image.c 2008-11-26 18:10:16.416309036 -0800
+@@ -110,7 +110,15 @@
+ width = MagickGetImageWidth(wand) & ~1; /* must be even for init_yuv_planes */
+ height = MagickGetImageHeight(wand);
+ img_buf = malloc(width * height * 3);
++/* In 6.4.5.4 MagickGetImagePixels changed to MagickGetAuthenticPixels
++ * But upstream did not update their deprecated compat stuff.
++ * So do a fun hack to make it work.
++ * - 2008/11/26 Robin H. Johnson <robbat2@gentoo.org>
++ */
++#if MagickLibVersion >= 0x645
++#define MagickGetImagePixels MagickGetAuthenticPixels
++#endif
+ MagickGetImagePixels(wand, 0, 0, width, height, "RGB", CharPixel, img_buf);
+ DestroyMagickWand(wand);
+
+ _x_stream_info_set(this->stream, XINE_STREAM_INFO_VIDEO_WIDTH, width);
diff --git a/media-libs/xine-lib/xine-lib-1.1.15-r1.ebuild b/media-libs/xine-lib/xine-lib-1.1.15-r1.ebuild
index fc114623be77..46f7ab3a4e83 100644
--- a/media-libs/xine-lib/xine-lib-1.1.15-r1.ebuild
+++ b/media-libs/xine-lib/xine-lib-1.1.15-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.15-r1.ebuild,v 1.11 2008/11/23 16:40:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.15-r1.ebuild,v 1.12 2008/12/19 13:06:14 aballier Exp $
EAPI=1
@@ -55,7 +55,7 @@ RDEPEND="X? ( x11-libs/libXext
vcd? ( media-video/vcdimager )
a52? ( >=media-libs/a52dec-0.7.4-r5 )
mad? ( media-libs/libmad )
- imagemagick? ( <media-gfx/imagemagick-6.4.5.7 )
+ imagemagick? ( media-gfx/imagemagick )
dts? ( media-libs/libdca )
aac? ( >=media-libs/faad2-2.6.1 )
>=media-video/ffmpeg-0.4.9_p20070129
@@ -91,6 +91,7 @@ src_unpack() {
epatch "$FILESDIR"/${P}-libmpeg2-vis.patch
epatch "$FILESDIR"/${P}-buffer_h_ansi.patch
epatch "$FILESDIR"/${P}-ffmpeg.patch
+ epatch "$FILESDIR"/${P}-GetImagePixels.patch
}
src_compile() {