summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-03-22 13:29:34 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-03-22 13:29:34 +0000
commitf652ab9b9d6485440915a1d759b79a837300a7c7 (patch)
tree76154d873f3e9d75c8b7b9f8dd1fc78022548c2d /media-plugins/eq-xmms/eq-xmms-0.6-r2.ebuild
parentBug 59931 (diff)
downloadgentoo-2-f652ab9b9d6485440915a1d759b79a837300a7c7.tar.gz
gentoo-2-f652ab9b9d6485440915a1d759b79a837300a7c7.tar.bz2
gentoo-2-f652ab9b9d6485440915a1d759b79a837300a7c7.zip
added fix for mono streams playing
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-plugins/eq-xmms/eq-xmms-0.6-r2.ebuild')
-rw-r--r--media-plugins/eq-xmms/eq-xmms-0.6-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-plugins/eq-xmms/eq-xmms-0.6-r2.ebuild b/media-plugins/eq-xmms/eq-xmms-0.6-r2.ebuild
new file mode 100644
index 000000000000..b36a53e3e83b
--- /dev/null
+++ b/media-plugins/eq-xmms/eq-xmms-0.6-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/eq-xmms/eq-xmms-0.6-r2.ebuild,v 1.1 2005/03/22 13:29:34 voxus Exp $
+
+IUSE=""
+
+inherit eutils
+
+DESCRIPTION="EQU is a realtime graphical equalizer effect plugin that will equalize almost everything that you play through XMMS, not just the MP3s"
+HOMEPAGE="http://equ.sourceforge.net/"
+SRC_URI="mirror://sourceforge/equ/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc"
+
+RDEPEND="media-sound/xmms"
+DEPEND="${RDEPEND}
+ !x86? ( >=sys-devel/automake-1.7 )"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch ${FILESDIR}/${P}-shade_fix.patch
+ epatch ${FILESDIR}/${P}-mono_fix.patch
+
+ if ! use x86; then
+ cd ${S}
+ epatch ${FILESDIR}/${P}-nonx86.patch
+
+ WANT_AUTOMAKE=1.7 aclocal
+ WANT_AUTOMAKE=1.7 automake
+ WANT_AUTOCONF=2.5 autoconf
+ libtoolize --copy --force
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" libdir=`xmms-config --effect-plugin-dir` install || die
+
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README README.BSD SKINS TODO
+}