summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2009-07-08 19:44:15 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2009-07-08 19:44:15 +0000
commit7c212eb1eb7137d7fb7a3119af25aa89b0b054c7 (patch)
tree695989b996e5ff30e7a3e51c5e02febf52c6b3cd /media-plugins/vdr-atscepg
parentInclude signal.h and sys/types.h in tdb.h to avoid 3rd party software from fa... (diff)
downloadgentoo-2-7c212eb1eb7137d7fb7a3119af25aa89b0b054c7.tar.gz
gentoo-2-7c212eb1eb7137d7fb7a3119af25aa89b0b054c7.tar.bz2
gentoo-2-7c212eb1eb7137d7fb7a3119af25aa89b0b054c7.zip
Version bumped.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-plugins/vdr-atscepg')
-rw-r--r--media-plugins/vdr-atscepg/ChangeLog8
-rw-r--r--media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild5
-rw-r--r--media-plugins/vdr-atscepg/vdr-atscepg-0.3.0.ebuild35
3 files changed, 44 insertions, 4 deletions
diff --git a/media-plugins/vdr-atscepg/ChangeLog b/media-plugins/vdr-atscepg/ChangeLog
index 04e0eb406d6b..e645b1e14422 100644
--- a/media-plugins/vdr-atscepg/ChangeLog
+++ b/media-plugins/vdr-atscepg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-atscepg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-atscepg/ChangeLog,v 1.2 2009/07/08 19:21:05 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-atscepg/ChangeLog,v 1.3 2009/07/08 19:44:15 zzam Exp $
+
+*vdr-atscepg-0.3.0 (08 Jul 2009)
+
+ 08 Jul 2009; Matthias Schwarzott <zzam@gentoo.org>
+ vdr-atscepg-0.1.1.ebuild, +vdr-atscepg-0.3.0.ebuild:
+ Version bumped.
08 Jul 2009; Matthias Schwarzott <zzam@gentoo.org>
vdr-atscepg-0.1.1.ebuild, +files/vdr-atscepg-0.1.1-gcc-4.4.diff:
diff --git a/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild b/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild
index 79154c13fd25..68381406c9c6 100644
--- a/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild
+++ b/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild,v 1.2 2009/07/08 19:21:05 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild,v 1.3 2009/07/08 19:44:15 zzam Exp $
inherit vdr-plugin
-DESCRIPTION="VDR plugin: implements the Program and System Information
-Protocol for DVB-T and DVB-C Broadcast from the ATSC standard"
+DESCRIPTION="VDR plugin: receive schedule and event information from ATSC broadcasts"
HOMEPAGE="http://www.fepg.org/atscepg.html"
SRC_URI="http://www.fepg.org/files/${P}.tgz"
diff --git a/media-plugins/vdr-atscepg/vdr-atscepg-0.3.0.ebuild b/media-plugins/vdr-atscepg/vdr-atscepg-0.3.0.ebuild
new file mode 100644
index 000000000000..05f9e9081ca3
--- /dev/null
+++ b/media-plugins/vdr-atscepg/vdr-atscepg-0.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-atscepg/vdr-atscepg-0.3.0.ebuild,v 1.1 2009/07/08 19:44:15 zzam Exp $
+
+inherit vdr-plugin
+
+DESCRIPTION="VDR plugin: receive schedule and event information from ATSC broadcasts"
+HOMEPAGE="http://www.fepg.org/atscepg.html"
+SRC_URI="http://www.fepg.org/files/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.6"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ vdr-plugin_pkg_setup
+
+ if ! built_with_use media-video/vdr atsc; then
+ echo
+ ewarn "To support this plugin you need to"
+ ewarn "recompile media-video/vdr with use-flag atsc"
+ echo
+ fi
+}
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ #epatch "${FILESDIR}/${P}-gcc-4.4.diff"
+ fix_vdr_libsi_include tables.cpp filter.cpp
+}