summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-04-21 10:45:33 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-04-21 10:45:33 +0000
commitc6faef90a9563f097b02194571b817e32fc033c6 (patch)
tree2706f8875a07c3addc9c90cbd984d78b9c2be5b3 /media-plugins/vdr-softplay/vdr-softplay-0.0.2.20080421.ebuild
parentInstall missing icons; add ~amd64 keyword, bug #218664 (diff)
downloadgentoo-2-c6faef90a9563f097b02194571b817e32fc033c6.tar.gz
gentoo-2-c6faef90a9563f097b02194571b817e32fc033c6.tar.bz2
gentoo-2-c6faef90a9563f097b02194571b817e32fc033c6.zip
Added new snapshot that also can work with ffmpeg-0.4.9_p20080326, Bug #218094. Fixed quoting.
(Portage version: 2.1.5_rc5)
Diffstat (limited to 'media-plugins/vdr-softplay/vdr-softplay-0.0.2.20080421.ebuild')
-rw-r--r--media-plugins/vdr-softplay/vdr-softplay-0.0.2.20080421.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-plugins/vdr-softplay/vdr-softplay-0.0.2.20080421.ebuild b/media-plugins/vdr-softplay/vdr-softplay-0.0.2.20080421.ebuild
new file mode 100644
index 000000000000..d1ef2e57b00b
--- /dev/null
+++ b/media-plugins/vdr-softplay/vdr-softplay-0.0.2.20080421.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softplay/vdr-softplay-0.0.2.20080421.ebuild,v 1.1 2008/04/21 10:45:33 zzam Exp $
+
+inherit vdr-plugin versionator
+
+MY_PV=$(get_version_component_range 4)
+MY_P=${PN}-cvs-${MY_PV}
+
+DESCRIPTION="VDR plugin: play media-files with vdr+vdr-softdevice as output device"
+HOMEPAGE="http://softdevice.berlios.de/softplay/index.html"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.3.20
+ >=media-plugins/vdr-softdevice-0.2.3.20060814-r1
+ >=media-video/ffmpeg-0.4.9_pre1"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P#vdr-}
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ cd "${S}"
+ # Inclusion of vdr-softdevice header-files from /usr/include/vdr-softdevice
+ sed -i SoftHandles.h -e 's#../softdevice/softdevice.h#vdr-softdevice/softdevice.h#'
+
+ # ffmpeg-header-directory
+ sed -i Makefile -e 's#^LIBFFMPEG=.*$#LIBFFMPEG=/usr/include/ffmpeg#'
+
+ epatch "${FILESDIR}/ffmpeg-linking.diff"
+ if has_version ">=media-video/ffmpeg-0.4.9_p20080326"; then
+ epatch "${FILESDIR}/ffmpeg-0.4.9_p20080326-new_header.diff"
+ fi
+}