summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-04-07 08:52:23 +0000
committerPacho Ramos <pacho@gentoo.org>2011-04-07 08:52:23 +0000
commit12b9be2dfa2e9ea02a92cc5ebd30b72472aec2f9 (patch)
tree028a1b375ec81cf11c7b34fd316ca359707bd688 /media-plugins
parentVersion bump with new features and lots of bugfixes. (diff)
downloadgentoo-2-12b9be2dfa2e9ea02a92cc5ebd30b72472aec2f9.tar.gz
gentoo-2-12b9be2dfa2e9ea02a92cc5ebd30b72472aec2f9.tar.bz2
gentoo-2-12b9be2dfa2e9ea02a92cc5ebd30b72472aec2f9.zip
Version bump with new features and lots of bugfixes.
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/banshee-community-extensions/ChangeLog8
-rw-r--r--media-plugins/banshee-community-extensions/banshee-community-extensions-2.0.0.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/media-plugins/banshee-community-extensions/ChangeLog b/media-plugins/banshee-community-extensions/ChangeLog
index 7ac45090cb68..9f8298a2ee3d 100644
--- a/media-plugins/banshee-community-extensions/ChangeLog
+++ b/media-plugins/banshee-community-extensions/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/banshee-community-extensions
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/banshee-community-extensions/ChangeLog,v 1.13 2011/02/27 14:55:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/banshee-community-extensions/ChangeLog,v 1.14 2011/04/07 08:52:23 pacho Exp $
+
+*banshee-community-extensions-2.0.0 (07 Apr 2011)
+
+ 07 Apr 2011; Pacho Ramos <pacho@gentoo.org>
+ +banshee-community-extensions-2.0.0.ebuild:
+ Version bump with new features and lots of bugfixes.
27 Feb 2011; Pacho Ramos <pacho@gentoo.org>
-files/banshee-community-extensions-1.5.5-magnatune-build-fix.patch,
diff --git a/media-plugins/banshee-community-extensions/banshee-community-extensions-2.0.0.ebuild b/media-plugins/banshee-community-extensions/banshee-community-extensions-2.0.0.ebuild
new file mode 100644
index 000000000000..c9b4346bb694
--- /dev/null
+++ b/media-plugins/banshee-community-extensions/banshee-community-extensions-2.0.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/banshee-community-extensions/banshee-community-extensions-2.0.0.ebuild,v 1.1 2011/04/07 08:52:23 pacho Exp $
+
+EAPI="3"
+
+inherit base mono
+
+DESCRIPTION="Community-developed plugins for the Banshee media player"
+HOMEPAGE="http://banshee.fm/"
+SRC_URI="http://download.banshee-project.org/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc lirc lyrics mirage telepathy"
+
+DEPEND=">=dev-lang/mono-2.0
+ >=media-sound/banshee-1.9.6[web]
+ >=gnome-base/gconf-2.0
+ dev-dotnet/gconf-sharp:2
+ doc? ( >=app-text/gnome-doc-utils-0.17.3 )
+ lirc? ( app-misc/lirc )
+ mirage? (
+ dev-libs/glib:2
+ dev-db/sqlite:3
+ sci-libs/fftw:3.0
+ media-libs/libsamplerate
+ >=media-libs/gstreamer-0.10.15
+ >=media-libs/gst-plugins-base-0.10.15
+ )
+ telepathy? (
+ dev-dotnet/notify-sharp
+ >=dev-lang/mono-2.4.2
+ )"
+RDEPEND="${DEPEND}
+ !media-plugins/banshee-lyrics
+ !media-plugins/banshee-mirage"
+
+src_configure() {
+ # Disable ClutterFlow as we don't have clutter-sharp and co in tree
+ # Disable UbuntuOneMusicStore as we don't have ubuntuone-sharp
+ # Disable AppIndicator as it's not in tree
+ # Disable OpenVP as some of its dependencies are not in the tree
+ # Disable SoundMenu as it requires indicate-sharp
+ # Disable zeitgeistdataprovider as it requires zeitgeist-sharp
+ local myconf="--enable-gnome --disable-static --enable-release
+ --with-gconf-schema-file-dir=/etc/gconf/schemas
+ --with-vendor-build-id=Gentoo/${PN}/${PVR}
+ --disable-scrollkeeper --disable-clutterflow
+ --disable-appindicator --disable-openvp --enable-ampache
+ --enable-karaoke --enable-jamendo --enable-lastfmfingerprint
+ --disable-zeitgeistdataprovider --enable-randombylastfm"
+
+ econf \
+ $(use_enable doc user-help) \
+ $(use_enable lirc) \
+ $(use_enable lyrics) \
+ $(use_enable mirage) \
+ $(use_enable telepathy) \
+ $(use_enable test tests) \
+ ${myconf}
+}
+
+src_install() {
+ base_src_install
+ find "${ED}" -name "*.la" -delete || die "remove of la files failed"
+ dodoc AUTHORS NEWS README || die
+}