summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-10 19:24:24 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-10 19:24:24 +0000
commitf5089185723f2b7222fb96b85be326dba1474732 (patch)
tree4c57b93fc16fb940b2aed624542a8b6f13a8ddfc /media-plugins
parentVersion bump (diff)
downloadgentoo-2-f5089185723f2b7222fb96b85be326dba1474732.tar.gz
gentoo-2-f5089185723f2b7222fb96b85be326dba1474732.tar.bz2
gentoo-2-f5089185723f2b7222fb96b85be326dba1474732.zip
Enable multilib support, bug #493176.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gst-plugins-ximagesrc/ChangeLog10
-rw-r--r--media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-0.10.31-r1.ebuild29
-rw-r--r--media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.2.4-r1.ebuild29
3 files changed, 67 insertions, 1 deletions
diff --git a/media-plugins/gst-plugins-ximagesrc/ChangeLog b/media-plugins/gst-plugins-ximagesrc/ChangeLog
index d1de1c446897..e230e87f0bb1 100644
--- a/media-plugins/gst-plugins-ximagesrc/ChangeLog
+++ b/media-plugins/gst-plugins-ximagesrc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-plugins/gst-plugins-ximagesrc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ximagesrc/ChangeLog,v 1.77 2014/05/31 15:24:21 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ximagesrc/ChangeLog,v 1.78 2014/06/10 19:24:24 mgorny Exp $
+
+*gst-plugins-ximagesrc-0.10.31-r1 (10 Jun 2014)
+*gst-plugins-ximagesrc-1.2.4-r1 (10 Jun 2014)
+
+ 10 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +gst-plugins-ximagesrc-0.10.31-r1.ebuild,
+ +gst-plugins-ximagesrc-1.2.4-r1.ebuild:
+ Enable multilib support, bug #493176.
*gst-plugins-ximagesrc-1.2.4 (31 May 2014)
diff --git a/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-0.10.31-r1.ebuild b/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-0.10.31-r1.ebuild
new file mode 100644
index 000000000000..7026225372ec
--- /dev/null
+++ b/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-0.10.31-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-0.10.31-r1.ebuild,v 1.1 2014/06/10 19:24:24 mgorny Exp $
+
+EAPI="5"
+
+GST_ORG_MODULE=gst-plugins-good
+inherit gstreamer
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libSM[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ x11-proto/damageproto[${MULTILIB_USEDEP}]
+ x11-proto/fixesproto[${MULTILIB_USEDEP}]
+ x11-proto/xextproto[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+"
+
+# xshm is a compile time option of ximage
+GST_PLUGINS_BUILD="x xshm"
+GST_PLUGINS_BUILD_DIR="ximage"
diff --git a/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.2.4-r1.ebuild b/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..d7c48dd31ea1
--- /dev/null
+++ b/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.2.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.2.4-r1.ebuild,v 1.1 2014/06/10 19:24:24 mgorny Exp $
+
+EAPI="5"
+
+GST_ORG_MODULE=gst-plugins-good
+inherit gstreamer
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libSM[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ x11-proto/damageproto[${MULTILIB_USEDEP}]
+ x11-proto/fixesproto[${MULTILIB_USEDEP}]
+ x11-proto/xextproto[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+"
+
+# xshm is a compile time option of ximage
+GST_PLUGINS_BUILD="x xshm"
+GST_PLUGINS_BUILD_DIR="ximage"