summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-25 08:07:02 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-25 08:07:02 +0000
commitfff842362fd4c90be5209361727a1e7b74333f85 (patch)
treed16b9751f610c7a61177fc12dd7012f77b05c9f0 /media-sound/abcmidi/abcmidi-2014.04.24.ebuild
parentVersion bump. (diff)
downloadgentoo-2-fff842362fd4c90be5209361727a1e7b74333f85.tar.gz
gentoo-2-fff842362fd4c90be5209361727a1e7b74333f85.tar.bz2
gentoo-2-fff842362fd4c90be5209361727a1e7b74333f85.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound/abcmidi/abcmidi-2014.04.24.ebuild')
-rw-r--r--media-sound/abcmidi/abcmidi-2014.04.24.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/abcmidi/abcmidi-2014.04.24.ebuild b/media-sound/abcmidi/abcmidi-2014.04.24.ebuild
new file mode 100644
index 000000000000..bd5abe018b0c
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2014.04.24.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/abcmidi-2014.04.24.ebuild,v 1.1 2014/04/25 08:07:02 radhermit Exp $
+
+EAPI=5
+
+inherit eutils versionator autotools
+
+MY_P="abcMIDI-$(replace_all_version_separators '-')"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="http://abc.sourceforge.net/abcMIDI/"
+SRC_URI="http://ifdo.pugmarks.com/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2011.10.19-install.patch
+ rm configure makefile || die
+ sed -i "s:-O2::" configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}