summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-02-06 10:09:51 +0000
committerTim Harder <radhermit@gentoo.org>2014-02-06 10:09:51 +0000
commit32165142a33ff178c418ac81af05bec1d63aa279 (patch)
treec8975dbbcb4c4c9ff9d116c1fb6ddd8855024fd6 /media-sound/abcmidi
parentDrop testing arches back to testing (diff)
downloadgentoo-2-32165142a33ff178c418ac81af05bec1d63aa279.tar.gz
gentoo-2-32165142a33ff178c418ac81af05bec1d63aa279.tar.bz2
gentoo-2-32165142a33ff178c418ac81af05bec1d63aa279.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound/abcmidi')
-rw-r--r--media-sound/abcmidi/ChangeLog7
-rw-r--r--media-sound/abcmidi/abcmidi-2014.02.05.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-sound/abcmidi/ChangeLog b/media-sound/abcmidi/ChangeLog
index ccd75057cf45..c39e26c4979d 100644
--- a/media-sound/abcmidi/ChangeLog
+++ b/media-sound/abcmidi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/abcmidi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.51 2014/01/22 03:54:27 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.52 2014/02/06 10:09:51 radhermit Exp $
+
+*abcmidi-2014.02.05 (06 Feb 2014)
+
+ 06 Feb 2014; Tim Harder <radhermit@gentoo.org> +abcmidi-2014.02.05.ebuild:
+ Version bump.
*abcmidi-2014.01.20 (22 Jan 2014)
diff --git a/media-sound/abcmidi/abcmidi-2014.02.05.ebuild b/media-sound/abcmidi/abcmidi-2014.02.05.ebuild
new file mode 100644
index 000000000000..6a2f2def44be
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2014.02.05.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/abcmidi-2014.02.05.ebuild,v 1.1 2014/02/06 10:09:51 radhermit Exp $
+
+EAPI=5
+
+inherit eutils versionator autotools
+
+MY_P="abcMIDI-$(replace_all_version_separators '-')"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="http://abc.sourceforge.net/abcMIDI/"
+SRC_URI="http://ifdo.pugmarks.com/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2011.10.19-install.patch
+ rm configure makefile || die
+ sed -i "s:-O2::" configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}