summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-06 17:03:08 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-06 17:03:08 +0000
commit69cae846e33ff6177655ec08323aa8ce2fb803f1 (patch)
tree4667a8be59bc20c2a719bee72422fecf595448d2 /media-sound/alsa-driver
parentRemoved sed-4 from *DEPEND. (diff)
downloadgentoo-2-69cae846e33ff6177655ec08323aa8ce2fb803f1.tar.gz
gentoo-2-69cae846e33ff6177655ec08323aa8ce2fb803f1.tar.bz2
gentoo-2-69cae846e33ff6177655ec08323aa8ce2fb803f1.zip
Double-check the ALSA_CARDS variable by checking that the requested drivers are supported by the ebuild and they are available on the architecture.
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/ChangeLog7
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild45
2 files changed, 26 insertions, 26 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 34e2acd6cf2e..21a8625c1f49 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.240 2006/12/06 11:43:47 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.241 2006/12/06 17:03:08 flameeyes Exp $
+
+ 06 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+ alsa-driver-1.0.14_pre20061130.ebuild:
+ Double-check the ALSA_CARDS variable by checking that the requested drivers
+ are supported by the ebuild and they are available on the architecture.
06 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
alsa-driver-1.0.14_pre20061130.ebuild:
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild
index 52d16a8b7d99..a397d1b5365b 100644
--- a/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild,v 1.2 2006/12/06 11:43:47 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild,v 1.3 2006/12/06 17:03:08 flameeyes Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -58,7 +58,13 @@ pkg_setup() {
#
# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
#
- ALSA_CARDS=${ALSA_CARDS:-all}
+ ALSA_CARDS=${ALSA_CARDS:-${IUSE_ALSA_CARDS}}
+
+ local TMP_ALSA_CARDS
+ for card in ${ALSA_CARDS}; do
+ has alsa_cards_${card} ${IUSE} && use alsa_cards_${card} && TMP_ALSA_CARDS="${TMP_ALSA_CARDS} ${card}"
+ done
+ ALSA_CARDS="${TMP_ALSA_CARDS}"
# Which drivers need PNP
local PNP_DRIVERS="interwave interwave-stb"
@@ -71,29 +77,18 @@ pkg_setup() {
local PNP_ERROR="Some of the drivers you selected require PnP support in your kernel (${PNP_DRIVERS}). Either enable PnP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
local FW_LOADER_ERROR="Some of the drivers you selected require 'Userspace firmware loading support' in your kernel (${FW_DRIVERS}). Either enable that feature or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
- if [[ "${ALSA_CARDS}" == "all" ]]; then
- # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
- case ${ARCH} in
- ppc|ppc64) ;;
- *)
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
- ;;
- esac
- CONFIG_CHECK="${CONFIG_CHECK} FW_LOADER"
- else
- for pnpdriver in ${PNP_DRIVERS}; do
- if use alsa_cards_${pnpdriver}; then
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
- break;
- fi
- done
- for fwdriver in ${FW_DRIVERS}; do
- if use alsa_cards_${fwdriver}; then
- CONFIG_CHECK="${CONFIG_CHECK} FW_LOADER"
- break;
- fi
- done
- fi
+ for pnpdriver in ${PNP_DRIVERS}; do
+ if use alsa_cards_${pnpdriver}; then
+ CONFIG_CHECK="${CONFIG_CHECK} PNP"
+ break;
+ fi
+ done
+ for fwdriver in ${FW_DRIVERS}; do
+ if use alsa_cards_${fwdriver}; then
+ CONFIG_CHECK="${CONFIG_CHECK} FW_LOADER"
+ break;
+ fi
+ done
linux-mod_pkg_setup