summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-19 15:54:56 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-19 15:54:56 +0000
commitbf12b6e6609cccbb464fe86a648ba8020f256267 (patch)
tree664443716df31a190d5d1b1744931f94f507f2e9 /media-sound/alsa-utils
parent*** empty log message *** (diff)
downloadgentoo-2-bf12b6e6609cccbb464fe86a648ba8020f256267.tar.gz
gentoo-2-bf12b6e6609cccbb464fe86a648ba8020f256267.tar.bz2
gentoo-2-bf12b6e6609cccbb464fe86a648ba8020f256267.zip
*** empty log message ***
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/alsa-utils-0.5.9.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/alsa-utils/alsa-utils-0.5.9.ebuild b/media-sound/alsa-utils/alsa-utils-0.5.9.ebuild
new file mode 100644
index 000000000000..8203fe7b5fa0
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-0.5.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-0.5.9.ebuild,v 1.1 2000/08/19 15:54:55 achim Exp $
+
+P=alsa-utils-0.5.9
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="Advanced Linux Sound Architecture / Utils"
+SRC_URI="ftp://ftp.alsa-project.org/pub/utils/"${A}
+HOMEPAGE="http://www.alsa-project.org/"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr
+ make
+
+}
+
+src_install() {
+ cd ${S}/aplay
+ cd aplay
+ cp Makefile Makefile.orig
+ sed -e "s:cd \$(bindir):cd \$(DESTDIR)\$(bindir):" \
+ sed -e "s:cd \$(mandir):cd \$(DESTDIR)\$(mandir):" \
+ Makefile.orig > Makefile
+ cd ${S}
+ make DESTDIR=${D} install
+ dodoc ChangeLog COPYING README
+ newdoc alsamixer/README README.alsamixer
+ dodoc seq/aconnect/README* seq/aseqnet/README*
+ prepman
+}
+
+
+
+