summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-02-19 06:26:20 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-02-19 06:26:20 +0000
commitca5b347ee6cd08c762d2d1b68b1c9513ca2624a8 (patch)
treeca3b52a658bad9666f1b19d1d3d4d9c66edc1298 /media-sound/alsaplayer
parentUpstream changed the distfile (diff)
downloadgentoo-2-ca5b347ee6cd08c762d2d1b68b1c9513ca2624a8.tar.gz
gentoo-2-ca5b347ee6cd08c762d2d1b68b1c9513ca2624a8.tar.bz2
gentoo-2-ca5b347ee6cd08c762d2d1b68b1c9513ca2624a8.zip
Switch to using gtk1 interface since the gtk2 interface is incomplete. Add
warning about possible crashes with unicode filenames. Create desktop menu entry. (Portage version: 2.1.2-r9)
Diffstat (limited to 'media-sound/alsaplayer')
-rw-r--r--media-sound/alsaplayer/ChangeLog10
-rw-r--r--media-sound/alsaplayer/alsaplayer-0.99.77-r1.ebuild98
-rw-r--r--media-sound/alsaplayer/files/digest-alsaplayer-0.99.77-r13
3 files changed, 110 insertions, 1 deletions
diff --git a/media-sound/alsaplayer/ChangeLog b/media-sound/alsaplayer/ChangeLog
index 0d55f8147de8..c9a65bd65c1f 100644
--- a/media-sound/alsaplayer/ChangeLog
+++ b/media-sound/alsaplayer/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/alsaplayer
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/ChangeLog,v 1.55 2007/02/18 15:30:35 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/ChangeLog,v 1.56 2007/02/19 06:26:20 dirtyepic Exp $
+
+*alsaplayer-0.99.77-r1 (19 Feb 2007)
+
+ 19 Feb 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +alsaplayer-0.99.77-r1.ebuild:
+ Switch to using gtk1 interface since the gtk2 interface is incomplete. Add
+ warning about possible crashes with unicode filenames. Create desktop menu
+ entry.
18 Feb 2007; nixnut <nixnut@gentoo.org> alsaplayer-0.99.77.ebuild:
Added ~ppc wrt bug 166464
diff --git a/media-sound/alsaplayer/alsaplayer-0.99.77-r1.ebuild b/media-sound/alsaplayer/alsaplayer-0.99.77-r1.ebuild
new file mode 100644
index 000000000000..e49ea0409825
--- /dev/null
+++ b/media-sound/alsaplayer/alsaplayer-0.99.77-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/alsaplayer-0.99.77-r1.ebuild,v 1.1 2007/02/19 06:26:20 dirtyepic Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="A heavily multi-threaded pluggable audio player."
+HOMEPAGE="http://www.alsaplayer.org/"
+SRC_URI="http://www.alsaplayer.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="alsa audiofile doc esd flac gtk jack mikmod nas nls ogg opengl oss vorbis xosd"
+
+RDEPEND="
+ media-libs/libsndfile
+ alsa? ( media-libs/alsa-lib )
+ audiofile? ( media-libs/audiofile )
+ esd? ( media-sound/esound )
+ flac? ( media-libs/flac )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.80.0 )
+ mikmod? ( >=media-libs/libmikmod-3.1.10 )
+ nas? ( media-libs/nas )
+ ogg? ( media-libs/libogg )
+ opengl? ( virtual/opengl )
+ vorbis? ( media-libs/libvorbis )
+ xosd? ( x11-libs/xosd )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}"/${P}-ppc-endian-fix.patch
+ epatch "${FILESDIR}"/${P}-join-null-thread.patch
+ epatch "${FILESDIR}"/${P}-cxxflags.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ use xosd ||
+ export ac_cv_lib_xosd_xosd_create="no"
+
+ use doc ||
+ export ac_cv_prog_HAVE_DOXYGEN="false"
+
+ if use ogg && use flac; then
+ myconf="${myconf} --enable-oggflac"
+ fi
+
+ econf \
+ $(use_enable audiofile) \
+ $(use_enable esd) \
+ $(use_enable flac) \
+ $(use_enable gtk gtk) \
+ $(use_enable jack) \
+ $(use_enable mikmod) \
+ $(use_enable nas) \
+ $(use_enable opengl) \
+ $(use_enable oss) \
+ $(use_enable nls) \
+ $(use_enable sparc) \
+ $(use_enable vorbis oggvorbis) \
+ ${myconf} \
+ --disable-gtk2 \
+ --disable-sgi \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${D}/usr/share/doc/${PF}" install \
+ || die "make install failed"
+
+ make_desktop_entry ${PN} "Alsaplayer" ${PN} \
+ "AudioVideo;Audio;Player"
+
+ dodoc AUTHORS ChangeLog README TODO
+ dodoc docs/wishlist.txt
+}
+
+pkg_postinst() {
+ if use gtk; then
+ elog
+ elog "The GTK-1 interface is known to crash with unicode filenames. If you"
+ elog "experience such crashes, consider using the text interface (\`alsaplayer -i"
+ elog "text\`), or trying another audio player."
+ elog
+ fi
+}
diff --git a/media-sound/alsaplayer/files/digest-alsaplayer-0.99.77-r1 b/media-sound/alsaplayer/files/digest-alsaplayer-0.99.77-r1
new file mode 100644
index 000000000000..385f3c3f0ed7
--- /dev/null
+++ b/media-sound/alsaplayer/files/digest-alsaplayer-0.99.77-r1
@@ -0,0 +1,3 @@
+MD5 3280795b199ae1bb245559ccbbca5c02 alsaplayer-0.99.77.tar.bz2 657622
+RMD160 a40c25f17ec6f4f81283bb2ee91c0bee27e1a108 alsaplayer-0.99.77.tar.bz2 657622
+SHA256 5bfcbb14f5c64f0d5fd56420910f192a1bebac99c8a6e53855a69f64a3f3d6a0 alsaplayer-0.99.77.tar.bz2 657622