summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-02-19 16:41:52 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-02-19 16:41:52 +0000
commit0cf257095389be6bcc468006d8a7d0c9d7c1a4f3 (patch)
tree1884bd33e906965090474ec4df82d1ff46925e16 /media-sound/amarok-utils
parentVersion bump (from the lisp overlay); obsolete dependency on app-text/texi2ht... (diff)
downloadgentoo-2-0cf257095389be6bcc468006d8a7d0c9d7c1a4f3.tar.gz
gentoo-2-0cf257095389be6bcc468006d8a7d0c9d7c1a4f3.tar.bz2
gentoo-2-0cf257095389be6bcc468006d8a7d0c9d7c1a4f3.zip
Bumped amarok to the 2.2.2.90 release (2.3 Beta 1).
Dropped the bindist use flag and added a hard dep on taglib[asf,mp4] (bug 299899) - thanks to Jeff Mitchell (jefferai). (Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amarok-utils')
-rw-r--r--media-sound/amarok-utils/ChangeLog10
-rw-r--r--media-sound/amarok-utils/amarok-utils-2.2.2.90.ebuild64
2 files changed, 73 insertions, 1 deletions
diff --git a/media-sound/amarok-utils/ChangeLog b/media-sound/amarok-utils/ChangeLog
index 3cd79ba2dc1f..a0a825f3cfc1 100644
--- a/media-sound/amarok-utils/ChangeLog
+++ b/media-sound/amarok-utils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/amarok-utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/ChangeLog,v 1.12 2010/01/08 15:50:10 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/ChangeLog,v 1.13 2010/02/19 16:41:52 jmbsvicetto Exp $
+
+*amarok-utils-2.2.2.90 (19 Feb 2010)
+
+ 19 Feb 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +amarok-utils-2.2.2.90.ebuild:
+ Bumped amarok to the 2.2.2.90 release (2.3 Beta 1).
+ Dropped the bindist use flag and added a hard dep on taglib[asf,mp4] (bug
+ 299899) - thanks to Jeff Mitchell (jefferai).
*amarok-utils-2.2.2 (08 Jan 2010)
diff --git a/media-sound/amarok-utils/amarok-utils-2.2.2.90.ebuild b/media-sound/amarok-utils/amarok-utils-2.2.2.90.ebuild
new file mode 100644
index 000000000000..83e31331bb42
--- /dev/null
+++ b/media-sound/amarok-utils/amarok-utils-2.2.2.90.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/amarok-utils-2.2.2.90.ebuild,v 1.1 2010/02/19 16:41:52 jmbsvicetto Exp $
+
+EAPI="2"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git"
+ EGIT_PROJECT="amarok"
+ EGIT_REPO_URI="git://gitorious.org/amarok/amarok.git"
+fi
+
+inherit base cmake-utils ${GIT_ECLASS}
+
+MY_PN="amarok"
+
+DESCRIPTION="Various utility programs for Amarok."
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="mirror://kde/unstable/${MY_PN}/${PV}/src/${MY_PN}-${PV}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ >=media-libs/taglib-1.6.1[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ >=x11-libs/qt-core-4.4:4
+ >=x11-libs/qt-dbus-4.4:4
+"
+RDEPEND="${DEPEND}
+ !<media-sound/amarok-2.1.80:2
+ !<media-sound/amarok-2.1.80:${SLOT}
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS="TODO README ChangeLog AUTHORS"
+
+src_prepare() {
+ # Disable po processing
+ sed -e "s:include(MacroOptionalAddSubdirectory)::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+ sed -e "s:macro_optional_add_subdirectory( po )::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+
+ base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_PLAYER=OFF
+ -DWITH_UTILITIES=ON
+ )
+
+ cmake-utils_src_configure
+}