summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-09-19 05:10:25 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-09-19 05:10:25 +0000
commit3734e776dca7061eb9df04a86f503a83d383ed6a (patch)
treeb820465f2e66c82bd44ce28ceb415ab9ee42a71f /media-sound/amarok
parent[package.mask] Masked media-sound/amarok-2.3.2 until the public release. (diff)
downloadgentoo-2-3734e776dca7061eb9df04a86f503a83d383ed6a.tar.gz
gentoo-2-3734e776dca7061eb9df04a86f503a83d383ed6a.tar.bz2
gentoo-2-3734e776dca7061eb9df04a86f503a83d383ed6a.zip
[media-sound/amarok-2.3.2] Bumped amarok to the 2.3.2 release - masked until the public release.
Applied commit ce57e426 from the git tree to fix a BMP tag bug related to flac files - thanks to Jeff Mitchell <mitchell AT kde DOT org>. (Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog12
-rw-r--r--media-sound/amarok/amarok-2.3.1.90.ebuild3
-rw-r--r--media-sound/amarok/amarok-2.3.2.ebuild151
-rw-r--r--media-sound/amarok/files/amarok-2.3.2-flac-fix.patch21
4 files changed, 184 insertions, 3 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index c356bd7a3b44..c95a03a12f0d 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.388 2010/08/24 01:44:26 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.389 2010/09/19 05:10:25 jmbsvicetto Exp $
+
+*amarok-2.3.2 (19 Sep 2010)
+
+ 19 Sep 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ amarok-2.3.1.90.ebuild, +amarok-2.3.2.ebuild,
+ +files/amarok-2.3.2-flac-fix.patch:
+ [media-sound/amarok-2.3.2] Bumped amarok to the 2.3.2 release - masked
+ until the public release.
+ Applied commit ce57e426 from the git tree to fix a BMP tag bug related to
+ flac files - thanks to Jeff Mitchell <mitchell AT kde DOT org>.
24 Aug 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
amarok-2.3.1-r2.ebuild:
diff --git a/media-sound/amarok/amarok-2.3.1.90.ebuild b/media-sound/amarok/amarok-2.3.1.90.ebuild
index e9ec37745ded..ab6469ee45d9 100644
--- a/media-sound/amarok/amarok-2.3.1.90.ebuild
+++ b/media-sound/amarok/amarok-2.3.1.90.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.3.1.90.ebuild,v 1.1 2010/08/24 01:17:32 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.3.1.90.ebuild,v 1.2 2010/09/19 05:10:25 jmbsvicetto Exp $
EAPI="2"
@@ -46,7 +46,6 @@ COMMONDEPEND="
>=kde-base/libkcompactdisc-${KDE_MINIMAL}
>=kde-base/kdemultimedia-kioslaves-${KDE_MINIMAL}
)
- embedded? ( <dev-db/mysql-5.1[embedded,-minimal] )
ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
lastfm? ( >=media-libs/liblastfm-0.3.0 )
mp3tunes? (
diff --git a/media-sound/amarok/amarok-2.3.2.ebuild b/media-sound/amarok/amarok-2.3.2.ebuild
new file mode 100644
index 000000000000..148f0ace958e
--- /dev/null
+++ b/media-sound/amarok/amarok-2.3.2.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.3.2.ebuild,v 1.1 2010/09/19 05:10:25 jmbsvicetto Exp $
+
+EAPI="2"
+
+# Translations are only in the tarballs, not the git repo
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="af bg ca ca@valencia cs da de el en_GB es et fr it ja lt lv nb nds pa pl
+ pt pt_BR ru sk sl sr sr@ijekavian sr@ijekavianlatin sr@latin sv th tr uk zh_CN zh_TW"
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+else
+ EGIT_REPO_URI="git://git.kde.org/${PN}/${PN}.git"
+ GIT_ECLASS="git"
+fi
+
+KDE_REQUIRED="never"
+inherit flag-o-matic kde4-base ${GIT_ECLASS}
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="4"
+IUSE="cdda daap debug embedded ipod lastfm mp3tunes mtp opengl +player semantic-desktop +utils"
+
+# Tests require gmock - http://code.google.com/p/gmock/
+# It's not in the tree yet
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${P}-flac-fix.patch" )
+
+# ipod requires gdk enabled and also gtk compiled in libgpod
+COMMONDEPEND="
+ >=media-libs/taglib-1.6.1[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ player? (
+ app-crypt/qca:2
+ >=app-misc/strigi-0.5.7[dbus,qt4]
+ || ( >=dev-db/mysql-5.0.76 =virtual/mysql-5.1 )
+ >=kde-base/kdelibs-${KDE_MINIMAL}[opengl?,semantic-desktop?]
+ sys-libs/zlib
+ x11-libs/qt-script
+ >=x11-libs/qtscriptgenerator-0.1.0
+ cdda? (
+ >=kde-base/libkcddb-${KDE_MINIMAL}
+ >=kde-base/libkcompactdisc-${KDE_MINIMAL}
+ >=kde-base/kdemultimedia-kioslaves-${KDE_MINIMAL}
+ )
+ ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
+ lastfm? ( >=media-libs/liblastfm-0.3.0 )
+ mp3tunes? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ x11-libs/qt-core[glib]
+ )
+ mtp? ( >=media-libs/libmtp-1.0.0 )
+ opengl? ( virtual/opengl )
+ )
+ utils? (
+ x11-libs/qt-core
+ x11-libs/qt-dbus
+ )
+ !player? ( !utils? ( media-sound/amarok[player] ) )
+"
+DEPEND="${COMMONDEPEND}
+ dev-util/automoc
+ dev-util/pkgconfig
+"
+RDEPEND="${COMMONDEPEND}
+ !media-sound/amarok-utils
+ player? ( >=kde-base/phonon-kde-${KDE_MINIMAL} )
+"
+
+src_prepare() {
+ if ! use player; then
+ # Disable po processing
+ sed -e "s:include(MacroOptionalAddSubdirectory)::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+ sed -e "s:macro_optional_add_subdirectory( po )::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ # Append minimal-toc cflag for ppc64, see bug 280552 and 292707
+ use ppc64 && append-flags -mminimal-toc
+
+ if use player; then
+ mycmakeargs=(
+ -DWITH_PLAYER=ON
+ -DWITH_Libgcrypt=OFF
+ $(cmake-utils_use embedded WITH_MYSQL_EMBEDDED)
+ $(cmake-utils_use_with ipod)
+ $(cmake-utils_use_with ipod Gdk)
+ $(cmake-utils_use_with lastfm LibLastFm)
+ $(cmake-utils_use_with mtp)
+ $(cmake-utils_use_with mp3tunes MP3Tunes)
+ )
+ else
+ mycmakeargs=(
+ -DWITH_PLAYER=OFF
+ )
+ fi
+
+ mycmakeargs+=(
+ $(cmake-utils_use_with utils UTILITIES)
+ )
+ # $(cmake-utils_use_with semantic-desktop Nepomuk)
+ # $(cmake-utils_use_with semantic-desktop Soprano)
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if use player; then
+
+ if use daap; then
+ echo
+ elog "You have installed amarok with daap support."
+ elog "You may be interested in installing www-servers/mongrel as well."
+ echo
+ fi
+
+ if ! use embedded; then
+ echo
+ elog "You've disabled the amarok support for embedded mysql DBs."
+ elog "You'll have to configure amarok to use an external db server."
+ echo
+ elog "Please read http://amaroklive.com/wiki/MySQL_Server for details on how"
+ elog "to configure the external db and migrate your data from the embedded database."
+ echo
+
+ if has_version "dev-db/mysql[minimal]"; then
+ elog "You built mysql with the minimal use flag, so it doesn't include the server."
+ elog "You won't be able to use the local mysql installation to store your amarok collection."
+ echo
+ fi
+ fi
+ fi
+}
diff --git a/media-sound/amarok/files/amarok-2.3.2-flac-fix.patch b/media-sound/amarok/files/amarok-2.3.2-flac-fix.patch
new file mode 100644
index 000000000000..341582658c46
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.3.2-flac-fix.patch
@@ -0,0 +1,21 @@
+commit ce57e4264d0395b15e7253e3cdef48e36a8b129c
+Author: Jeff Mitchell <mitchell@kde.org>
+Date: Fri Sep 17 13:02:38 2010 -0400
+
+ FLAC BPM tags could be read in incorrectly.
+
+ BUG: 234166
+
+diff --git a/utilities/collectionscanner/CollectionScanner.cpp b/utilities/collectionscanner/CollectionScanner.cpp
+index a9d6755..0a23a53 100644
+--- a/utilities/collectionscanner/CollectionScanner.cpp
++++ b/utilities/collectionscanner/CollectionScanner.cpp
+@@ -701,7 +701,7 @@ CollectionScanner::readTags( const QString &path, TagLib::AudioProperties::ReadS
+ attributes["composer"] = TStringToQString( file->xiphComment()->fieldListMap()["COMPOSER"].front() ).trimmed();
+
+ if ( !file->xiphComment()->fieldListMap()[ "BPM" ].isEmpty() )
+- attributes["bpm"] = TStringToQString( file->xiphComment()->fieldListMap()["BPM"].front() ).trimmed().toFloat();
++ attributes["bpm"] = TStringToQString( file->xiphComment()->fieldListMap()["BPM"].front() ).trimmed();
+
+ if ( !file->xiphComment()->fieldListMap()[ "DISCNUMBER" ].isEmpty() )
+ disc = TStringToQString( file->xiphComment()->fieldListMap()["DISCNUMBER"].front() ).trimmed(); \ No newline at end of file