summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-07-29 07:23:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-07-29 07:23:17 +0000
commitcffd935210048044c07d6fca3cdb225b5a2e8861 (patch)
tree1fef594a75d74a9d3a16fb8beeee075517fb69ac /media-sound/ardour
parentBump for #376847 and 1.9 alpha update (diff)
downloadgentoo-2-cffd935210048044c07d6fca3cdb225b5a2e8861.tar.gz
gentoo-2-cffd935210048044c07d6fca3cdb225b5a2e8861.tar.bz2
gentoo-2-cffd935210048044c07d6fca3cdb225b5a2e8861.zip
Use raptor2 instead of raptor wrt #375027
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/ardour')
-rw-r--r--media-sound/ardour/ChangeLog8
-rw-r--r--media-sound/ardour/ardour-2.8.11-r20.ebuild86
-rw-r--r--media-sound/ardour/files/ardour-2.8.11-raptor2.patch57
3 files changed, 150 insertions, 1 deletions
diff --git a/media-sound/ardour/ChangeLog b/media-sound/ardour/ChangeLog
index dffa98b797c5..f67da903837a 100644
--- a/media-sound/ardour/ChangeLog
+++ b/media-sound/ardour/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/ardour
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.94 2011/05/01 12:04:01 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.95 2011/07/29 07:23:17 ssuominen Exp $
+
+*ardour-2.8.11-r20 (29 Jul 2011)
+
+ 29 Jul 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +ardour-2.8.11-r20.ebuild, +files/ardour-2.8.11-raptor2.patch:
+ Use raptor2 instead of raptor wrt #375027
01 May 2011; Tim Harder <radhermit@gentoo.org> ardour-2.8.11-r1.ebuild:
Conditionally apply the gcc-4.6 patch (bug #365437).
diff --git a/media-sound/ardour/ardour-2.8.11-r20.ebuild b/media-sound/ardour/ardour-2.8.11-r20.ebuild
new file mode 100644
index 000000000000..2b9a407eda74
--- /dev/null
+++ b/media-sound/ardour/ardour-2.8.11-r20.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-2.8.11-r20.ebuild,v 1.1 2011/07/29 07:23:17 ssuominen Exp $
+
+EAPI=4
+inherit eutils flag-o-matic toolchain-funcs scons-utils
+
+DESCRIPTION="Digital Audio Workstation"
+HOMEPAGE="http://ardour.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="altivec curl debug nls lv2 sse"
+
+RDEPEND="media-libs/aubio
+ media-libs/liblo
+ lv2? ( >=media-libs/slv2-0.6.1 )
+ sci-libs/fftw:3.0
+ media-libs/freetype:2
+ >=dev-libs/glib-2.10.1:2
+ dev-cpp/glibmm:2
+ >=x11-libs/gtk+-2.8.1:2
+ >=dev-libs/libxml2-2.6:2
+ >=media-libs/libsndfile-1.0.18
+ >=media-libs/libsamplerate-0.1
+ >=media-libs/rubberband-1.6.0
+ media-libs/libsoundtouch
+ media-libs/flac
+ media-libs/raptor:2
+ >=media-libs/liblrdf-0.4.0-r20
+ >=media-sound/jack-audio-connection-kit-0.109
+ >=gnome-base/libgnomecanvas-2
+ media-libs/vamp-plugin-sdk
+ dev-libs/libxslt
+ dev-libs/libsigc++:2
+ >=dev-cpp/gtkmm-2.16:2.4
+ >=dev-cpp/libgnomecanvasmm-2.26:2.6
+ media-libs/alsa-lib
+ x11-libs/pango
+ x11-libs/cairo
+ media-libs/libart_lgpl
+ virtual/libusb:0
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/${P}-syslibs.patch \
+ "${FILESDIR}"/${P}-type.patch \
+ "${FILESDIR}"/${P}-ldpath.patch \
+ "${FILESDIR}"/${P}-raptor2.patch
+
+ if [[ ($(gcc-major-version) -eq 4 && $(gcc-minor-version) -ge 6) ]]; then
+ epatch "${FILESDIR}"/${P}-gcc46.patch
+ fi
+}
+
+src_compile() {
+ local FPU_OPTIMIZATION=$($(use altivec || use sse) && echo 1 || echo 0)
+ tc-export CC CXX
+ append-cxxflags -D__STDC_FORMAT_MACROS
+ mkdir -p "${D}"
+
+ escons \
+ DESTDIR="${D}" \
+ FPU_OPTIMIZATION="${FPU_OPTIMIZATION}" \
+ PREFIX=/usr \
+ SYSLIBS=1 \
+ $(use_scons curl FREESOUND) \
+ $(use_scons debug DEBUG) \
+ $(use_scons nls NLS) \
+ $(use_scons lv2 LV2)
+}
+
+src_install() {
+ escons install
+ doman ${PN}.1
+ newicon icons/icon/ardour_icon_mac.png ${PN}.png
+ make_desktop_entry ardour2 ardour AudioVideo
+}
diff --git a/media-sound/ardour/files/ardour-2.8.11-raptor2.patch b/media-sound/ardour/files/ardour-2.8.11-raptor2.patch
new file mode 100644
index 000000000000..405e1a83e5d3
--- /dev/null
+++ b/media-sound/ardour/files/ardour-2.8.11-raptor2.patch
@@ -0,0 +1,57 @@
+http://projects.archlinux.org/svntogit/packages.git/plain/ardour/trunk/raptor2.patch
+
+--- SConstruct
++++ SConstruct
+@@ -431,7 +431,6 @@
+ 'gtk+-2.0' : '2.8.1',
+ 'libxml-2.0' : '2.6.0',
+ 'samplerate' : '0.1.0',
+- 'raptor' : '1.4.2',
+ 'lrdf' : '0.4.0',
+ 'jack' : '0.109.0',
+ 'libgnomecanvas-2.0' : '2.0',
+@@ -487,7 +486,10 @@
+
+ libraries['core'] = LibraryInfo (CCFLAGS = '-Ilibs')
+
+-conf = env.Configure (custom_tests = { 'CheckPKGExists' : CheckPKGExists } )
++conf = env.Configure (custom_tests = { 'CheckPKGExists' : CheckPKGExists,
++ 'CheckPKGVersion' : CheckPKGVersion }
++ )
++
+
+ if conf.CheckPKGExists ('fftw3f'):
+ libraries['fftw3f'] = LibraryInfo()
+@@ -501,6 +503,22 @@
+ libraries['aubio'] = LibraryInfo()
+ libraries['aubio'].ParseConfig('pkg-config --cflags --libs aubio')
+
++raptorOK = 0
++
++if conf.CheckPKGExists ('raptor2'):
++ libraries['raptor'] = LibraryInfo()
++ libraries['raptor'].ParseConfig('pkg-config --cflags --libs raptor2')
++ raptorOK = 1
++else:
++ if conf.CheckPKGExists ('raptor') and conf.CheckPKGVersion (pkg, '1.4.2'):
++ libraries['raptor'] = LibraryInfo()
++ libraries['raptor'].ParseConfig('pkg-config --cflags --libs raptor')
++ raptorOK = 1
++
++if raptorOK == 0:
++ print "Ardour requires either raptor or raptor2 to be available at build time"
++ Exit (1)
++
+ env = conf.Finish ()
+
+ if env['FFT_ANALYSIS']:
+@@ -570,9 +588,6 @@
+ libraries['lrdf'] = LibraryInfo()
+ libraries['lrdf'].ParseConfig('pkg-config --cflags --libs lrdf')
+
+-libraries['raptor'] = LibraryInfo()
+-libraries['raptor'].ParseConfig('pkg-config --cflags --libs raptor')
+-
+ libraries['sndfile'] = LibraryInfo()
+ libraries['sndfile'].ParseConfig ('pkg-config --cflags --libs sndfile')
+