summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-11-18 20:28:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-11-18 20:28:32 +0000
commitbc9bd6ff1573403f074ba29607a92a62cf1fffac (patch)
tree973d14c9a286e93e7623ea05292584fff0cdb99a /media-sound/audacity/audacity-1.3.4.ebuild
parentadd a check for flac cxx use flag, FLAC++ is needed here (diff)
downloadgentoo-2-bc9bd6ff1573403f074ba29607a92a62cf1fffac.tar.gz
gentoo-2-bc9bd6ff1573403f074ba29607a92a62cf1fffac.tar.bz2
gentoo-2-bc9bd6ff1573403f074ba29607a92a62cf1fffac.zip
add a check for flac cxx use flag, FLAC++ is needed here
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-sound/audacity/audacity-1.3.4.ebuild')
-rw-r--r--media-sound/audacity/audacity-1.3.4.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/media-sound/audacity/audacity-1.3.4.ebuild b/media-sound/audacity/audacity-1.3.4.ebuild
index 7c6987264045..49b3a9333789 100644
--- a/media-sound/audacity/audacity-1.3.4.ebuild
+++ b/media-sound/audacity/audacity-1.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.4.ebuild,v 1.2 2007/11/18 17:07:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.4.ebuild,v 1.3 2007/11/18 20:28:32 aballier Exp $
inherit eutils wxwidgets
@@ -33,6 +33,14 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${MY_P}-beta"
+pkg_setup() {
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+}
+
src_unpack() {
unpack ${A}