summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-12-13 23:00:48 +0000
committerTim Harder <radhermit@gentoo.org>2011-12-13 23:00:48 +0000
commita98a71e66e5da85874b7a1a3454b0bd1c72856bb (patch)
treed792b956c5a640def4551fde43d500a0d08b387c /media-sound/audacity
parentStable for AMD64, wrt bug #392861 (diff)
downloadgentoo-2-a98a71e66e5da85874b7a1a3454b0bd1c72856bb.tar.gz
gentoo-2-a98a71e66e5da85874b7a1a3454b0bd1c72856bb.tar.bz2
gentoo-2-a98a71e66e5da85874b7a1a3454b0bd1c72856bb.zip
Version bump.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/audacity')
-rw-r--r--media-sound/audacity/ChangeLog8
-rw-r--r--media-sound/audacity/audacity-1.3.14.ebuild97
-rw-r--r--media-sound/audacity/files/audacity-1.3.14-typecast.patch15
3 files changed, 119 insertions, 1 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index 1d30977fc914..7bfba3ae05c8 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audacity
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.161 2011/08/07 17:08:16 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.162 2011/12/13 23:00:48 radhermit Exp $
+
+*audacity-1.3.14 (13 Dec 2011)
+
+ 13 Dec 2011; Tim Harder <radhermit@gentoo.org> +audacity-1.3.14.ebuild,
+ +files/audacity-1.3.14-typecast.patch:
+ Version bump.
07 Aug 2011; Tim Harder <radhermit@gentoo.org> -audacity-1.3.8.ebuild,
-files/audacity-1.3.8-automagic.patch,
diff --git a/media-sound/audacity/audacity-1.3.14.ebuild b/media-sound/audacity/audacity-1.3.14.ebuild
new file mode 100644
index 000000000000..e6b3d77222b0
--- /dev/null
+++ b/media-sound/audacity/audacity-1.3.14.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.14.ebuild,v 1.1 2011/12/13 23:00:48 radhermit Exp $
+
+EAPI=4
+
+inherit eutils wxwidgets autotools versionator
+
+MY_PV=$(replace_version_separator 3 -)
+MY_P="${PN}-src-${MY_PV}-beta"
+MY_T="${PN}-minsrc-${MY_PV}-beta"
+DESCRIPTION="Free crossplatform audio editor"
+HOMEPAGE="http://audacity.sourceforge.net/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_T}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="alsa ffmpeg flac id3tag jack ladspa libsamplerate midi mp3 soundtouch twolame vamp vorbis"
+RESTRICT="test"
+
+COMMON_DEPEND="x11-libs/wxGTK:2.8[X]
+ >=app-arch/zip-2.3
+ >=media-libs/libsndfile-1.0.0
+ dev-libs/expat
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )
+ vorbis? ( >=media-libs/libvorbis-1.0 )
+ mp3? ( >=media-libs/libmad-0.14.2b )
+ flac? ( >=media-libs/flac-1.2.0[cxx] )
+ id3tag? ( media-libs/libid3tag )
+ soundtouch? ( >=media-libs/libsoundtouch-1.3.1 )
+ vamp? ( >=media-libs/vamp-plugin-sdk-2.0 )
+ twolame? ( media-sound/twolame )
+ ffmpeg? ( virtual/ffmpeg )
+ alsa? ( media-libs/alsa-lib )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.103.0 )"
+# Crashes at startup here...
+# lv2? ( >=media-libs/slv2-0.6.0 )
+# Disabled upstream ATM
+# ladspa? ( >=media-libs/liblrdf-0.4.0 )
+
+RDEPEND="${COMMON_DEPEND}
+ mp3? ( >=media-sound/lame-3.70 )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+REQUIRED_USE="soundtouch? ( midi )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.3.13-automagic.patch
+ epatch "${FILESDIR}"/${PN}-1.3.13-ffmpeg.patch
+ epatch "${FILESDIR}"/${P}-typecast.patch
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
+src_configure() {
+ WX_GTK_VER="2.8"
+ need-wxwidgets unicode
+
+ # * always use system libraries if possible
+ # * options listed in the order that configure --help lists them
+ # * if libsamplerate not requested, use libresample instead.
+ econf \
+ --enable-unicode \
+ --enable-nyquist \
+ $(use_enable ladspa) \
+ --with-libsndfile=system \
+ --with-expat=system \
+ $(use_with libsamplerate) \
+ $(use_with !libsamplerate libresample) \
+ $(use_with vorbis libvorbis) \
+ $(use_with mp3 libmad) \
+ $(use_with flac libflac) \
+ $(use_with id3tag libid3tag) \
+ $(use_with soundtouch) \
+ $(use_with vamp libvamp) \
+ $(use_with twolame libtwolame) \
+ $(use_with ffmpeg) \
+ $(use_with midi) \
+ $(use_with alsa) \
+ $(use_with jack)
+}
+
+# $(use_with lv2 slv2) \
+# $(use_with ladspa liblrdf) \
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Remove bad doc install
+ rm -rf "${D}"/usr/share/doc
+
+ # Install our docs
+ dodoc README.txt
+}
diff --git a/media-sound/audacity/files/audacity-1.3.14-typecast.patch b/media-sound/audacity/files/audacity-1.3.14-typecast.patch
new file mode 100644
index 000000000000..c01046143b21
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.14-typecast.patch
@@ -0,0 +1,15 @@
+--- audacity-src-1.3.14-beta/src/TrackPanel.cpp.orig
++++ audacity-src-1.3.14-beta/src/TrackPanel.cpp
+@@ -2915,7 +2915,11 @@
+ {
+ // Make sure we always have the first linked track of a stereo track
+ if (!mouseTrack->GetLinked() && mTracks->GetLink(mouseTrack))
+- mouseTrack = mTracks->GetLink(mouseTrack);
++ mouseTrack =
++#ifndef USE_MIDI
++ (WaveTrack*)
++#endif
++ mTracks->GetLink(mouseTrack);
+
+ // Temporary apply the offset because we want to see if the
+ // track fits with the desired offset