summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-03-30 00:20:07 +0000
committerCédric Krier <cedk@gentoo.org>2008-03-30 00:20:07 +0000
commit5454aec7e33ec69977416dee73881b90130db4ec (patch)
treea48d22204bb829f395a6648ac9ddba84f319e82b /media-sound/audicle
parentStable on x86 wrt bug #215047 (diff)
downloadgentoo-2-5454aec7e33ec69977416dee73881b90130db4ec.tar.gz
gentoo-2-5454aec7e33ec69977416dee73881b90130db4ec.tar.bz2
gentoo-2-5454aec7e33ec69977416dee73881b90130db4ec.zip
New ebuild for bug #144667
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-sound/audicle')
-rw-r--r--media-sound/audicle/ChangeLog11
-rw-r--r--media-sound/audicle/Manifest6
-rw-r--r--media-sound/audicle/audicle-1.0.0.6.ebuild81
-rw-r--r--media-sound/audicle/files/audicle-1.0.0.6-font.patch65
-rw-r--r--media-sound/audicle/files/audicle-1.0.0.6-hid-smc.patch148
-rw-r--r--media-sound/audicle/metadata.xml15
6 files changed, 326 insertions, 0 deletions
diff --git a/media-sound/audicle/ChangeLog b/media-sound/audicle/ChangeLog
new file mode 100644
index 000000000000..658bab669052
--- /dev/null
+++ b/media-sound/audicle/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-sound/audicle
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audicle/ChangeLog,v 1.1 2008/03/30 00:20:06 cedk Exp $
+
+*audicle-1.0.0.6 (30 Mar 2008)
+
+ 30 Mar 2008; Cédric Krier <cedk@gentoo.org>
+ +files/audicle-1.0.0.6-font.patch, +files/audicle-1.0.0.6-hid-smc.patch,
+ +metadata.xml, +audicle-1.0.0.6.ebuild:
+ New ebuild for bug #144667
+
diff --git a/media-sound/audicle/Manifest b/media-sound/audicle/Manifest
new file mode 100644
index 000000000000..06e163b77e0e
--- /dev/null
+++ b/media-sound/audicle/Manifest
@@ -0,0 +1,6 @@
+AUX audicle-1.0.0.6-font.patch 2862 RMD160 12edc5098b4ae21adbdcc0eaef7b6c386329dd44 SHA1 2d0845bad78570b084087f4489c86bb24f6eabd2 SHA256 ca958277aaead8c7cfe4f02a4ee78a0ba3d527bfb61857f4e349ad8f1389c152
+AUX audicle-1.0.0.6-hid-smc.patch 3105 RMD160 759c6d34beb8fb00be475f7c82f2f313d4f22e6c SHA1 21e2b0875483598ed5fdeabd07911b59d98d00c4 SHA256 051cffc2db8207f5e78cec4fa059580fc734c57d00b0055eb9de7a67b10c462d
+DIST audicle-1.0.0.6.tgz 5531625 RMD160 66a4a69b2a7dbe0d8aa705358f71c0d8df312a3e SHA1 c8967cfb3238064fb12cb91d0fcf19dc90628bb4 SHA256 685b86a263e92be279ccbae001202b159175363ecc87d8a7bc521f8a42a92f90
+EBUILD audicle-1.0.0.6.ebuild 2075 RMD160 f38e861255f012715d6811446cf732306c4cfa57 SHA1 88bdc942863111c020aff8bc866386b787c062e4 SHA256 9aedb595ca92b2e6113bb19aa07b542b335775d5f845347752530a72195dde1f
+MISC ChangeLog 346 RMD160 bf6307591b2a82ab7d5f2438fd5fbccb77874c02 SHA1 b9c163b0c019a29cabf64283d0bffaba4562c651 SHA256 3f84e9a4d877eaafaeb08c00cba66526d5f1ca3d145b69e19d66680c747ce665
+MISC metadata.xml 472 RMD160 4062e70f23fec1b713ec4661229c94fe3b5977e5 SHA1 37e6ab7cdce21b32d6c434bfaf2a23d03ea70499 SHA256 5bafa4cb9fb7a68864b326ac3b15881be3e2f9e52f0b23f47d50581e4998d895
diff --git a/media-sound/audicle/audicle-1.0.0.6.ebuild b/media-sound/audicle/audicle-1.0.0.6.ebuild
new file mode 100644
index 000000000000..2e5c07a7db91
--- /dev/null
+++ b/media-sound/audicle/audicle-1.0.0.6.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audicle/audicle-1.0.0.6.ebuild,v 1.1 2008/03/30 00:20:06 cedk Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A Context-sensitive, On-the-fly Audio Programming Environ/mentality"
+HOMEPAGE="http://audicle.cs.princeton.edu/"
+SRC_URI="http://audicle.cs.princeton.edu/release/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="oss jack alsa truetype"
+
+RDEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ media-libs/libsndfile
+ virtual/glut
+ virtual/opengl
+ virtual/glu
+ >=x11-libs/gtk+-2
+ truetype? ( media-libs/ftgl
+ media-fonts/corefonts )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-font.patch"
+ epatch "${FILESDIR}/${P}-hid-smc.patch"
+
+ sed -i \
+ -e "s@../ftgl_lib/FTGL/include@/usr/include/FTGL@" \
+ -e "s@../ftgl_lib/FTGL/mac/build@/usr/lib@" \
+ src/makefile.{alsa,jack,oss} || die "sed failed"
+}
+
+pkg_setup() {
+ local cnt=0
+ use jack && cnt="$((${cnt} + 1))"
+ use alsa && cnt="$((${cnt} + 1))"
+ use oss && cnt="$((${cnt} + 1))"
+ if [[ "${cnt}" -eq 0 ]]; then
+ eerror "One of the following USE flags is needed: jack, alsa or oss"
+ die "Please set one audio engine type"
+ elif [[ "${cnt}" -ne 1 ]]; then
+ ewarn "You have set ${P} to use multiple audio engine."
+ fi
+}
+
+src_compile() {
+ local backend
+ if use jack; then
+ backend="jack"
+ elif use alsa; then
+ backend="alsa"
+ elif use oss; then
+ backend="oss"
+ fi
+ einfo "Compiling against ${backend}"
+ local config
+ use truetype && config="USE_FREETYPE_LIBS=1"
+
+ # when compile with athlon or athlon-xp flags
+ # audicle crashes on removing a shred with a double free or corruption
+ # it happens in Chuck_VM_Stack::shutdown() on the line
+ # SAFE_DELETE_ARRAY( stack );
+ replace-cpu-flags athlon athlon-xp i686
+
+ cd "${S}/src"
+ emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) $config || die "emake failed"
+}
+
+src_install() {
+ dobin src/audicle
+
+ dodoc AUTHORS PROGRAMMER README THANKS TODO VERSIONS
+}
diff --git a/media-sound/audicle/files/audicle-1.0.0.6-font.patch b/media-sound/audicle/files/audicle-1.0.0.6-font.patch
new file mode 100644
index 000000000000..9e2658df16c3
--- /dev/null
+++ b/media-sound/audicle/files/audicle-1.0.0.6-font.patch
@@ -0,0 +1,65 @@
+diff -ru audicle-1.0.0.6~/src/audicle_font.cpp audicle-1.0.0.6/src/audicle_font.cpp
+--- audicle-1.0.0.6~/src/audicle_font.cpp 2008-03-30 00:29:37.000000000 +0100
++++ audicle-1.0.0.6/src/audicle_font.cpp 2008-03-30 01:04:46.000000000 +0100
+@@ -201,13 +201,13 @@
+ #ifdef __PLATFORM_WIN32__
+ char fontpath[] = "C:\\WINDOWS\\FONTS\\";
+ #else
+-char fontpath[] = "/define/this/directory/";
++char fontpath[] = "/usr/share/fonts/corefonts/";
+
+ #endif
+ #endif
+
+-char kernedfontfile[] = "FTGL:verdana.TTF";
+-char monospacedfontfile[] = "FTGL:LUCON.TTF";
++char kernedfontfile[] = "FTGL:verdana.ttf";
++char monospacedfontfile[] = "FTGL:couri.ttf";
+
+
+ class AudicleFTGLFont : public AudicleFont {
+@@ -301,13 +301,11 @@
+ #endif
+
+ // we should do a directory scan here...
+- AudicleFont::available_fonts().push_back( "FTGL:ARIAL.TTF" );
+- AudicleFont::available_fonts().push_back( "FTGL:ARIBLK.TTF" );
+- AudicleFont::available_fonts().push_back( "FTGL:BYTE.TTF" );
+- AudicleFont::available_fonts().push_back( "FTGL:COUR.TTF" );
+- AudicleFont::available_fonts().push_back( "FTGL:LUCON.TTF" );
+- AudicleFont::available_fonts().push_back( "FTGL:TIMES.TTF" );
+- AudicleFont::available_fonts().push_back( "FTGL:verdana.TTF" );
++ AudicleFont::available_fonts().push_back( "FTGL:arial.ttf" );
++ AudicleFont::available_fonts().push_back( "FTGL:ariblk.ttf" );
++ AudicleFont::available_fonts().push_back( "FTGL:cour.ttf" );
++ AudicleFont::available_fonts().push_back( "FTGL:times.ttf" );
++ AudicleFont::available_fonts().push_back( "FTGL:verdana.ttf" );
+
+ };
+
+diff -ru audicle-1.0.0.6~/src/audicle_ui_base.cpp audicle-1.0.0.6/src/audicle_ui_base.cpp
+--- audicle-1.0.0.6~/src/audicle_ui_base.cpp 2008-03-30 00:29:37.000000000 +0100
++++ audicle-1.0.0.6/src/audicle_ui_base.cpp 2008-03-30 00:30:32.000000000 +0100
+@@ -47,8 +47,8 @@
+ void init_UI_Fonts() {
+ if ( _ui_fonts_inited ) return;
+ #ifdef _USE_FTGL_FONTS_
+- labelFont = AudicleFont::loadFont ( "FTGL:verdana.TTF" );
+- labelFontMono = AudicleFont::loadFont ( "FTGL:LUCON.TTF" );
++ labelFont = AudicleFont::loadFont ( "FTGL:verdana.ttf" );
++ labelFontMono = AudicleFont::loadFont ( "FTGL:couri.ttf" );
+ #else
+ labelFont = AudicleFont::loadFont ( "OpenGL:variable" );
+ labelFontMono = AudicleFont::loadFont ( "OpenGL:variable" );
+diff -ru audicle-1.0.0.6~/src/audicle_ui_editor.cpp audicle-1.0.0.6/src/audicle_ui_editor.cpp
+--- audicle-1.0.0.6~/src/audicle_ui_editor.cpp 2008-03-30 00:29:37.000000000 +0100
++++ audicle-1.0.0.6/src/audicle_ui_editor.cpp 2008-03-30 00:30:32.000000000 +0100
+@@ -46,7 +46,7 @@
+
+ void init_Buffer_Font() {
+ #ifdef _USE_FTGL_FONTS_
+- bufferFont = AudicleFont::loadFont ( "FTGL:LUCON.TTF" );
++ bufferFont = AudicleFont::loadFont ( "FTGL:couri.ttf" );
+ #else
+ bufferFont = AudicleFont::loadFont ( "OpenGL:mono" );
+ #endif
diff --git a/media-sound/audicle/files/audicle-1.0.0.6-hid-smc.patch b/media-sound/audicle/files/audicle-1.0.0.6-hid-smc.patch
new file mode 100644
index 000000000000..358f0801bbe4
--- /dev/null
+++ b/media-sound/audicle/files/audicle-1.0.0.6-hid-smc.patch
@@ -0,0 +1,148 @@
+diff -ru audicle-1.0.0.6~/lang/chuck-1.2.1.1/src/util_hid.cpp audicle-1.0.0.6/lang/chuck-1.2.1.1/src/util_hid.cpp
+--- audicle-1.0.0.6~/lang/chuck-1.2.1.1/src/util_hid.cpp 2008-03-30 00:29:37.000000000 +0100
++++ audicle-1.0.0.6/lang/chuck-1.2.1.1/src/util_hid.cpp 2008-03-30 00:33:08.000000000 +0100
+@@ -7175,14 +7175,139 @@
+ int WiiRemote_send( const HidMsg * msg ){ return -1; }
+ const char * WiiRemote_name( int wr ){ return NULL; }
+
++#define SYSFS_TILTSENSOR_FILE "/sys/devices/platform/applesmc/position"
++#define TILTSENSOR_BUF_LEN 32
++
++static struct t_TiltSensor_data
++{
++ union
++ {
++ struct t_macbook
++ {
++ int x;
++ int y;
++ int z;
++ } macbook;
++ } data;
++ int dataType;
++ int detected;
++ int refcount;
++
++ t_TiltSensor_data()
++ {
++ refcount = 0;
++ dataType = -1;
++ detected = 0;
++ }
++
++} TiltSensor_data;
++enum
++{
++ linuxAppleSMCMacBookDataType
++};
++static int TiltSensor_detect()
++{
++ int fd;
++
++ fd = open(SYSFS_TILTSENSOR_FILE, O_RDONLY);
++
++ if (fd > 0)
++ {
++ TiltSensor_data.dataType = linuxAppleSMCMacBookDataType;
++ TiltSensor_data.detected = 1;
++ close(fd);
++ return 1;
++ }
++
++ TiltSensor_data.detected = -1;
++
++ return 0;
++}
++
++static int TiltSensor_do_read()
++{
++
++ switch(TiltSensor_data.dataType)
++ {
++ case linuxAppleSMCMacBookDataType:
++ char buf[TILTSENSOR_BUF_LEN];
++ int ret, fd;
++ fd = open(SYSFS_TILTSENSOR_FILE, O_RDONLY);
++
++ if (fd < 0) {
++ return -1;
++ }
++ ret = read(fd, buf, TILTSENSOR_BUF_LEN);
++ if (ret < 0) {
++ close(fd);
++ return -1;
++ }
++ if (sscanf(buf, "(%d,%d,%d)\n", &TiltSensor_data.data.macbook.x, &TiltSensor_data.data.macbook.y, &TiltSensor_data.data.macbook.z) != 3) {
++ close(fd);
++ return -1;
++ }
++ close(fd);
++ break;
++ default:
++ return 0;
++ }
++ return 1;
++}
+ void TiltSensor_init(){}
+ void TiltSensor_quit(){}
+ void TiltSensor_probe(){}
+-int TiltSensor_count(){ return 0; }
+-int TiltSensor_open( int ts ){ return -1; }
+-int TiltSensor_close( int ts ){ return -1; }
+-int TiltSensor_read( int ts, int type, int num, HidMsg * msg ){ return -1; }
+-const char * TiltSensor_name( int ts ){ return NULL; }
++int TiltSensor_count()
++{
++ if(TiltSensor_data.detected == 0)
++ TiltSensor_detect();
++
++ if(TiltSensor_data.detected == -1)
++ return 0;
++ else if(TiltSensor_data.detected == 1)
++ return 1;
++
++ return 0;
++}
++int TiltSensor_open( int ts )
++{
++ if(TiltSensor_data.detected == 0)
++ TiltSensor_detect();
++
++ if(TiltSensor_data.detected == -1)
++ return -1;
++
++ TiltSensor_data.refcount++;
++
++ return 0;
++}
++int TiltSensor_close( int ts )
++{
++ TiltSensor_data.refcount--;
++
++ return 0;
++}
++int TiltSensor_read( int ts, int type, int num, HidMsg * msg )
++{
++
++ if(TiltSensor_data.detected == -1)
++ return -1;
++
++ if(!TiltSensor_do_read())
++ return -1;
++
++ if(TiltSensor_data.dataType == linuxAppleSMCMacBookDataType)
++ {
++ msg->idata[0] = TiltSensor_data.data.macbook.x;
++ msg->idata[1] = TiltSensor_data.data.macbook.y;
++ msg->idata[2] = TiltSensor_data.data.macbook.z;
++ }
++
++ return 0;
++}
++const char * TiltSensor_name( int ts )
++{
++ return "Apple Sudden Motion Sensor";
++}
+
+
+ #endif
diff --git a/media-sound/audicle/metadata.xml b/media-sound/audicle/metadata.xml
new file mode 100644
index 000000000000..322fe315b562
--- /dev/null
+++ b/media-sound/audicle/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>cedk@gentoo.org</email>
+ <name>Cédric Krier</name>
+ </maintainer>
+ <longdescription lang="en">
+ a potentially new type of audio programming environment that integrates
+ the programmability of the development environment with elements of the
+ runtime environment
+ </longdescription>
+</pkgmetadata>
+