summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-02-06 20:37:09 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-02-06 20:37:09 +0000
commite887c7d5f0d7fcc9382f5c118eebd3b3296ebdc0 (patch)
tree7638198561a096c4a45392a9229382d486ab8d74 /media-sound/cantus/cantus-20060206.ebuild
parentMark 0.1.9 stable on ia64 (diff)
downloadgentoo-2-e887c7d5f0d7fcc9382f5c118eebd3b3296ebdc0.tar.gz
gentoo-2-e887c7d5f0d7fcc9382f5c118eebd3b3296ebdc0.tar.bz2
gentoo-2-e887c7d5f0d7fcc9382f5c118eebd3b3296ebdc0.zip
Version bump
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'media-sound/cantus/cantus-20060206.ebuild')
-rw-r--r--media-sound/cantus/cantus-20060206.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/cantus/cantus-20060206.ebuild b/media-sound/cantus/cantus-20060206.ebuild
new file mode 100644
index 000000000000..1307491a1038
--- /dev/null
+++ b/media-sound/cantus/cantus-20060206.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cantus/cantus-20060206.ebuild,v 1.1 2006/02/06 20:37:09 chutzpah Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Easy to use tool for tagging and renaming MP3 and OGG/Vorbis files"
+HOMEPAGE="http://www.debain.org/software/cantus"
+
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND="media-libs/libvorbis
+ media-libs/libogg
+ >=dev-cpp/gtkmm-2.4.0
+ >=dev-cpp/libglademm-2.4.0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-gentoo.patch
+}
+
+src_compile() {
+ GENTOO_LIBDIR="$(get_libdir)" ./build.sh --prefix /usr || die "Build failed"
+}
+
+src_install() {
+ # this package has an amazingly stupid installer
+ dodir /usr/$(get_libdir)
+ GENTOO_LIBDIR="$(get_libdir)" ./build.sh --install --prefix ${D}/usr || die "Install failed"
+
+ rm -rf "${D}"/usr/doc "${D}"/usr/share/gnome/help/cantus_3/C/figures/CVS/
+ dodoc AUTHORS TODO README NEWS CHANGELOG
+
+ insinto /usr/share/pixmaps
+ newins ${FILESDIR}/${PN}.png ${PN}3.png
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+}