summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-04-28 22:54:18 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-04-28 22:54:18 +0000
commit025e9c3e1443492c10d911058127af2ccbb2bbd6 (patch)
treebd3dbec9296bee2c4d9d6ddad86f1605e855b4fd /media-sound/cmus
parentVersion bump (bug #201846). (diff)
downloadgentoo-2-025e9c3e1443492c10d911058127af2ccbb2bbd6.tar.gz
gentoo-2-025e9c3e1443492c10d911058127af2ccbb2bbd6.tar.bz2
gentoo-2-025e9c3e1443492c10d911058127af2ccbb2bbd6.zip
make it work with some newer versions of ffmpeg, see bug 218105; patch provided by Ben de Groot <yngwin AT gentoo DOT org>
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-sound/cmus')
-rw-r--r--media-sound/cmus/ChangeLog9
-rw-r--r--media-sound/cmus/cmus-2.2.0.ebuild13
-rw-r--r--media-sound/cmus/files/cmus-2.2.0-new-ffmpeg.patch15
3 files changed, 33 insertions, 4 deletions
diff --git a/media-sound/cmus/ChangeLog b/media-sound/cmus/ChangeLog
index 5a9e6c92fb73..4d75355f119f 100644
--- a/media-sound/cmus/ChangeLog
+++ b/media-sound/cmus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/cmus
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cmus/ChangeLog,v 1.17 2007/10/14 11:34:11 opfer Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cmus/ChangeLog,v 1.18 2008/04/28 22:54:17 opfer Exp $
+
+ 28 Apr 2008; Christian Faulhammer <opfer@gentoo.org>
+ +files/cmus-2.2.0-new-ffmpeg.patch, cmus-2.2.0.ebuild:
+ make it work with some newer versions of ffmpeg, see bug 218105; patch
+ provided by Ben de Groot <yngwin AT gentoo DOT org>
14 Oct 2007; Christian Faulhammer <opfer@gentoo.org> cmus-2.2.0.ebuild:
new HOMEPAGE value and new download location
diff --git a/media-sound/cmus/cmus-2.2.0.ebuild b/media-sound/cmus/cmus-2.2.0.ebuild
index dfff93c3c1df..5b1852b45187 100644
--- a/media-sound/cmus/cmus-2.2.0.ebuild
+++ b/media-sound/cmus/cmus-2.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cmus/cmus-2.2.0.ebuild,v 1.6 2007/10/14 11:34:11 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cmus/cmus-2.2.0.ebuild,v 1.7 2008/04/28 22:54:17 opfer Exp $
inherit eutils multilib
@@ -54,6 +54,15 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}"
+ if $(has_version ">=media-video/ffmpeg-0.4.9_p20080326")
+ then
+ epatch "${FILESDIR}"/${P}-new-ffmpeg.patch
+ fi
+}
+
src_compile() {
local debuglevel=1 myconf="CONFIG_SUN=n"
diff --git a/media-sound/cmus/files/cmus-2.2.0-new-ffmpeg.patch b/media-sound/cmus/files/cmus-2.2.0-new-ffmpeg.patch
new file mode 100644
index 000000000000..89812b21b193
--- /dev/null
+++ b/media-sound/cmus/files/cmus-2.2.0-new-ffmpeg.patch
@@ -0,0 +1,15 @@
+--- cmus-2.2.0-orig/ffmpeg.c 2007-07-27 16:52:13.000000000 +0200
++++ cmus-2.2.0/ffmpeg.c 2008-04-25 16:32:40.000000000 +0200
+@@ -18,9 +18,9 @@
+ */
+
+ #include <stdio.h>
+-#include <ffmpeg/avcodec.h>
+-#include <ffmpeg/avformat.h>
+-#include <ffmpeg/avio.h>
++#include <libavcodec/avcodec.h>
++#include <libavformat/avformat.h>
++#include <libavformat/avio.h>
+
+ #include "ip.h"
+ #include "xmalloc.h"