summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-05 08:49:45 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-05 08:49:45 +0000
commit83ab4b43732f05ea7476cf5c16c9770b11da8d08 (patch)
tree0446737ee74a4c8133dd1621453626ae0b7cedfd /media-sound/daapd/daapd-0.2.3d.ebuild
parentStable on x86 and ppc; bug #66274. (Manifest recommit) (diff)
downloadgentoo-2-83ab4b43732f05ea7476cf5c16c9770b11da8d08.tar.gz
gentoo-2-83ab4b43732f05ea7476cf5c16c9770b11da8d08.tar.bz2
gentoo-2-83ab4b43732f05ea7476cf5c16c9770b11da8d08.zip
Version bump closes bug #66364. Added ~amd64.
Diffstat (limited to 'media-sound/daapd/daapd-0.2.3d.ebuild')
-rw-r--r--media-sound/daapd/daapd-0.2.3d.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-sound/daapd/daapd-0.2.3d.ebuild b/media-sound/daapd/daapd-0.2.3d.ebuild
new file mode 100644
index 000000000000..e82c01a183f6
--- /dev/null
+++ b/media-sound/daapd/daapd-0.2.3d.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/daapd/daapd-0.2.3d.ebuild,v 1.1 2004/10/05 08:49:45 eradicator Exp $
+
+IUSE="mpeg4 howl"
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="daapd scans a directory for mp3 files and makes them available via the Apple proprietary protocol DAAP"
+HOMEPAGE="http://www.deleet.de/projekte/daap/daapd/"
+SRC_URI="http://www.deleet.de/projekte/daap/daapd/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+
+DEPEND="zlib? ( sys-libs/zlib )
+ howl? ( >=net-misc/howl-0.9.6-r1 )
+ mpeg4? ( media-libs/faad2 )
+ >=media-libs/libid3tag-0.15.0b
+ >=net-libs/libhttpd-persistent-1.3p-r8
+ >=media-libs/daaplib-0.1.1a"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+
+ cd ${S}
+ if ! use zlib; then
+ sed -ie 's/ZLIB_ENABLE = 1/ZLIB_ENABLE = 0/g' makefile
+ fi
+
+ if ! use howl; then
+ sed -ie 's/HOWL_ENABLE = 1/HOWL_ENABLE = 0/g' makefile
+ fi
+
+ if ! use mpeg4; then
+ sed -ie 's/MPEG4_ENABLE = 1/MPEG4_ENABLE = 0/g' makefile
+ fi
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin daapd
+
+ dodoc COPYING README* daapd-example.conf
+ doman ${PN}.8
+
+ insinto /etc
+ newins daapd-example.conf daapd.conf
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/daapd.conf.d daapd || die
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/daapd.init.d daapd || die
+}
+