summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-22 22:43:14 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-22 22:43:14 +0000
commitd93b92ff4c0c4e33fb986ac56118a7a9ba7da471 (patch)
treee06e9d508a9297d821fb91f751a3c58f61d15a7e /media-sound/ecasound/ecasound-2.4.3.ebuild
parentRemoving SRC_TEST since when enabled, it requires a display (and another module) (diff)
downloadgentoo-2-d93b92ff4c0c4e33fb986ac56118a7a9ba7da471.tar.gz
gentoo-2-d93b92ff4c0c4e33fb986ac56118a7a9ba7da471.tar.bz2
gentoo-2-d93b92ff4c0c4e33fb986ac56118a7a9ba7da471.zip
Use $(get_libdir) to get the site's dir for python modules.
(Portage version: 2529-svn)
Diffstat (limited to 'media-sound/ecasound/ecasound-2.4.3.ebuild')
-rw-r--r--media-sound/ecasound/ecasound-2.4.3.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/media-sound/ecasound/ecasound-2.4.3.ebuild b/media-sound/ecasound/ecasound-2.4.3.ebuild
index 0603db3df88c..fb65fc0e7c0b 100644
--- a/media-sound/ecasound/ecasound-2.4.3.ebuild
+++ b/media-sound/ecasound/ecasound-2.4.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.3.ebuild,v 1.3 2005/12/26 14:42:15 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.3.ebuild,v 1.4 2006/01/22 22:43:14 flameeyes Exp $
+
+inherit multilib
IUSE="alsa arts audiofile debug jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
@@ -56,7 +58,7 @@ src_compile () {
python_prefix="`python -c 'import sys; print sys.prefix'`"
python_includes="$python_prefix/include/python$python_version"
- python_modules="$python_prefix/lib/python$python_version"
+ python_modules="$python_prefix/$(get_libdir)/python$python_version"
myconf="$myconf --with-python-includes=$python_includes"
myconf="$myconf --with-python-modules=$python_modules"