summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2006-07-08 23:25:54 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2006-07-08 23:25:54 +0000
commit7d7cd8680f2829ed291cc3669446a4379c6e4a98 (patch)
tree7e6de1f9e88606cf18b406847f559f8d2207cda4 /media-sound/ecasound
parentMarked stable on mips. (diff)
downloadgentoo-2-7d7cd8680f2829ed291cc3669446a4379c6e4a98.tar.gz
gentoo-2-7d7cd8680f2829ed291cc3669446a4379c6e4a98.tar.bz2
gentoo-2-7d7cd8680f2829ed291cc3669446a4379c6e4a98.zip
Version bump to 2.4.4. Closes bug #134872.
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'media-sound/ecasound')
-rw-r--r--media-sound/ecasound/ChangeLog7
-rw-r--r--media-sound/ecasound/ecasound-2.4.4.ebuild109
-rw-r--r--media-sound/ecasound/files/digest-ecasound-2.4.32
-rw-r--r--media-sound/ecasound/files/digest-ecasound-2.4.43
4 files changed, 120 insertions, 1 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
index b5d3bffadc35..a323823b69e1 100644
--- a/media-sound/ecasound/ChangeLog
+++ b/media-sound/ecasound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/ecasound
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.37 2006/01/25 22:19:55 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.38 2006/07/08 23:25:54 fvdpol Exp $
+
+*ecasound-2.4.4 (08 Jul 2006)
+
+ 08 Jul 2006; Frank van de Pol <fvdpol@gentoo.org> +ecasound-2.4.4.ebuild:
+ Version bump to 2.4.4. Closes bug #134872.
25 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> -ecasound-2.3.3.ebuild:
Drop old version with broken PIC handling.
diff --git a/media-sound/ecasound/ecasound-2.4.4.ebuild b/media-sound/ecasound/ecasound-2.4.4.ebuild
new file mode 100644
index 000000000000..6ec4b7b094ae
--- /dev/null
+++ b/media-sound/ecasound/ecasound-2.4.4.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.4.ebuild,v 1.1 2006/07/08 23:25:54 fvdpol Exp $
+
+inherit multilib
+
+IUSE="alsa arts audiofile debug jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
+
+DESCRIPTION="A package for multitrack audio processing"
+SRC_URI="http://ecasound.seul.org/download/${P}.tar.gz"
+HOMEPAGE="http://eca.cx/"
+LICENSE="GPL-2"
+
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~x86"
+
+DEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ media-libs/ladspa-sdk
+ audiofile? ( media-libs/audiofile )
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libvorbis )
+ arts? ( kde-base/arts )
+ libsamplerate? ( media-libs/libsamplerate )
+ mikmod? ( media-libs/libmikmod )
+ ruby? ( dev-lang/ruby )
+ python? ( dev-lang/python )
+ ncurses? ( sys-libs/ncurses )
+ sndfile? ( media-libs/libsndfile )"
+
+# We don't make RDEPEND for vorbis-tools, mpg123/mpg321, timidity++ or lame -- no
+# use flags for them.
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i 's:map.h:map:g' configure
+}
+
+src_compile () {
+ local myconf
+
+ myconf="${myconf} --enable-shared --with-largefile"
+
+ if use python; then
+ #
+ # ecasound is braindead about finding python includes/libdirs and
+ # about where to install modules. Luckily, it allows us to specify
+ # all this.
+ #
+ local python_version python_prefix python_includes python_modules
+ if use userland_Darwin ; then
+ myconf="$myconf --enable-pyecasound=python"
+ else
+ myconf="$myconf --enable-pyecasound=c"
+ fi
+ python_version="`python -c 'import sys; print sys.version[:3]'`"
+ python_prefix="`python -c 'import sys; print sys.prefix'`"
+
+ python_includes="$python_prefix/include/python$python_version"
+ python_modules="$python_prefix/$(get_libdir)/python$python_version"
+
+ myconf="$myconf --with-python-includes=$python_includes"
+ myconf="$myconf --with-python-modules=$python_modules"
+ else
+ myconf="$myconf --disable-pyecasound"
+ fi
+
+ econf \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable audiofile) \
+ $(use_enable debug) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate) \
+ $(use_enable ncurses) \
+ $(use_enable oss) \
+ $(use_enable ruby rubyecasound) \
+ $(use_enable sndfile) \
+ ${myconf} \
+ || die "configure failed"
+ make || die "build failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ if use python; then
+ cd pyecasound || die
+ python -c "import compileall; compileall.compile_dir('.')" || die
+ python -O -c "import compileall; compileall.compile_dir('.')" || die
+ python_sitepkgsdir="`python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`"
+ install *.pyc *.pyo "${D}/${python_sitepkgsdir}"
+ cd ..
+ fi
+
+ dodoc BUGS NEWS README TODO
+ dohtml `find Documentation -name "*.html"`
+ dodoc Documentation/edi-list.txt
+}
+
+pkg_postinst() {
+ if use arts; then
+ ewarn "WARNING: You have requested ecasound ARTS support,"
+ ewarn "this is no longer supported and will go away in"
+ ewarn "future releases."
+ fi
+}
+
diff --git a/media-sound/ecasound/files/digest-ecasound-2.4.3 b/media-sound/ecasound/files/digest-ecasound-2.4.3
index d4f80f548164..dadb25f459a6 100644
--- a/media-sound/ecasound/files/digest-ecasound-2.4.3
+++ b/media-sound/ecasound/files/digest-ecasound-2.4.3
@@ -1 +1,3 @@
MD5 ea4af6ffa9f00743270151927f7b4584 ecasound-2.4.3.tar.gz 1112995
+RMD160 c79ac8e4965155d0cd2eb80f981fc959f899bef3 ecasound-2.4.3.tar.gz 1112995
+SHA256 18e198993d4fe696ffc495b2229d99c75583015b4b2429349fab2d5219057945 ecasound-2.4.3.tar.gz 1112995
diff --git a/media-sound/ecasound/files/digest-ecasound-2.4.4 b/media-sound/ecasound/files/digest-ecasound-2.4.4
new file mode 100644
index 000000000000..b4fad551a603
--- /dev/null
+++ b/media-sound/ecasound/files/digest-ecasound-2.4.4
@@ -0,0 +1,3 @@
+MD5 3032a157f736bb38426b2ebcc92c6513 ecasound-2.4.4.tar.gz 1128867
+RMD160 7b9cefaea2f088c26894cf21ce121611147297cd ecasound-2.4.4.tar.gz 1128867
+SHA256 dd6afb770f97894763310d4435c1ab4ceb6529f0c0c9c790d126f22ea6f8bf77 ecasound-2.4.4.tar.gz 1128867