summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-28 18:51:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-28 18:51:12 +0000
commita1458883c90b708b208f1a3c0da0884888a85919 (patch)
tree4e36eaf4b2c6455bd640af5254fbc11299bb3cbf /media-sound/fluidsynth/fluidsynth-1.0.8.ebuild
parentStable for HPPA (bug #207663). (diff)
downloadgentoo-2-a1458883c90b708b208f1a3c0da0884888a85919.tar.gz
gentoo-2-a1458883c90b708b208f1a3c0da0884888a85919.tar.bz2
gentoo-2-a1458883c90b708b208f1a3c0da0884888a85919.zip
version bump
(Portage version: 2.1.4)
Diffstat (limited to 'media-sound/fluidsynth/fluidsynth-1.0.8.ebuild')
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.0.8.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/media-sound/fluidsynth/fluidsynth-1.0.8.ebuild b/media-sound/fluidsynth/fluidsynth-1.0.8.ebuild
new file mode 100644
index 000000000000..0360b021382a
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.0.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.8.ebuild,v 1.1 2008/01/28 18:51:11 aballier Exp $
+
+inherit flag-o-matic eutils libtool
+
+IUSE="alsa debug jack ladspa lash oss readline"
+
+DESCRIPTION="Fluidsynth is a software real-time synthesizer based on the Soundfont 2 specifications."
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="http://savannah.nongnu.org/download/fluid/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( >=media-libs/ladspa-sdk-1.12
+ >=media-libs/ladspa-cmt-1.15 )
+ alsa? ( media-libs/alsa-lib
+ lash? ( >=media-sound/lash-0.5 ) )
+ readline? ( sys-libs/readline )"
+
+S="${WORKDIR}/${P/7a/7}"
+
+# Alsa is required for lash support in this package.
+pkg_setup() {
+ if use lash && ! use alsa; then
+ ewarn "ALSA support is required for lash support to be enabled."
+ ewarn "Continuing with lash support disabled."
+ fi
+
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build Fluidsynth with ALSA support you need"
+ eerror "to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if use alsa; then
+ myconf="${myconf} $(use_enable lash)"
+ else
+ myconf="--disable-lash"
+ fi
+
+ elibtoolize
+ # ladcca support is deprecated in place of lash
+ econf \
+ --disable-ladcca \
+ --disable-dependency-tracking \
+ $(use_enable ladspa) \
+ $(use_enable jack jack-support) \
+ $(use_enable oss oss-support) \
+ $(use_enable alsa alsa-support) \
+ $(use_enable lash) \
+ $(use_enable debug) \
+ $(use_with readline) \
+ ${myconf} || die "./configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README THANKS TODO
+}