summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2005-02-27 15:32:08 +0000
committerJason Wever <weeve@gentoo.org>2005-02-27 15:32:08 +0000
commit54bcf6c97489a694a494a10f3d8b3c1b68ee8a99 (patch)
tree997e000a0e4e7a62923df9c67c4031f342f569e4 /media-sound/gqradio/gqradio-1.9.2.ebuild
parentAdded to ~ppc. (diff)
downloadgentoo-2-54bcf6c97489a694a494a10f3d8b3c1b68ee8a99.tar.gz
gentoo-2-54bcf6c97489a694a494a10f3d8b3c1b68ee8a99.tar.bz2
gentoo-2-54bcf6c97489a694a494a10f3d8b3c1b68ee8a99.zip
Marked 1.9.1 stable, version bump for 1.9.2.
(Portage version: 2.0.51.17)
Diffstat (limited to 'media-sound/gqradio/gqradio-1.9.2.ebuild')
-rw-r--r--media-sound/gqradio/gqradio-1.9.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/gqradio/gqradio-1.9.2.ebuild b/media-sound/gqradio/gqradio-1.9.2.ebuild
new file mode 100644
index 000000000000..3b23dbdda21f
--- /dev/null
+++ b/media-sound/gqradio/gqradio-1.9.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gqradio/gqradio-1.9.2.ebuild,v 1.1 2005/02/27 15:32:08 weeve Exp $
+
+IUSE="nls gnome"
+
+DESCRIPTION="GQradio is an FM radio tuner app from the people who brought you GQmpeg."
+HOMEPAGE="http://gqmpeg.sourceforge.net/radio.html"
+SRC_URI="mirror://sourceforge/gqmpeg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+
+DEPEND=">=x11-libs/gtk+-2.4.0
+ >=media-libs/gdk-pixbuf-0.7.0
+ >=media-libs/gdk-pixbuf-0.13.0"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README SKIN-SPECS TODO
+
+ use gnome && ( \
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/gqmpeg.desktop
+ )
+
+}