summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2006-03-31 20:38:20 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2006-03-31 20:38:20 +0000
commit9d59145907f1ea9b5a6c84bd2a5bc7452d9e44f9 (patch)
treeb37a98f164694f20120139b7e45df373199e994f /media-sound/lash/lash-0.5.1.ebuild
parentChanged nostrip to strip and nomirror to mirror. (diff)
downloadgentoo-2-9d59145907f1ea9b5a6c84bd2a5bc7452d9e44f9.tar.gz
gentoo-2-9d59145907f1ea9b5a6c84bd2a5bc7452d9e44f9.tar.bz2
gentoo-2-9d59145907f1ea9b5a6c84bd2a5bc7452d9e44f9.zip
Added media-sound/lash to the tree
(Portage version: 2.1_pre7-r1)
Diffstat (limited to 'media-sound/lash/lash-0.5.1.ebuild')
-rw-r--r--media-sound/lash/lash-0.5.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/lash/lash-0.5.1.ebuild b/media-sound/lash/lash-0.5.1.ebuild
new file mode 100644
index 000000000000..491417b22f61
--- /dev/null
+++ b/media-sound/lash/lash-0.5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/lash-0.5.1.ebuild,v 1.1 2006/03/31 20:38:20 fvdpol Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="LASH Audio Session Handler"
+HOMEPAGE="http://www.nongnu.org/lash/"
+SRC_URI="http://download.savannah.gnu.org/releases/lash/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/alsa-lib
+ media-sound/jack-audio-connection-kit
+ dev-libs/libxml2
+ >=x11-libs/gtk+-2.0"
+
+src_compile() {
+ econf --disable-serv-inst || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # Add to /etc/services
+ if ! grep -q ^lash /etc/services; then
+ dodir /etc
+ insinto /etc
+ doins /etc/services
+ echo -e "\nlash\t\t14541/tcp\t\t\t# LASH client/server protocol" >> ${D}/etc/services
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}