summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-13 14:32:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-13 14:32:56 +0000
commit778b748db4e80b2a352a9e79de35136a6e15bd11 (patch)
tree795a3cdd171597280703c83fce7f5b4f1bf65806 /media-sound/lash
parentremove old (diff)
downloadgentoo-2-778b748db4e80b2a352a9e79de35136a6e15bd11.tar.gz
gentoo-2-778b748db4e80b2a352a9e79de35136a6e15bd11.tar.bz2
gentoo-2-778b748db4e80b2a352a9e79de35136a6e15bd11.zip
variable quoting, add missing pkgconfig dep, bug #205626
(Portage version: 2.1.4)
Diffstat (limited to 'media-sound/lash')
-rw-r--r--media-sound/lash/ChangeLog6
-rw-r--r--media-sound/lash/lash-0.5.1.ebuild12
-rw-r--r--media-sound/lash/lash-0.5.4.ebuild8
3 files changed, 17 insertions, 9 deletions
diff --git a/media-sound/lash/ChangeLog b/media-sound/lash/ChangeLog
index 161083811616..592fd3e47e1b 100644
--- a/media-sound/lash/ChangeLog
+++ b/media-sound/lash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/lash
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/ChangeLog,v 1.15 2008/01/13 14:29:54 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/ChangeLog,v 1.16 2008/01/13 14:32:56 aballier Exp $
+
+ 13 Jan 2008; Alexis Ballier <aballier@gentoo.org> lash-0.5.1.ebuild,
+ lash-0.5.4.ebuild:
+ variable quoting, add missing pkgconfig dep, bug #205626
13 Jan 2008; Alexis Ballier <aballier@gentoo.org> -lash-0.5.2.ebuild,
-lash-0.5.3.ebuild:
diff --git a/media-sound/lash/lash-0.5.1.ebuild b/media-sound/lash/lash-0.5.1.ebuild
index 23fc92f96010..f23a0424cf45 100644
--- a/media-sound/lash/lash-0.5.1.ebuild
+++ b/media-sound/lash/lash-0.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/lash-0.5.1.ebuild,v 1.6 2006/10/10 14:04:37 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/lash-0.5.1.ebuild,v 1.7 2008/01/13 14:32:56 aballier Exp $
inherit eutils
@@ -15,10 +15,12 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE=""
-DEPEND="media-libs/alsa-lib
+RDEPEND="media-libs/alsa-lib
media-sound/jack-audio-connection-kit
dev-libs/libxml2
>=x11-libs/gtk+-2.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
src_compile() {
econf --disable-serv-inst || die "econf failed"
@@ -26,14 +28,14 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
# Add to /etc/services
if ! grep -q ^lash /etc/services; then
dodir /etc
insinto /etc
doins /etc/services
- echo -e "\nlash\t\t14541/tcp\t\t\t# LASH client/server protocol" >> ${D}/etc/services
+ echo -e "\nlash\t\t14541/tcp\t\t\t# LASH client/server protocol" >> "${D}/etc/services"
fi
dodoc AUTHORS ChangeLog NEWS README TODO
diff --git a/media-sound/lash/lash-0.5.4.ebuild b/media-sound/lash/lash-0.5.4.ebuild
index 3af33f167c00..11d108652de2 100644
--- a/media-sound/lash/lash-0.5.4.ebuild
+++ b/media-sound/lash/lash-0.5.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/lash-0.5.4.ebuild,v 1.1 2007/12/16 16:07:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/lash-0.5.4.ebuild,v 1.2 2008/01/13 14:32:56 aballier Exp $
inherit eutils libtool
@@ -13,12 +13,14 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="alsa debug gtk python"
-DEPEND="alsa? ( media-libs/alsa-lib )
+RDEPEND="alsa? ( media-libs/alsa-lib )
media-sound/jack-audio-connection-kit
dev-libs/libxml2
gtk? ( >=x11-libs/gtk+-2.0 )
python? ( dev-lang/python )
|| ( sys-libs/readline sys-libs/libedit )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
pkg_setup() {
if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then