summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-03-28 00:11:13 +0000
committerAron Griffis <agriffis@gentoo.org>2006-03-28 00:11:13 +0000
commit5b5a45c0f50d10847833e97d0f939a6dc78572af (patch)
treea72a30f453dc566d9d63e9ab2f9ebc69ebef7b02 /media-sound/lilypond/lilypond-2.0.3.ebuild
parentMark 3.5.2 3.5.1 3.5.0 ~ia64 (diff)
downloadgentoo-2-5b5a45c0f50d10847833e97d0f939a6dc78572af.tar.gz
gentoo-2-5b5a45c0f50d10847833e97d0f939a6dc78572af.tar.bz2
gentoo-2-5b5a45c0f50d10847833e97d0f939a6dc78572af.zip
Restrict older lilyponds to tetex-2 which provides /usr/bin/inimf #92040.
sed makefiles so that mftrace-1.1.x can be used in place of mftrace-1.0.x #90334 (Portage version: 2.1_pre5-r4)
Diffstat (limited to 'media-sound/lilypond/lilypond-2.0.3.ebuild')
-rw-r--r--media-sound/lilypond/lilypond-2.0.3.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/media-sound/lilypond/lilypond-2.0.3.ebuild b/media-sound/lilypond/lilypond-2.0.3.ebuild
index ea230a4bb14b..6fe594169c6c 100644
--- a/media-sound/lilypond/lilypond-2.0.3.ebuild
+++ b/media-sound/lilypond/lilypond-2.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.0.3.ebuild,v 1.9 2006/03/26 21:51:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.0.3.ebuild,v 1.10 2006/03/28 00:11:13 agriffis Exp $
inherit eutils versionator
@@ -26,15 +26,23 @@ DEPEND="${RDEPEND}
>=sys-devel/flex-2.5.4a-r5
>=sys-devel/gcc-3.1-r8
>=sys-devel/make-3.80
- >=app-text/mftrace-1.0.19
+ >=app-text/mftrace-1.1.16
sys-devel/bison !=sys-devel/bison-1.75
doc? ( media-gfx/imagemagick
>=media-libs/netpbm-9.12-r4 )"
src_unpack() {
unpack ${A} || die "unpack failed"
- cd ${S}; epatch ${FILESDIR}/${PN}-2.0.0-coreutils-compat.patch
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-2.0.0-coreutils-compat.patch
NOCONFIGURE=1 ./autogen.sh >/dev/null
+
+ # Fix makefiles to work with recent mftrace #90334
+ grep -rlZ 'MFTRACE.*--pf[ab]' --include=GNUmakefile --include=\*.make ${S} | \
+ xargs -0r sed -i '
+ s/--pfa --pfb/--formats=PFA,PFB/;
+ s/--pfa/--formats=PFA/;
+ s/--pfa/--formats=PFA/'
}
src_compile() {