summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-08 20:36:49 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-08 20:36:49 +0000
commitbcebfc1705b9f221965652e9f9dc7ff3a336cdd7 (patch)
treefb6d0137d4ef9a9b27e32f937d942701fcf8e1e5 /media-sound/mpd/mpd-0.9.2.ebuild
parentVersion bumped. (diff)
downloadgentoo-2-bcebfc1705b9f221965652e9f9dc7ff3a336cdd7.tar.gz
gentoo-2-bcebfc1705b9f221965652e9f9dc7ff3a336cdd7.tar.bz2
gentoo-2-bcebfc1705b9f221965652e9f9dc7ff3a336cdd7.zip
Version bumped.
Diffstat (limited to 'media-sound/mpd/mpd-0.9.2.ebuild')
-rw-r--r--media-sound/mpd/mpd-0.9.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/mpd/mpd-0.9.2.ebuild b/media-sound/mpd/mpd-0.9.2.ebuild
new file mode 100644
index 000000000000..59d5dd2fdae3
--- /dev/null
+++ b/media-sound/mpd/mpd-0.9.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.9.2.ebuild,v 1.1 2003/10/08 20:36:42 mholzer Exp $
+
+IUSE="oggvorbis mad"
+
+DESCRIPTION="Music Player Daemon (mpd)"
+SRC_URI="http://mercury.chem.pitt.edu/~shank/${P}.tar.gz"
+HOMEPAGE="http://www.musicpd.org"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="oggvorbis? ( media-libs/libvorbis )
+ mad? ( media-sound/mad )
+ >=media-libs/flac-1.1.0
+ media-libs/libao
+ sys-libs/zlib"
+
+src_compile() {
+ local myconf
+ myconf="--with-gnu-ld"
+
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-oggtest \
+ --disable-vorbistest"
+ use mad || myconf="${myconf} --enable-mpd-mad --enable-mpd-id3tag"
+
+ econf ${myconf} || die "could not configure"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+ rm -rf ${D}/usr/share/doc/mpd/
+ dodoc COPYING ChangeLog INSTALL README TODO UPGRADING
+ dodoc doc/COMMANDS doc/mpdconf.example
+}
+
+pkg_postinst() {
+ einfo "libao has issues with the ALSA drivers, please refer to the FAQ"
+ einfo "http://musicpd.sourceforge.net/faq.php"
+}