summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-25 15:24:18 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-25 15:24:18 +0000
commit9151f90c7efe97fef9a0bed3df9ff6d2fb6e48ce (patch)
tree40643f5c963ee3a530b016a167a7ee657cf2016d /media-sound/musepack-tools
parentMask musepack-tools SV8 for testing. (diff)
downloadgentoo-2-9151f90c7efe97fef9a0bed3df9ff6d2fb6e48ce.tar.gz
gentoo-2-9151f90c7efe97fef9a0bed3df9ff6d2fb6e48ce.tar.bz2
gentoo-2-9151f90c7efe97fef9a0bed3df9ff6d2fb6e48ce.zip
Version bump to SV8.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/musepack-tools')
-rw-r--r--media-sound/musepack-tools/ChangeLog8
-rw-r--r--media-sound/musepack-tools/files/musepack-tools-444-gentoo.patch127
-rw-r--r--media-sound/musepack-tools/musepack-tools-444.ebuild25
3 files changed, 159 insertions, 1 deletions
diff --git a/media-sound/musepack-tools/ChangeLog b/media-sound/musepack-tools/ChangeLog
index 94875de81efe..788dfa8e7d1d 100644
--- a/media-sound/musepack-tools/ChangeLog
+++ b/media-sound/musepack-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/musepack-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/musepack-tools/ChangeLog,v 1.37 2009/05/14 20:11:37 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/musepack-tools/ChangeLog,v 1.38 2009/07/25 15:24:18 ssuominen Exp $
+
+*musepack-tools-444 (25 Jul 2009)
+
+ 25 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +musepack-tools-444.ebuild, +files/musepack-tools-444-gentoo.patch:
+ Version bump to SV8.
14 May 2009; Markus Meier <maekke@gentoo.org>
musepack-tools-1.15v-r1.ebuild:
diff --git a/media-sound/musepack-tools/files/musepack-tools-444-gentoo.patch b/media-sound/musepack-tools/files/musepack-tools-444-gentoo.patch
new file mode 100644
index 000000000000..fed26426882f
--- /dev/null
+++ b/media-sound/musepack-tools/files/musepack-tools-444-gentoo.patch
@@ -0,0 +1,127 @@
+diff -ruN musepack-tools-444.orig/CMakeLists.txt musepack-tools-444/CMakeLists.txt
+--- musepack-tools-444.orig/CMakeLists.txt 2009-07-25 16:49:11.000000000 +0300
++++ musepack-tools-444/CMakeLists.txt 2009-07-25 18:04:19.000000000 +0300
+@@ -22,3 +22,4 @@
+ add_subdirectory(mpc2sv8)
+ add_subdirectory(mpccut)
+ add_subdirectory(mpcchap)
++add_subdirectory(wavcmp)
+diff -ruN musepack-tools-444.orig/include/mpc/mpcmath.h musepack-tools-444/include/mpc/mpcmath.h
+--- musepack-tools-444.orig/include/mpc/mpcmath.h 2009-07-25 16:49:10.000000000 +0300
++++ musepack-tools-444/include/mpc/mpcmath.h 2009-07-25 17:37:16.000000000 +0300
+@@ -16,6 +16,8 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include <math.h>
++
+ #include <mpc/mpc_types.h>
+
+ typedef union mpc_floatint
+diff -ruN musepack-tools-444.orig/libmpcdec/CMakeLists.txt musepack-tools-444/libmpcdec/CMakeLists.txt
+--- musepack-tools-444.orig/libmpcdec/CMakeLists.txt 2009-07-25 16:49:10.000000000 +0300
++++ musepack-tools-444/libmpcdec/CMakeLists.txt 2009-07-25 17:58:04.000000000 +0300
+@@ -1,2 +1,15 @@
+ include_directories(${libmpc_SOURCE_DIR}/include)
++
+ add_library(mpcdec_static STATIC huffman mpc_decoder mpc_reader streaminfo mpc_bits_reader mpc_demux requant synth_filter ${libmpc_SOURCE_DIR}/common/crc32)
++set_target_properties(mpcdec_static PROPERTIES OUTPUT_NAME mpcdec CLEAN_DIRECT_OUTPUT 1)
++if(NOT MSVC)
++target_link_libraries(mpcdec_static m)
++endif(NOT MSVC)
++
++add_library(mpcdec_shared SHARED huffman mpc_decoder mpc_reader streaminfo mpc_bits_reader mpc_demux requant synth_filter ${libmpc_SOURCE_DIR}/common/crc32)
++set_target_properties(mpcdec_shared PROPERTIES OUTPUT_NAME mpcdec CLEAN_DIRECT_OUTPUT 1 VERSION 6.1.0 SOVERSION 6)
++if(NOT MSVC)
++target_link_libraries(mpcdec_shared m)
++endif(NOT MSVC)
++
++install(TARGETS mpcdec_static mpcdec_shared LIBRARY DESTINATION "lib${LIB_SUFFIX}" ARCHIVE DESTINATION "lib${LIB_SUFFIX}")
+diff -ruN musepack-tools-444.orig/mpc2sv8/CMakeLists.txt musepack-tools-444/mpc2sv8/CMakeLists.txt
+--- musepack-tools-444.orig/mpc2sv8/CMakeLists.txt 2009-07-25 16:49:11.000000000 +0300
++++ musepack-tools-444/mpc2sv8/CMakeLists.txt 2009-07-25 17:59:54.000000000 +0300
+@@ -12,7 +12,7 @@
+
+ add_executable(mpc2sv8 mpc2sv8.c)
+
+-target_link_libraries(mpc2sv8 mpcdec_static)
++target_link_libraries(mpc2sv8 mpcdec_shared)
+ target_link_libraries(mpc2sv8 mpcenc_static)
+
+ if(WIN32)
+@@ -27,3 +27,4 @@
+ target_link_libraries(mpc2sv8 ossaudio)
+ endif(CMAKE_SYSTEM_NAME STREQUAL OpenBSD)
+
++install(TARGETS mpc2sv8 RUNTIME DESTINATION bin)
+diff -ruN musepack-tools-444.orig/mpcchap/CMakeLists.txt musepack-tools-444/mpcchap/CMakeLists.txt
+--- musepack-tools-444.orig/mpcchap/CMakeLists.txt 2009-07-25 16:49:11.000000000 +0300
++++ musepack-tools-444/mpcchap/CMakeLists.txt 2009-07-25 17:59:30.000000000 +0300
+@@ -14,7 +14,7 @@
+
+ add_executable(mpcchap mpcchap dictionary iniparser ${libmpc_SOURCE_DIR}/common/tags)
+
+-target_link_libraries(mpcchap mpcdec_static)
++target_link_libraries(mpcchap mpcdec_shared)
+ target_link_libraries(mpcchap mpcenc_static)
+ target_link_libraries(mpcchap ${CUEFILE_LIBRARY})
+
+@@ -22,3 +22,4 @@
+ target_link_libraries(mpcchap m)
+ endif(NOT MSVC)
+
++install(TARGETS mpcchap RUNTIME DESTINATION bin)
+diff -ruN musepack-tools-444.orig/mpccut/CMakeLists.txt musepack-tools-444/mpccut/CMakeLists.txt
+--- musepack-tools-444.orig/mpccut/CMakeLists.txt 2009-07-25 16:49:10.000000000 +0300
++++ musepack-tools-444/mpccut/CMakeLists.txt 2009-07-25 18:00:24.000000000 +0300
+@@ -12,10 +12,11 @@
+
+ add_executable(mpccut mpccut)
+
+-target_link_libraries(mpccut mpcdec_static)
++target_link_libraries(mpccut mpcdec_shared)
+ target_link_libraries(mpccut mpcenc_static)
+
+ if(NOT MSVC)
+ target_link_libraries(mpccut m)
+ endif(NOT MSVC)
+
++install(TARGETS mpccut RUNTIME DESTINATION bin)
+diff -ruN musepack-tools-444.orig/mpcdec/CMakeLists.txt musepack-tools-444/mpcdec/CMakeLists.txt
+--- musepack-tools-444.orig/mpcdec/CMakeLists.txt 2009-07-25 16:49:10.000000000 +0300
++++ musepack-tools-444/mpcdec/CMakeLists.txt 2009-07-25 18:00:49.000000000 +0300
+@@ -17,4 +17,6 @@
+ endif(NOT MSVC)
+
+ target_link_libraries(mpcdec wavformat_static)
+-target_link_libraries(mpcdec mpcdec_static)
++target_link_libraries(mpcdec mpcdec_shared)
++
++install(TARGETS mpcdec RUNTIME DESTINATION bin)
+diff -ruN musepack-tools-444.orig/mpcgain/CMakeLists.txt musepack-tools-444/mpcgain/CMakeLists.txt
+--- musepack-tools-444.orig/mpcgain/CMakeLists.txt 2009-07-25 16:49:11.000000000 +0300
++++ musepack-tools-444/mpcgain/CMakeLists.txt 2009-07-25 18:05:03.000000000 +0300
+@@ -18,9 +18,10 @@
+ add_executable(mpcgain mpcgain.c)
+
+ target_link_libraries(mpcgain ${REPLAY_GAIN_LIBRARY})
+-target_link_libraries(mpcgain mpcdec_static)
++target_link_libraries(mpcgain mpcdec_shared)
+
+ if(NOT MSVC)
+ target_link_libraries(mpcgain m)
+ endif(NOT MSVC)
+
++install(TARGETS mpcgain RUNTIME DESTINATION bin)
+diff -ruN musepack-tools-444.orig/wavcmp/CMakeLists.txt musepack-tools-444/wavcmp/CMakeLists.txt
+--- musepack-tools-444.orig/wavcmp/CMakeLists.txt 1970-01-01 02:00:00.000000000 +0200
++++ musepack-tools-444/wavcmp/CMakeLists.txt 2009-07-25 18:20:36.000000000 +0300
+@@ -0,0 +1,8 @@
++include_directories(${libmpc_SOURCE_DIR}/libwavformat)
++link_directories(${libmpc_BINARY_DIR}/libwavformat)
++
++add_executable(wavcmp wavcmp)
++
++target_link_libraries(wavcmp wavformat_static)
++
++install(TARGETS wavcmp RUNTIME DESTINATION bin)
diff --git a/media-sound/musepack-tools/musepack-tools-444.ebuild b/media-sound/musepack-tools/musepack-tools-444.ebuild
new file mode 100644
index 000000000000..b7086e085847
--- /dev/null
+++ b/media-sound/musepack-tools/musepack-tools-444.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/musepack-tools/musepack-tools-444.ebuild,v 1.1 2009/07/25 15:24:18 ssuominen Exp $
+
+inherit cmake-utils
+
+# svn co http://svn.musepack.net/libmpc/trunk musepack-tools-${PV}
+# tar -cjf musepack-tools-${PV}.tar.bz2 musepack-tools-${PV}
+
+DESCRIPTION="Musepack SV8 libraries and utilities"
+HOMEPAGE="http://www.musepack.net"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=media-libs/libcuefile-${PV}
+ >=media-libs/libreplaygain-${PV}"
+DEPEND="${RDEPEND}
+ !media-libs/libmpcdec"
+
+PATCHES=( "${FILESDIR}/${P}-gentoo.patch" )