summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-21 06:33:24 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-21 06:33:24 +0000
commitb5483b08ffe279e587b4aaafbd6104aaeb17c6be (patch)
treebd2b3ac36bac0ab49e12c1e92d94e10e4a2cff4c /media-sound/nted
parentmarked x86 per bug 416333 (diff)
downloadgentoo-2-b5483b08ffe279e587b4aaafbd6104aaeb17c6be.tar.gz
gentoo-2-b5483b08ffe279e587b4aaafbd6104aaeb17c6be.tar.bz2
gentoo-2-b5483b08ffe279e587b4aaafbd6104aaeb17c6be.zip
Remove || ( ) from LICENSE field because they are all required. Missing glib, freetype, gdk-pixbuf, libX11, pango and gettext dependencies. Punt unnecessary doman from src_install() and whole function as a result. Missing debug in IUSE. Trick ./configure to believe gnome-extra/yelp is installed so we can avoid pulling in vulnerable copy of net-libs/xulrunner wrt #416843. Pretty much rewrite the whole ebuild...
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/nted')
-rw-r--r--media-sound/nted/ChangeLog9
-rw-r--r--media-sound/nted/nted-1.10.18.ebuild47
2 files changed, 33 insertions, 23 deletions
diff --git a/media-sound/nted/ChangeLog b/media-sound/nted/ChangeLog
index 2f1014e32ecf..13506d0fbc94 100644
--- a/media-sound/nted/ChangeLog
+++ b/media-sound/nted/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/nted
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/ChangeLog,v 1.26 2012/05/21 06:16:13 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/ChangeLog,v 1.27 2012/05/21 06:33:24 ssuominen Exp $
+
+ 21 May 2012; Samuli Suominen <ssuominen@gentoo.org> nted-1.10.18.ebuild:
+ Remove || ( ) from LICENSE field because they are all required. Missing glib,
+ freetype, gdk-pixbuf, libX11, pango and gettext dependencies. Punt
+ unnecessary doman from src_install() and whole function as a result. Missing
+ debug in IUSE. Trick ./configure to believe gnome-extra/yelp is installed so
+ we can avoid pulling in vulnerable copy of net-libs/xulrunner wrt #416843.
21 May 2012; Samuli Suominen <ssuominen@gentoo.org> -nted-1.10.7-r1.ebuild:
old
diff --git a/media-sound/nted/nted-1.10.18.ebuild b/media-sound/nted/nted-1.10.18.ebuild
index 4f4cd0e8d51e..c49af193c6cd 100644
--- a/media-sound/nted/nted-1.10.18.ebuild
+++ b/media-sound/nted/nted-1.10.18.ebuild
@@ -1,37 +1,40 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/nted-1.10.18.ebuild,v 1.5 2012/05/05 08:45:04 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/nted-1.10.18.ebuild,v 1.6 2012/05/21 06:33:24 ssuominen Exp $
-EAPI="4"
+EAPI=4
-inherit eutils
-
-DESCRIPTION="WYSIWYG score editor for GTK+2"
+DESCRIPTION="WYSIWYG score editor for GTK+"
HOMEPAGE="http://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml"
SRC_URI="http://vsr.informatik.tu-chemnitz.de/staff/jan/${PN}/sources/${P}.tar.gz"
-LICENSE="|| ( GPL-2 FDL-1.2 NTED_FONT )"
+LICENSE="GPL-2 FDL-1.2 NTED_FONT"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="doc nls"
-RDEPEND="doc? ( gnome-extra/yelp app-text/xmlto )
+IUSE="doc debug nls"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/alsa-lib
+ >=media-libs/freetype-2
x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2
x11-libs/gtk+:2
- media-libs/alsa-lib"
-
+ x11-libs/libX11
+ x11-libs/pango"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )
+ nls? ( sys-devel/gettext )"
-src_configure() {
- econf $(use_with doc) \
- $(use_enable debug) \
- $(use_enable nls) \
- --docdir=/usr/share/doc/${PF}
+DOCS="ABOUT_THE_EXAMPLES.TXT AUTHORS FAQ README"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ABOUT_THE_EXAMPLES.TXT FAQ README
- doman "man/${PN}.1"
+src_configure() {
+ # Trick ./configure to believe we have gnome-extra/yelp installed.
+ has_version gnome-extra/yelp || export ac_cv_path_YELP="$(type -P true)"
+
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_with doc)
}