summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-03-03 16:11:10 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-03-03 16:11:10 +0000
commite1056a88ff5aef8ce387e532e411a574b9e40653 (patch)
treedfaf444380f5da8d3e4f40fa27f952a7551b6c79 /media-sound/protux/protux-0.50.100.ebuild
parentFix as-needed patch mess up reported by Daniel Glockner (bug #166374) (diff)
downloadgentoo-2-e1056a88ff5aef8ce387e532e411a574b9e40653.tar.gz
gentoo-2-e1056a88ff5aef8ce387e532e411a574b9e40653.tar.bz2
gentoo-2-e1056a88ff5aef8ce387e532e411a574b9e40653.zip
Version bump for bug #127537. protux is now written entirely in Java so adding java herd with the sound herd as the maintainer.
(Portage version: 2.1.2-r12)
Diffstat (limited to 'media-sound/protux/protux-0.50.100.ebuild')
-rw-r--r--media-sound/protux/protux-0.50.100.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/protux/protux-0.50.100.ebuild b/media-sound/protux/protux-0.50.100.ebuild
new file mode 100644
index 000000000000..49f8bf3e9502
--- /dev/null
+++ b/media-sound/protux/protux-0.50.100.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/protux/protux-0.50.100.ebuild,v 1.1 2007/03/03 16:11:10 betelgeuse Exp $
+
+inherit java-pkg-2
+
+DESCRIPTION="Professional Audio Tools for GNU/Linux"
+HOMEPAGE="http://protux.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/releases/${P}.tar.gz"
+
+IUSE="source"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND=">=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ cd src
+ ejavac -encoding latin1 $(find . -name "*.java")
+ jar cf ${PN}.jar $(find . -name "*.class") || die
+}
+
+src_install() {
+ java-pkg_dojar src/${PN}.jar
+ dodoc AUTHORS BUGLIST ChangeLog COPYRIGHT INSTALL README TODO || die
+ use source && java-pkg_dosrc src/org
+ # pwd like this because it does not find resources otherwise
+ java-pkg_dolauncher ${PN} \
+ --main org.protux.Main \
+ --pwd /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins -r resources || die
+}