summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-06-08 17:04:55 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-06-08 17:04:55 +0000
commit7a151f113a726b6dfe0c1c891753efb416b72c7c (patch)
treeb69e74e400f0c3e9200248a8974beeed6295f1f5 /media-sound/shorten
parent~arm (diff)
downloadgentoo-2-7a151f113a726b6dfe0c1c891753efb416b72c7c.tar.gz
gentoo-2-7a151f113a726b6dfe0c1c891753efb416b72c7c.tar.bz2
gentoo-2-7a151f113a726b6dfe0c1c891753efb416b72c7c.zip
Remove tests that try to see if shorten doesn't accept to output to a tty as when run by portage it's not a tty thus shorten tries to output and the test fails, bug #159095
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-sound/shorten')
-rw-r--r--media-sound/shorten/ChangeLog8
-rw-r--r--media-sound/shorten/files/shorten-tests.patch15
-rw-r--r--media-sound/shorten/shorten-3.6.0.ebuild12
-rw-r--r--media-sound/shorten/shorten-3.6.1.ebuild11
4 files changed, 41 insertions, 5 deletions
diff --git a/media-sound/shorten/ChangeLog b/media-sound/shorten/ChangeLog
index 7873e7cb5049..22b3f53ce272 100644
--- a/media-sound/shorten/ChangeLog
+++ b/media-sound/shorten/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/shorten
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shorten/ChangeLog,v 1.18 2007/04/27 00:39:02 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shorten/ChangeLog,v 1.19 2007/06/08 17:04:55 aballier Exp $
+
+ 08 Jun 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/shorten-tests.patch, shorten-3.6.0.ebuild, shorten-3.6.1.ebuild:
+ Remove tests that try to see if shorten doesn't accept to output to a tty as
+ when run by portage it's not a tty thus shorten tries to output and the test
+ fails, bug #159095
*shorten-3.6.1 (27 Apr 2007)
diff --git a/media-sound/shorten/files/shorten-tests.patch b/media-sound/shorten/files/shorten-tests.patch
new file mode 100644
index 000000000000..9d067fe3b63c
--- /dev/null
+++ b/media-sound/shorten/files/shorten-tests.patch
@@ -0,0 +1,15 @@
+Index: shorten-3.6.1/tests/test-errors.sh
+===================================================================
+--- shorten-3.6.1.orig/tests/test-errors.sh
++++ shorten-3.6.1/tests/test-errors.sh
+@@ -36,8 +36,8 @@ for testdir in mono stereo; do
+ $SHORTEN - - && exit 1
+ $SHORTEN - test.shn && exit 1
+ $SHORTEN -x - test.wav && exit 1
+- $SHORTEN test.wav - && exit 1
+- $SHORTEN -x test.shn - && exit 1
++ #$SHORTEN test.wav - && exit 1
++ #$SHORTEN -x test.shn - && exit 1
+
+ # test missing filename with -S
+ $SHORTEN -S test.shn && exit 1
diff --git a/media-sound/shorten/shorten-3.6.0.ebuild b/media-sound/shorten/shorten-3.6.0.ebuild
index 8904ccc22649..6806fa2b51ea 100644
--- a/media-sound/shorten/shorten-3.6.0.ebuild
+++ b/media-sound/shorten/shorten-3.6.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shorten/shorten-3.6.0.ebuild,v 1.5 2006/12/08 00:42:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shorten/shorten-3.6.0.ebuild,v 1.6 2007/06/08 17:04:55 aballier Exp $
+
+inherit eutils
IUSE=""
@@ -12,6 +14,12 @@ SLOT="0"
LICENSE="as-is"
KEYWORDS="alpha amd64 ~ppc sparc x86 ~x86-fbsd"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-tests.patch"
+}
+
src_install() {
make DESTDIR="${D}" install || die
dodoc AUTHORS LICENSE ChangeLog NEWS README
diff --git a/media-sound/shorten/shorten-3.6.1.ebuild b/media-sound/shorten/shorten-3.6.1.ebuild
index 6a4b830de6be..780cc90a1430 100644
--- a/media-sound/shorten/shorten-3.6.1.ebuild
+++ b/media-sound/shorten/shorten-3.6.1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shorten/shorten-3.6.1.ebuild,v 1.1 2007/04/27 00:39:02 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shorten/shorten-3.6.1.ebuild,v 1.2 2007/06/08 17:04:55 aballier Exp $
+
+inherit eutils
IUSE=""
-RESTRICT="test"
DESCRIPTION="fast, low complexity waveform coder (i.e. audio compressor)"
HOMEPAGE="http://shnutils.freeshell.org/shorten/"
@@ -13,6 +14,12 @@ SLOT="0"
LICENSE="as-is"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-tests.patch"
+}
+
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README