summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-01-08 00:13:42 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-01-08 00:13:42 +0000
commitd40ca98ed03ccc7d00959d3763b003053261d26f (patch)
treefb4462c9706de231ac8f004b5e7d1a5457fd5238 /media-sound/snd
parentadding metadata (diff)
downloadgentoo-2-d40ca98ed03ccc7d00959d3763b003053261d26f.tar.gz
gentoo-2-d40ca98ed03ccc7d00959d3763b003053261d26f.tar.bz2
gentoo-2-d40ca98ed03ccc7d00959d3763b003053261d26f.zip
Version bumped. Closes 37046
Diffstat (limited to 'media-sound/snd')
-rw-r--r--media-sound/snd/ChangeLog7
-rw-r--r--media-sound/snd/files/digest-snd-7.01
-rw-r--r--media-sound/snd/snd-7.0.ebuild74
3 files changed, 81 insertions, 1 deletions
diff --git a/media-sound/snd/ChangeLog b/media-sound/snd/ChangeLog
index 1e67a13b030d..a2e9f06a4d19 100644
--- a/media-sound/snd/ChangeLog
+++ b/media-sound/snd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/snd
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.7 2003/07/12 20:30:58 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.8 2004/01/08 00:13:41 mholzer Exp $
+
+*snd-7.0 (08 Jan 2004)
+
+ 08 Jan 2004; Martin Holzer <mholzer@gentoo.org> snd-7.0.ebuild:
+ Version bumped. Closes 37046
21 Jun 2003; jje <jje@gentoo.org> snd-6.7.ebuild, snd-6.ebuild:
Remove snd-6 and move snd-6.7 to stable.
diff --git a/media-sound/snd/files/digest-snd-7.0 b/media-sound/snd/files/digest-snd-7.0
new file mode 100644
index 000000000000..26248c3c7528
--- /dev/null
+++ b/media-sound/snd/files/digest-snd-7.0
@@ -0,0 +1 @@
+MD5 acd33880a74f863dcbf19610b40e9a28 snd-7.0.tar.gz 5026908
diff --git a/media-sound/snd/snd-7.0.ebuild b/media-sound/snd/snd-7.0.ebuild
new file mode 100644
index 000000000000..b2819429164a
--- /dev/null
+++ b/media-sound/snd/snd-7.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-7.0.ebuild,v 1.1 2004/01/08 00:13:42 mholzer Exp $
+
+IUSE="esd motif guile X gtk ruby alsa"
+
+S="${WORKDIR}/${P/\.*//}"
+DESCRIPTION="Snd is a sound editor"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://snd.sourceforge.net"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+DEPEND="X? ( virtual/x11 )
+ dev-libs/gsl
+ media-libs/ladspa-sdk
+ media-libs/audiofile
+ esd? ( media-sound/esound )
+ alsa? ( media-libs/alsa-lib )
+ gtk? ( x11-libs/gtk+ )
+ guile? ( dev-util/guile )
+ motif? ( x11-libs/openmotif )
+ ruby? ( dev-lang/ruby )"
+
+
+src_compile() {
+ local myconf
+
+ use alsa \
+ && myconf="${myconf} --with-alsa" \
+ || myconf="${myconf} --without-alsa"
+
+ use esd \
+ && myconf="${myconf} --with-esd" \
+ || myconf="${myconf} --without-esd"
+
+ use gtk \
+ && myconf="${myconf} --with-gtk" \
+ || myconf="${myconf} --without-gtk"
+
+ use guile \
+ && myconf="${myconf} --with-guile --with-run" \
+ || myconf="${myconf} --without-guile"
+
+ use ruby \
+ && myconf="${myconf} --with-ruby" \
+ || myconf="${myconf} --without-ruby"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+# Seems to cause problem I will look into it but for now we will just disable
+# use gl \
+# && myconf="${myconf} --with-just-gl" \
+# || myconf="${myconf} --without-gl"
+
+ econf --with-ladspa --with-float-samples \
+ --with-float-sample-width ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ dobin snd
+
+ dodoc COPYING HISTORY.Snd README.Snd TODO.Snd
+
+ cd contrib/tutorial
+ dohtml *
+}