summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-07 16:05:23 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-07 16:05:23 +0000
commitedd73c4a80d62ef2b90b6c87d38610fcac3aab2d (patch)
tree87ec0f762a2d49d0e9428c3fda9b9895559a5b49 /media-sound/toolame
parentAdd ~sparc keyword (Bug #122726). (diff)
downloadgentoo-2-edd73c4a80d62ef2b90b6c87d38610fcac3aab2d.tar.gz
gentoo-2-edd73c4a80d62ef2b90b6c87d38610fcac3aab2d.tar.bz2
gentoo-2-edd73c4a80d62ef2b90b6c87d38610fcac3aab2d.zip
Drop virtual/libc dependency. Respect LDFLAGS.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'media-sound/toolame')
-rw-r--r--media-sound/toolame/ChangeLog9
-rw-r--r--media-sound/toolame/files/toolame-02l-gentoo.diff2
-rw-r--r--media-sound/toolame/toolame-02l-r1.ebuild7
-rw-r--r--media-sound/toolame/toolame-02l-r2.ebuild14
-rw-r--r--media-sound/toolame/toolame-02l.ebuild7
5 files changed, 17 insertions, 22 deletions
diff --git a/media-sound/toolame/ChangeLog b/media-sound/toolame/ChangeLog
index 0436f2d768f2..f6ba704b685f 100644
--- a/media-sound/toolame/ChangeLog
+++ b/media-sound/toolame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/toolame
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/toolame/ChangeLog,v 1.14 2005/08/25 12:21:58 flameeyes Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/toolame/ChangeLog,v 1.15 2006/03/07 16:05:23 flameeyes Exp $
+
+ 07 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ files/toolame-02l-gentoo.diff, toolame-02l.ebuild, toolame-02l-r1.ebuild,
+ toolame-02l-r2.ebuild:
+ Drop virtual/libc dependency. Respect LDFLAGS.
*toolame-02l-r2 (25 Aug 2005)
diff --git a/media-sound/toolame/files/toolame-02l-gentoo.diff b/media-sound/toolame/files/toolame-02l-gentoo.diff
index 00057ac21a87..1b011600e7ef 100644
--- a/media-sound/toolame/files/toolame-02l-gentoo.diff
+++ b/media-sound/toolame/files/toolame-02l-gentoo.diff
@@ -51,7 +51,7 @@
$(PGM): $(OBJ) Makefile
- $(CC) $(PG) -o $(PGM) $(OBJ) $(LIBS)
-+ $(CC) -o $(PGM) $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) -o $(PGM) $(OBJ) $(LIBS)
clean:
- -rm $(OBJ) $(DEP)
diff --git a/media-sound/toolame/toolame-02l-r1.ebuild b/media-sound/toolame/toolame-02l-r1.ebuild
index a916a746e8e7..de5756ebddee 100644
--- a/media-sound/toolame/toolame-02l-r1.ebuild
+++ b/media-sound/toolame/toolame-02l-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/toolame/toolame-02l-r1.ebuild,v 1.2 2005/08/24 16:15:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/toolame/toolame-02l-r1.ebuild,v 1.3 2006/03/07 16:05:23 flameeyes Exp $
IUSE=""
@@ -14,9 +14,6 @@ SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="amd64 ~sparc ~x86 ~ppc"
-DEPEND="virtual/libc
- sys-devel/gcc"
-
src_compile() {
epatch ${FILESDIR}/${P}-gentoo.diff
epatch ${FILESDIR}/${P}-uint.patch
diff --git a/media-sound/toolame/toolame-02l-r2.ebuild b/media-sound/toolame/toolame-02l-r2.ebuild
index 2d37a0f749f6..7415dbb3201c 100644
--- a/media-sound/toolame/toolame-02l-r2.ebuild
+++ b/media-sound/toolame/toolame-02l-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/toolame/toolame-02l-r2.ebuild,v 1.1 2005/08/25 12:21:58 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/toolame/toolame-02l-r2.ebuild,v 1.2 2006/03/07 16:05:23 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -14,21 +14,17 @@ SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-DEPEND="virtual/libc
- sys-devel/gcc"
-
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.diff
- epatch ${FILESDIR}/${P}-uint.patch
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+ epatch "${FILESDIR}/${P}-uint.patch"
}
src_compile() {
# Enable largefile support, as toolame doesn't use autoconf
- ( use elibc_glibc || use elibc_uclibc ) && \
- append-flags "-D_FILE_OFFSET_BITS=64"
+ append-lfs-flags
tc-export CC
diff --git a/media-sound/toolame/toolame-02l.ebuild b/media-sound/toolame/toolame-02l.ebuild
index 89d7e49e40b2..c34e5c956f19 100644
--- a/media-sound/toolame/toolame-02l.ebuild
+++ b/media-sound/toolame/toolame-02l.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/toolame/toolame-02l.ebuild,v 1.15 2005/08/24 16:15:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/toolame/toolame-02l.ebuild,v 1.16 2006/03/07 16:05:23 flameeyes Exp $
IUSE=""
@@ -14,9 +14,6 @@ SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="amd64 ppc ~sparc x86"
-DEPEND="virtual/libc
- sys-devel/gcc"
-
src_compile() {
epatch ${FILESDIR}/${P}-gentoo.diff
emake || die