summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-22 20:11:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-22 20:11:30 +0000
commit92128c8289ff933c6ae56acf9cfaa2657fe1162c (patch)
treec51e734575ab72d3a92e93195644295c44a7ec08 /media-sound/trommler/trommler-3.8.ebuild
parentFix make breakage bug #333461, also allow user to apply conditional patches b... (diff)
downloadgentoo-2-92128c8289ff933c6ae56acf9cfaa2657fe1162c.tar.gz
gentoo-2-92128c8289ff933c6ae56acf9cfaa2657fe1162c.tar.bz2
gentoo-2-92128c8289ff933c6ae56acf9cfaa2657fe1162c.zip
Respect LDFLAGS wrt #333741.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/trommler/trommler-3.8.ebuild')
-rw-r--r--media-sound/trommler/trommler-3.8.ebuild34
1 files changed, 21 insertions, 13 deletions
diff --git a/media-sound/trommler/trommler-3.8.ebuild b/media-sound/trommler/trommler-3.8.ebuild
index d29fcd813ab8..12d6c5841adc 100644
--- a/media-sound/trommler/trommler-3.8.ebuild
+++ b/media-sound/trommler/trommler-3.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/trommler/trommler-3.8.ebuild,v 1.6 2009/06/16 18:48:40 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/trommler/trommler-3.8.ebuild,v 1.7 2010/08/22 20:11:30 ssuominen Exp $
EAPI=2
inherit eutils toolchain-funcs
@@ -22,25 +22,33 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN/t/T}
+src_prepare() {
+ sed -i \
+ -e 's:$(CC):$(CC) $(LDFLAGS):' \
+ Makefile || die
+}
+
src_compile() {
- emake export.h || die "emake export.h failed"
- emake CFLAGS="${CFLAGS} $(pkg-config --cflags gtk+-2.0)" \
- CC="$(tc-getCC)" || die "emake failed"
+ tc-export CC
+ emake export.h || die
+ emake CFLAGS="${CFLAGS} -Wall $(pkg-config --cflags gtk+-2.0)" || die
}
src_install() {
exeinto /usr/libexec
- doexe ${PN} || die "doexe failed"
- newbin "${FILESDIR}"/${PN}.wrapper ${PN} || die "newbin failed"
- dobin wav2smp playsample || die "dobin failed"
- if use sox; then
- dobin smp2wav || die "dobin failed"
- fi
+ doexe ${PN} || die
+
+ newbin "${FILESDIR}"/${PN}.wrapper ${PN} || die
+ dobin wav2smp playsample || die
+ use sox && { dobin smp2wav || die; }
+
insinto /usr/share/${PN}/Drums
- doins Drums/*.smp || die "doins failed"
+ doins Drums/*.smp || die
insinto /usr/share/${PN}/Songs
- doins Songs/*.sng || die "doins failed"
+ doins Songs/*.sng || die
+
dodoc CHANGES README
dohtml index.html style.css
+
make_desktop_entry ${PN} Trommler
}