summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2013-08-21 01:21:08 +0000
committerJoe Sapp <nixphoeni@gentoo.org>2013-08-21 01:21:08 +0000
commit1974c4b63e4b65d10cbbc51fe00abfb3d76780b5 (patch)
treea8196e6d08285a96bd6e7e68527402fbed438602 /media-sound/xwax
parentAutomated update. (diff)
downloadgentoo-2-1974c4b63e4b65d10cbbc51fe00abfb3d76780b5.tar.gz
gentoo-2-1974c4b63e4b65d10cbbc51fe00abfb3d76780b5.tar.bz2
gentoo-2-1974c4b63e4b65d10cbbc51fe00abfb3d76780b5.zip
Version bump; remove mpg321 support
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 40D7E463)
Diffstat (limited to 'media-sound/xwax')
-rw-r--r--media-sound/xwax/ChangeLog8
-rw-r--r--media-sound/xwax/xwax-1.4.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/media-sound/xwax/ChangeLog b/media-sound/xwax/ChangeLog
index 55e0bfeb68cb..f19edc83fedf 100644
--- a/media-sound/xwax/ChangeLog
+++ b/media-sound/xwax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/xwax
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/ChangeLog,v 1.52 2013/06/16 09:36:03 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/ChangeLog,v 1.53 2013/08/21 01:21:08 nixphoeni Exp $
+
+*xwax-1.4 (21 Aug 2013)
+
+ 21 Aug 2013; Joe Sapp <nixphoeni@gentoo.org> +xwax-1.4.ebuild:
+ Version bump; remove mpg321 support since it doesn't seem to support a rate
+ conversion required in xwax-import
16 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due #79409
diff --git a/media-sound/xwax/xwax-1.4.ebuild b/media-sound/xwax/xwax-1.4.ebuild
new file mode 100644
index 000000000000..e544f39f4b57
--- /dev/null
+++ b/media-sound/xwax/xwax-1.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/xwax-1.4.ebuild,v 1.1 2013/08/21 01:21:08 nixphoeni Exp $
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Digital vinyl emulation software"
+HOMEPAGE="http://www.xwax.co.uk/"
+SRC_URI="http://www.xwax.co.uk/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="alsa jack oss cdda mp3 +fallback"
+REQUIRED_USE="|| ( cdda mp3 fallback )
+ || ( alsa jack oss )"
+
+RDEPEND="sys-libs/glibc
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ media-fonts/dejavu
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ cdda? ( media-sound/cdparanoia )
+ mp3? ( media-sound/mpg123 )
+ fallback? ( virtual/ffmpeg )"
+DEPEND="${RDEPEND}"
+
+DOCS="README CHANGES"
+
+src_prepare() {
+ # Remove the forced optimization from 'CFLAGS' and 'LDFLAGS' in
+ # the Makefile
+ # Also remove the dependency on the .version target so we don't need
+ # git just to build
+ sed -i -e 's/\(^\(LD\|C\)FLAGS.*\)-O[0-9]\(.*\)/\1\3/g' \
+ -e 's/^xwax\.o:.*\.version//' \
+ Makefile || die "sed failed"
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ --prefix "${EROOT}usr" \
+ $(use_enable alsa) \
+ $(use_enable jack) \
+ $(use_enable oss)
+}
+
+src_compile() {
+ # EXECDIR is the default directory in which xwax will look for
+ # the 'xwax-import' and 'xwax-scan' scripts
+ emake EXECDIR="\$(BINDIR)" VERSION="${PV}" xwax
+}
+
+src_install() {
+ # This is easier than setting all the environment variables
+ # needed, running the sed script required to get the man directory
+ # correct, and removing the GPL-2 after a 'make install' run
+ dobin xwax || die "failed to install xwax"
+ newbin scan xwax-scan || die "failed to install xwax-scan"
+ newbin import xwax-import || die "failed to install xwax-import"
+ doman xwax.1 || die "failed to install man page"
+
+ dodoc ${DOCS} || die "failed to install docs"
+}