summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-02-12 11:19:04 +0000
committerPacho Ramos <pacho@gentoo.org>2015-02-12 11:19:04 +0000
commit297fb2716a86a413b74a8cd2442ecfe186b9fc5a (patch)
tree60e3e4dd1a694ce1ea9a9937dd3596b6be13de3c /media-sound
parentamd64 stable, bug #526054 (diff)
downloadgentoo-2-297fb2716a86a413b74a8cd2442ecfe186b9fc5a.tar.gz
gentoo-2-297fb2716a86a413b74a8cd2442ecfe186b9fc5a.tar.bz2
gentoo-2-297fb2716a86a413b74a8cd2442ecfe186b9fc5a.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/soundconverter/ChangeLog7
-rw-r--r--media-sound/soundconverter/soundconverter-2.1.5.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/media-sound/soundconverter/ChangeLog b/media-sound/soundconverter/ChangeLog
index 5886fd9529ff..0494aa4dc437 100644
--- a/media-sound/soundconverter/ChangeLog
+++ b/media-sound/soundconverter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/soundconverter
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/soundconverter/ChangeLog,v 1.37 2015/02/03 20:24:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/soundconverter/ChangeLog,v 1.38 2015/02/12 11:19:04 pacho Exp $
+
+*soundconverter-2.1.5 (12 Feb 2015)
+
+ 12 Feb 2015; Pacho Ramos <pacho@gentoo.org> +soundconverter-2.1.5.ebuild:
+ Version bump
*soundconverter-2.1.4 (03 Feb 2015)
diff --git a/media-sound/soundconverter/soundconverter-2.1.5.ebuild b/media-sound/soundconverter/soundconverter-2.1.5.ebuild
new file mode 100644
index 000000000000..48164048b824
--- /dev/null
+++ b/media-sound/soundconverter/soundconverter-2.1.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/soundconverter/soundconverter-2.1.5.ebuild,v 1.1 2015/02/12 11:19:04 pacho Exp $
+
+EAPI=5
+GCONF_DEBUG=no
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 multilib python-single-r1
+
+DESCRIPTION="A simple audiofile converter application for the GNOME environment"
+HOMEPAGE="http://soundconverter.org/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="aac flac mp3 opus vorbis"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/gconf-python[${PYTHON_USEDEP}]
+ dev-python/gnome-vfs-python[${PYTHON_USEDEP}]
+ dev-python/gst-python:0.10[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.12[${PYTHON_USEDEP}]
+ dev-python/libgnome-python[${PYTHON_USEDEP}]
+ gnome-base/libglade[${PYTHON_USEDEP}]
+ aac? (
+ media-plugins/gst-plugins-faac:0.10
+ media-plugins/gst-plugins-faad:0.10 )
+ flac? ( media-plugins/gst-plugins-flac:0.10 )
+ mp3? (
+ media-plugins/gst-plugins-lame:0.10
+ media-plugins/gst-plugins-mad:0.10
+ media-plugins/gst-plugins-taglib:0.10 )
+ vorbis? (
+ media-plugins/gst-plugins-ogg:0.10
+ media-plugins/gst-plugins-vorbis:0.10 )
+ opus? ( media-plugins/gst-plugins-opus:0.10 )
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_prepare() {
+ python_fix_shebang .
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize "${ED%/}"/usr/$(get_libdir)/soundconverter/python
+}