summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2011-04-20 11:48:44 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2011-04-20 11:48:44 +0000
commit3a680417ee593058a434c73173070a37cd13480c (patch)
tree9e62d81349f9cf6546a8c12358c3afddc59e837b /media-sound
parent[bump] dev-perl/Params-Util-1.40.0 (diff)
downloadgentoo-2-3a680417ee593058a434c73173070a37cd13480c.tar.gz
gentoo-2-3a680417ee593058a434c73173070a37cd13480c.tar.bz2
gentoo-2-3a680417ee593058a434c73173070a37cd13480c.zip
Added upstream patch to fix the plugin detection at startup.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog6
-rw-r--r--media-sound/amarok/amarok-2.4.0.90.ebuild9
-rw-r--r--media-sound/amarok/files/amarok-2.4.0.90-fix-plugin-detection.patch19
3 files changed, 31 insertions, 3 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index a851561602b2..365314c14e10 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.401 2011/04/20 05:05:10 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.402 2011/04/20 11:48:44 jmbsvicetto Exp $
+
+ 20 Apr 2011; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ amarok-2.4.0.90.ebuild, +files/amarok-2.4.0.90-fix-plugin-detection.patch:
+ Added upstream patch to fix the plugin detection at startup.
20 Apr 2011; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
files/amarok-2.4.0.90-fix-upnp-dep.patch:
diff --git a/media-sound/amarok/amarok-2.4.0.90.ebuild b/media-sound/amarok/amarok-2.4.0.90.ebuild
index 6440f8e61b7e..f1cd484a84fb 100644
--- a/media-sound/amarok/amarok-2.4.0.90.ebuild
+++ b/media-sound/amarok/amarok-2.4.0.90.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.4.0.90.ebuild,v 1.1 2011/04/19 02:40:12 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.4.0.90.ebuild,v 1.2 2011/04/20 11:48:44 jmbsvicetto Exp $
EAPI="3"
@@ -82,7 +82,12 @@ RDEPEND="${COMMONDEPEND}
player? ( $(add_kdebase_dep phonon-kde) )
"
-PATCHES=( "${FILESDIR}/${P}-fix-upnp-dep.patch" )
+# Upstream patch to fix the plugin detection on startup
+# https://projects.kde.org/projects/extragear/multimedia/amarok/repository/revisions/37eda947bd8181a73ad0fffc88e66c25ddd69f28
+PATCHES=(
+ "${FILESDIR}/${P}-fix-upnp-dep.patch"
+ "${FILESDIR}/${P}-fix-plugin-detection.patch"
+)
src_prepare() {
if ! use player; then
diff --git a/media-sound/amarok/files/amarok-2.4.0.90-fix-plugin-detection.patch b/media-sound/amarok/files/amarok-2.4.0.90-fix-plugin-detection.patch
new file mode 100644
index 000000000000..d075ba048601
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.4.0.90-fix-plugin-detection.patch
@@ -0,0 +1,19 @@
+commit 37eda947bd8181a73ad0fffc88e66c25ddd69f28
+Author: Rick W. Chen <stuffcorpse@archlinux.us>
+Date: Thu Mar 17 18:38:19 2011 +1300
+
+ Fix plugin loading and bump_plugin_version.rb script
+
+diff --git a/src/PluginManager.cpp b/src/PluginManager.cpp
+index ff52646..1e34510 100644
+--- a/src/PluginManager.cpp
++++ b/src/PluginManager.cpp
+@@ -32,7 +32,7 @@
+ #include <QFile>
+ #include <QMetaEnum>
+
+-const int Plugins::PluginManager::s_pluginFrameworkVersion = 60;
++const int Plugins::PluginManager::s_pluginFrameworkVersion = 61;
+ Plugins::PluginManager* Plugins::PluginManager::s_instance = 0;
+
+ Plugins::PluginManager*